Shader preparation on each login

From the last couple of days (but at least a full week by now) I get Shader preparation on each new login, no matter whether I've checked "shader preparation on startup" or not. This only seems to happen after a fresh reboot of my PC. I didn't change any hardware or OS recently, but somehow I suspect there's something odd with my machine's USB ports. Switching my devices to other ports doesn't fix it.

Any idea what could cause this strange behaviour?

Edit:

Attention, thread topic was a mistake! It's not the shaders, but Preparing Planet Generation System. Sorry for any confusion...
 
Last edited:
Pretty sure mine has always done it whether I had the option checked or not, shrugged and gave up worrying about it as it only takes a couple of seconds
 
AFAIK the 'long' preparing shaders should only happen if you update graphics drivers (or change your graphics card) or if the game updates.

Perhaps your GPU drivers are corrupt, so perhaps re-install your graphics driver and see whether that prevents it happening after the first startup?
 
I thought it's only graphics drivers changes that do it, maybe somethings gone wrong with a graphics driver update.

(ninja'd!)
 
Thanks for your answers so far, but I can say with confidence that nothing of that is the case. And yes, I know how and when it should work (which it did until recently). My gfx (nvidia) drivers are always up to date and I always use the fresh install option.
 
Correction:
Just re-checked and meanwhile it also occurs without rebooting my PC. I already considered a corrupt SSD but in this case I certainly would have other, way more serious problems.
 
Another update:

This strange behaviour doesn't occur on my steam account and since this is a separate install that's good news for now: Can't be a hardware problem as I first suspected. I've tried validate game files from the launcher but without success. This looks like there might be a cache corrupted. But where could it possibly be? I have also checked Enable Cache Check and Enable Virtual Cache in the launcher. What do you think, could either of this be the culprit?

edit:
No, it can't. Check boxes on both launchers are identical.

Attention!
The thread topic was a mistake! It's not the shaders, but Preparing Planet Generation System. Sorry for any confusion...
 
Got it!

It was the GpuWorkTable.xml in the elite-dangerous-64 folder. I renamed it to GpuWorkTable.xml_bac and restarted. Now all issues are gone.

I'm still a bit confused as the newly generated file must have overwritten the one with the_bac ending - which is gone.
How is this even possible?
 
are you sure it's the shader preparation? might be the planet generation system. that happens each gamestart and cannot be disabled afaik.

You had the right idea, meanwhile I edited the OP (can't edit the topic anymore). But you are right, I can't totally suppress that generation, but now it's loading super fast again, a matter of one or two seconds at worst - as it always was the case. And not almost a minute.

That was a strange adventure, but I'm glad I could finally fix it! :D
 
Last edited:
Top Bottom