• Good news Guest, we've updated our reporting system to make it easier for you to report issues to us!

    Head over to https://issues.frontierstore.net/ to report, vote, and give feedback on the issues that matter most to you!

Still no frame rate improvements on high end cards. (video included)

Severity
Severe

Frequency
All of the time (100% reproducible)

Area of Game Affected
Performance

Description
Come on guys this is beginning to become a joke.
You have changed something in the code on the first update which has severely limited the frame rate performance for high end graphics cards (980, 1070, 1080 for example) The game never ran so choppy before 1.0.1. Everything is laggy and takes time to load from the menu, to picking rides etc
Please watch the video attached.

I'm not one to be pushy with developers about bug fixes because I know it takes time but I've payed full price for a game that I expect to work on my high end system. And now I'm getting frustrated because I haven't been playing PC untill this issue is fixed.

<iframe width="560" height="315" src="https://www.youtube.com/embed/o1VYzF06dAE" frameborder="0" allowfullscreen></iframe>


- I understand this may be an issue with Nvidia
- Yes my card if in the 16 x pci slot
- yes i've updated and rollbacked drivers
- Yes my specs exceed the recommended
i7 6700k
Asus ROG N1070
16gb dd4 ram

Thanks


Steps to Reproduce
https://youtu.be/o1VYzF06dAE
 

Animator-Jonny

Frontier Animator
Please could we invite the player to try the following:

Ensure you have the most up-to-date BIOS and chipset drivers.
• These drivers will be available on the manufacturers’ website.
• Download and install these updates at your leisure.
• This will improve system stability and performance.

Perform a clean reinstallation of your graphics card drivers.

For NVIDIA hardware:
• Navigate to www.geforce.com
• Click ‘Drivers’
• Fill out the information for your graphics card
• Download and run the driver installer
• Ensure you select Perform a clean installation

For AMD hardware:

• Download and run the AMD Clean Uninstall Utility (http://support.amd.com/en-us/kb-articles/Pages/AMD-Clean-Uninstall-Utility.aspx)
• Navigate to http://support.amd.com/en-us/download
• Download and run the AMD Driver Autodetect Utility
• Run the driver installation program
Scan for and eliminate file system errors.

• Right-click on your Windows Start Menu
• Select ‘Command Prompt’
• Write the command sfc /scannow and press Enter
• Wait for the check to complete

Scan for and eliminate memory errors.
• Open your Windows Start Menu
• Search for Windows Memory Diagnostic
• Run this program.
• Your computer will restart and check for errors
 
I've tried all these solutions and nothing has helped.
Dont bother... I have the same problem as you (as well as a lot of people with those cards) and they wont solve it. I oppened a ticket with my problem and after a few emails they told me the solution: your graphics card is broken. Buy a new one... Unbelivable... And of course, my graphics card (1070) is not broken because, you know, have more games and those games run amazingly with this card at max settings. And NEW games. Sorry to tell you this but we cant play this game. You just have to read the solution they told me....
 
Last edited:
For what it's worth I have a GTX980Ti and have tried the above, yet once i've built out about a quarter of my park my frame rate falls below 10fps constantly. I turned all my settings to LOW and it barely made a difference (still below 10fps).. Occasionally i'm getting 1 or 2fps, while the average is about 6 - on LOW settings, on a GTX980Ti..

The game is ok when you first start an empty park, it runs smoothly, but once i've built about 15 rides the fps falls off a cliff. I'm playing other top end 2015/2016 games at ultra and they run perfectly fine (as i'd expect for my GC), but Planet Coaster is the only game that i'm getting unplayable frame rates.. Definitely not the card here.. Something is very wrong.
 
Dear Developers,

I have also this Problems now. Now the FPS are somewhere between 14 and 18 FPS. I remember at Rollercoaster Tycoon 3. In the end I had built a beautifully great Park but the FPS where somewhere between 4 and 8 FPS. That was the reason I stopped playing the game. You have programmed such a fantastic game and we want to use all the possibilities the game have but at the moment I think this will stay a wishful thinking. By the way I also have a PC with

i7 6700
32GB RAM
GTX 1080

Please improve the game related to the FPS. We don't want to have such problems. Up to yesterday I was really satisfied with the game (Irrespective of the completion of the ride signs I'm still waiting for). But at the moment Frustration had been started to exchange my enthusiasm. At the Moment I realize that I can't built the park of my dreams because of those problems.

Best regards
Michael
 
Hi all,

same here. Im using a Asus Strix GTX 1070 8G, I7 6700k, latest driver, bios etc. My FPS are around 60-80 but when i navigate around the map it drops down into the low 20's. My park has below 1000 visitors and just a few rides + a bit scenery. I play on high settings with 1200p. I do not experience so heavy Frame dops while playing other games like (CIV 6, CitiesSkylines, bf1).

Is there a Performance patch planned?

Best regards,
Seltenes
 
I'm getting a solid 30fps in 4K on in i7 6850 and a 1080 founders using the Steam FPS counter - everything maxed. Then again, I'm getting the same thing with the game paused. Hmm.

Anyway, the last time I loaded nvidia's experience sw, it started a shadowplay process running in the background that was always capturing video. That did a number on my framerate. I'm sure that only happened to me, however.

Robert
 
Last edited:
I sadly have to agree with the original post. My computer simply doesn't struggle to run other games but this game I can't get above medium settings. Have tried all sorts to sort this out.
By limiting the game in this way Frontier, you're actually making it harder for people to play your game and it will turn people off if they cannot play even with a system like the ones mentioned in this post. Its even harder here knowing my system should not be running into any problems with any games at the moment but Planet Coaster is extremely demanding even for the higher end machines. Hopefully we can see some improvements very soon...

Specs:
i7 6700
GTX 1080
16gb Ram
 
Bought a 1070 Hybrid to help but it does nothing to fix the issue.

Are we just stuck with poor program optimization and left to "Deal with it"???
 
This is just stupid though, I open a new sandbox map and the game freaks out. I go to zoom in and out on certain objects and the frame rate dips then goes back up. It's just inconsistent!. They can't make excuses for engine and optimization issues because Cities Skylines (even being coded in Unity) performs at a full 60fps for me with maxed graphics and a huge city. And just think of how much more sophisticated the simulation system is in that game. As far as I can tell this game has been rushed for release with an unacceptable beta period...
 
I have an i6700, 16 GB RAM, and a GTX 1080 and my build runs flawlessly (everything turned up as high as it can go, 40+ FPS nearly all the time). So unfortunately, it's not an NVIDIA interface issue. There must be some hidden bug that is only surfacing with certain configurations. Good luck on this one, because you guys are right, something is up.
 
This is just stupid though, I open a new sandbox map and the game freaks out. I go to zoom in and out on certain objects and the frame rate dips then goes back up. It's just inconsistent!. They can't make excuses for engine and optimization issues because Cities Skylines (even being coded in Unity) performs at a full 60fps for me with maxed graphics and a huge city. And just think of how much more sophisticated the simulation system is in that game. As far as I can tell this game has been rushed for release with an unacceptable beta period...
This is exactly what i've been seeing. I cant say if its because of a crowded area, ride or even a scenery. BTW, i have tried a few older NVIDA Driver without any possible impact on the performance. Im looking forward to see patch which address the issues described here.
 
This is outrageous. We have spent our money in a game we CANNOT play, even though we have systems to play at MAX settings without problem (according to them).

Misleading advertising??????
 
Last edited:
Yeah! 74.99$ US for a game that don't get me more thant 10 FPS....The Alpha was a better time... [cry]
 
Last edited:
Also running a 1070 on an i7 here... there was a new Nvidia driver yesterday that seemed to fix the weird kind of stuttering issue. I have had great performance today.
 
For what it's worth I have a GTX980Ti and have tried the above, yet once i've built out about a quarter of my park my frame rate falls below 10fps constantly. I turned all my settings to LOW and it barely made a difference (still below 10fps).. Occasionally i'm getting 1 or 2fps, while the average is about 6 - on LOW settings, on a GTX980Ti..

The game is ok when you first start an empty park, it runs smoothly, but once i've built about 15 rides the fps falls off a cliff. I'm playing other top end 2015/2016 games at ultra and they run perfectly fine (as i'd expect for my GC), but Planet Coaster is the only game that i'm getting unplayable frame rates.. Definitely not the card here.. Something is very wrong.
Yeah, I posted about this in several places here on the bug forum and no useful response from a Dev. I have a 980ti and get the exact same issue, as the park gets larger your FPS tanks. I have a park with 7,000 peeps about two dozens rides and my FPS hangs between 15-22, if I speed up the simulation I get 10 or less. As much as I love the game I stopped playing recently as it's not enjoyable with the FPS and queue problems. Kinda gave up getting help from them here on the forum. Disappointing.
 
Last edited:
GIGABYTE GeForce GTX 1050 Ti Windforce OC 4GB (GV-N105TWF2OC-4GD) with AM3+ 4320 - same here!
It's not really bother me, but it's a problem which has to be fixed! [knockout]
My System is more than just uptodate and it is in super good condition. I.e. Fallout 4 runs beautiful smooth.
Sorry for my bad English!!!

Best regards, KitKat
 
They dont seem to realize that there is a FPS problem in GTX 10X0 cards... Almost all the users with FPS problems have these cards. I understand that there are more problems they have to solve... But they MUST focus on the problems that hinder the players TO PLAY. Yes, people get stuck in the park, problems with queues.... but you STILL can play. We CANT.... Its the first time I see a company ignore the people that cant play their game in such a way. Even though we paid to play it... I feel cheated....
 
Last edited:
Top