Strange X52 pro problem.

This is an odd one. The "B" button (the middle lit one) on the throttle only seems to work when the throttle is below roughly 50%.

Anyone else come across this or can offer an explanation?

Cheers.
 
That is button D on my X52 Pro - The B button is on the joystick - there is also a madcatz application you can get for things such as setting up deadzones and changing light colours etc.
My button D is set to reverse the thrust of the engines, bound by ED default X52 pro bindings
Hope this is of some use.
 
Check it in device config. If it works there then it's probably an ED issue. If it doesn't work there then it's probably a stick issue.
 
Yup, another X52/ED problem. I've had the slider and the lateral thrusters hat go the same way, where they only worked if the throttle was above 50%, the thrusters now seem to be working OK, but the slider now doesn't work at all along with some of the other buttons that come and go depending on how you set them.

I took mine apart to see if there was a loose connector or dodgy wire, but everything seemed good inside.
 
if you have one try a mains powered usb hub (assuming bindings in game are backed up previously checked and unchanged)
some mobos have extremely low voltage milli amp output capacity to usb even though your PSU is of the 10 gigawatt mutts nutts range (FRAKING IDIOT MOBO DESIGNERS OR SUMTHING)
resulting in volts drop across your device
so you will need to rule that out if you can
so why all of a sudden now?
controller contacts oxidise over time and increase resistance to the point of joy ghosting inputs and things not working as they should symptom
I am not saying that's def the cause but it is worth trying to rule out b4 buying new or changing pots etc
if the device has lights try disabling them if performance increases slightly that will be a clue its volts drop related
also try unplugging any currently unused usb devices off the 5v rail and set pc power settings to high performance
 
Last edited:
Had a previous one, which worked fine for years until it finally gave up the ghost, so I'm sure it isn't a power problem. This new one is only a few months old, so I don't want to think it's hardware related.

I know it can get a bit picky depending on whether you're running the X53 pro software, so I'll carry on playing about with it for the meantime.

I'll try disabling the lights, though.

[EDIT]

Ok, pretty sure it's a software problem. If I load the X52 software (no loaded profile) and select the "programming" tab, It works when on minimum throttle (in control panel/devices and printers). Close the X52 software and it stops altogether. 🤷‍♂️
 
Last edited:
not that I own an x52 but isn't there some sort of clutch control in the properties of the device when looked at in cntl panel dev an print
I recall from someware(redit I think) may wanna check that it it does in fact exist
 
Since the Odyssey update I have 3 binds on the X55 Rhino giving out ghost commands. I can't fix it. I have even bought a new powered usb hub that can supply 7W of power to the throttle. But it still happens.
I get anything from random boosts, cargo hatch opening or landing gear descending.

I also play Star Citizen and I have no problems with ghosting in that game, so I know it is ED related.
 
Top Bottom