Hardware & Technical The black just got blacker - Full RGB

The black just got blacker for me across the board with a simple display tweak.

I ran across an article on How To Geek about if your monitor is connected via an HDMI cable you may not be getting Full RGB colors. I did the tweak and sure enough, the black does not seem washed out at all and now looks fully black. It really did make a difference.

I thought I would pass this along so others might benefit from this.

https://www.howtogeek.com/285277/how-to-avoid-washed-out-colors-when-using-hdmi-on-your-pc/


See you in the blackest of black! :D
 
Heh, perfect timing. [up]

Always known how to do this with AMD GFX cards but just been playing with an NVidia card tonight and that was the last little thing that was bugging me.
 
Yeah, it makes a huge difference. I had no idea that there was a "semi-hidden" setting in the NVidia control panel to fix this, until a friend pointed it out to me, a couple of years ago.
 
Useful thanks, although I recently fixed my shades-of-grey issues by moving from a 24" TN (DVI-D) display to a 27" IPS (Display Port).

Fan-flipping-tastic, with no drop in FPS despite increased resolution!

Worth every penny!!
 
I'm glad I'm not the only one who didn't know about this.

I like to go and peek at different hardware and software settings (especially advanced ones) to see all the options and sometimes change them to my liking but right clicking my desktop to change graphics settings never occurred to me. I figured the main GPU settings took care of everything.

Boy was I wrong.
 
I've been disappointed with a new monitor purchase for a few months now, turns out it looks awesome. Thanks for info, like a whole new game now.
 
It's worth pointing out here that Win 10 updates have a tendency to reset graphic driver settings so you have to re-enable full RGB. That's with nVidia, not sure about AMD. Couldn't work out what the hell was up the first time this happened until I googled why graphics suddenly looked so much worse.
 
Last edited:
I have this with my oculus and a GTX980, it appears to be set to limited, tried lots of different methods to get it on full but, appears not to want to take it.
 
Note that the panel you use, has to support the full gamut provided by RGB. Many (particularly newer) TN panels will cope, some certainly will not. Older/ cheap TN panels often don't. IPS panels typically will provide a massive improvement due to the technology better representing colours and the full RGB space is one of their biggest advantages.

If there is ever a reason to get an IPS panel, Elite is surely one of the good ones.
 
Goodness, mine was on default of 8, and limited, so I switched it to full and noticed the difference on my desktop.

I am going to go try out ED in VR and check it out.

Thank you.

Will post my results.
 
Well that was awesome!... I was on limited too, I had no idea, it looks great now. One tip... at least for me, when I changed it to full somehow it also reduced my refresh rate to 4k at 30hz, so I was baffled for a while that my fps dropped to below 30until I found that.
 
I misunderstood the 8, but it is on full now, and I just went and made 1.6 mil bounty hunting, and the visuals were amazing.

I especially love how much brighter the e
explosions are against a darker space.

Thank you.

Surely it made a difference in my Oculus Rift also, or might that be Dadburn it! Just had the word in my head.

A placebo effect, could it be that in VR?

My screen is darker for sure.
 
Last edited:
BTW console users might also check this in their system settings. On Playstation it's located under Home > Settings > Sound and Screen > Video Output Settings > RGB Range. You should also check the corresponding setting on your TV, provided the mode is supported (usually found under something like "HDMI black level"). The PS's standard setting is set to "Automatic" which just uses what ever is set on the TV. Set it to "low" and/or "full" respectively on both sides to enforce full RGB mode.
 
It's a very old and well known issue which also affects VR (and has led some people to buy an HDMI to DisplayPort converter to connect their headset in order to get around it) but thanks for posting a timely reminder as there's clearly a whole new generation of gamers who were completely unaware of the issue. Switching to Full dynamic range makes a MASSIVE difference, not just to ED but to your Windows desktop in general (especially noticeable if you're using beautiful ED images for your desktop background).
 
Top Bottom