The Star Citizen Thread V10

Just played Star Citizen for the first time since 3.1

From 5:30pm to 12:00am, my buddy and I decided to give 3.6 a try to see what's new since we last played (3.1).
We hadn't played in such a long time because we wanted to make a return when we felt that there was enough content to keep us busy for at least a few days.
When it was a thing (R.I.P.), we would watch ATV and RTV every single week and discuss all the cool new content over the occasional dinner or carpool to a movie. It was always exciting to see all the new stuff in the pipeline and all the new gameplay features being added regularly.

However, what happened tonight was really disheartening -it somehow felt like a step backwards from the last time we had played. We've waited well over a year and the game, while still in Alpha, just doesn't feel like it's moved forward at all. It seems like a lot of the stuff that used to work was now broken. With today's experience behind us, we're definitely going to wait much longer before we consider making a return and that really sucks to say.

After roughly 50 ATV videos worth of content since we last played, I don't think we got to see any of the new content in a positive light today. Right now, while an incredibly talented team of over 500 people work endlessly to add more content to the universe, the current content we have isn't flushed out and lacks any form of polish. Now, I'm no stranger to game development so it know that the polish phase isn't until Beta but when stuff that used to work well (or even halfway-decent) stops working entirely(or at random) and all the new stuff isn't working well either, it starts to feel like bunch of unique concepts are being held together with duct-tape.
I think it would really benefit CIG, and their community as a whole, if they stepped back and spent a solid month or two fixing all the game-breaking bugs that are preventing players like us from having fun. The game, in its current state, isn't something that I would be proud to share with a new friend(like it once was) and it doesn't have a strong foundation for their team to build upon. It's also something I would be incredibly embarrassed to hear being made available to outsiders for a Free Flight weekend -what a horrible first impression it would be.
CIG, I love what this could ultimately become but I cannot help but feel that it's a hot-mess at the moment. Why are there so many bugs that aren't being patched out? Why is this new patch breaking stuff that used to work just fine? Why do you have Evocati and bug reports if 3.6 is released in an unpleasant state like this? It such a beautiful mess right now. Ugh.

For anyone curious, here is our experience today. Unfortunately, there is just not enough time to write up all the bug reports needed to tackle the issues faced in our session today. I just hope they fix them.

Initial impressions:
  • Character creation is still extremely limited and not quite as good as EVE Online's yet. I still find this really odd considering that EVE has the best character creation system for absolutely no reason. w/e, moving on.
  • Why do the females have dude haircut options only? No red, blue, purple hair colors... not a big deal, maybe we can find a stylist in-game, moving on.
  • Game loads a lot faster, wow, that's a huge plus.
  • Game seems to run a lot better too, very smooth, no hitching or stuttering anymore.
  • Getting 60-90fps at 3440x1440 on Ultra, no complaints there, well done!
Then it became clear than this game is going to remain in Alpha for a very long time
We both spawn in our habs to a constantly shaking screen(it was jarring, like being slapped on the back of the head over and over) and constant blasts of ...some sort of weaponry(?)
Was Olisar station under attack from pirates? Bad NPCs? Was there a quest to save the station? No. hmmm, odd. No red lights, or smoke, or alarms/ must not be something important I guess...
None of the NPCs seem to care. The one and only security looking dude is just slowly walking into the side of a vending machine, face first. That answer's that, clearly the NPC AI clearly hasn't improved.
Eventually, we realized this was just the "new" law system attempting to shoot at some far away hostile ship millions of miles into the abyss, constantly, but we didn't know that yet...
Before we realized what it was, we had to figure out how to form a group.
7 minutes later, no joke, sifting through a Mobiglass interface that was needlessly confusing, we finally found a way to join forces.
We ran downstairs and decided to take out a Retaliator and leave this shaking nonsense as quickly as possible, at least that was the plan.
He spawns the ship, we walk to it, already sick of the shaking screen, we get inside, and then the ship starts to get fired upon by a hostile player griefing the area.
The "Olisar Law system" doesn't recognize him. Nope. It's too busy firing at that same ship, the one that is millions of miles in a completely different direction.
By the time we find our seats, ready flight mode, lift off, and started to advance from the station our ship gets blown up by some ole. w/e, that's that nature of a PVP title.
Rinse + repeat, we decided to summon an FC7-M instead so we could take off sooner if needed.
We walk through the loud explosions and shakiness, and get into the ship without any drama this time. Not a hostile player to be found, he must've logged, great!
...the Law system is still firing off it's weapons into nothingness...
Taking off was a little stuttery/glitchy, like the landing gear was slightly struck in the landing pads, but flying away from Olisar was pretty smooth.
Wait, why did the cockpit canopy just open? ...then close ...then open again. The canopy has a mind of it's own now but were in space suits so whatever...
We fly away from Port Olisar.
Finally, no more screen shaking!

Quantum jump time... ugh. What in the hell is this new system? It used to work so well.
This is the first major source of frustration that we had and it really soured the rest of the experience.
Worse yet, during any Free Flight, this is one of the first miserable experiences any new player would have to deal with and it sucked... a lot.
Pressed F2 to bring up the Mobi, zoomed out to select Hurston as the jump point. Zoomed into the planet to try and select a specific location and then the planet completely disappears from view.
Zoomed out, found the planet, zoomed back in and it's gone again...wth?
Pressed F2 to leave. Pressed F2 to enter, zoomed out, found Hurston again. Clicked on it, clicked to set waypoint. Verified with the long solid green line appeared on the map.
Pressed F2, pressed "B" attempted to spool, map showed Crusader as the waypoint for some reason but even then it was obstructed -maybe because we're still within earshot to Olisar? No Hurston target available anywhere...
Rinse and repeat the same process until it eventually selected Hurston but for some reason, we could see several other jump points but everything was obstructed.
Pressing B a bunch of times in frustration and then stopped, now we can see nearly every single destination in the galaxy, like at least 50 of them cluttering up the hud, flashing on and off, over and over. Not even enough time to attempt a warp let alone read what all the destination names were. Pressing B didn't stop it, it just kept making the sound.
Turned the ship off and then back on. VIOLA! The markers have stopped flashing and now we can only see the markers in the area, great!
Pressed F2, zoomed out, found Hurston yet again. Clicked on it, clicked to set waypoint. Verified with the long solid green line appeared on the map.
Pressed B and... everything is still obstructed... wth?
We then flew back to Screen shaking hell, stupid cannon still firing off into the distance...
I left the 2-seater to try a different ship to see if that ship was buggy and during my space walk, my friend reports that all of a sudden quantum jump was non-issue for him.
As soon as I jumped back in, "Obstructed". Okay, that's ...odd.
So apparently we can be in a group but we just cannot play together... that blows. Oh well, I have my own ships so it's not that much of a dealbreaker.
I leave to get my own ship, he takes off for Hurston only to get pulled out of jump(why is this even a thing??), for an inspection(leaving Olisar, really?), then he couldn't establish the jump again.
He sees the marker for Hurston but the jump isn't happening.
He fired guns, turned the ship off and on again, and pressing B didn't do anything. Just made those calibration noises in the background.
Then we figured out that he had to press F2, cancel the waypoint and then reestablish it.
He started the jump but not 5 seconds into the jump got pulled out for yet another inspection (why? why another one? why is there an inspection when leaving Olisar of all places?).
Different 3 ships, same NPC scan routine. Then rinse repeat with the same drama needed to start the jump again.
Fast forward several minutes later, almost excited to leave this portion of the game behind us, he then gets pulled out of the jump just 7 Million KM from the destination for no reason. There is nothing there. No secret alien ship, no wreckage, no debris field, no warpgate(?), no truckstop, no EMP interference or call for help. Just empty space. He's not out of quantum fuel. Nothing is overheating. It just decided that it wanted to fail for no apparent reason. Then rinse repeat the same drama needed to start the warp again.
Then he finally arrived just outside Hurston. Sweet, he is almost there!
Pressed B to see where he could go and there is only a single warp location visible, "OP-1".
Jumped to it because there was no other indication of where he could go.
Pressed F2, and noticed a bunch of white triangular looking destination markers on the planet map.... that's a start but ...there are no names on the markers.
Oh wait, nevermind, the names are in dark grey font, just barely visible in the blackness of a black background, and they were floating far away from the correct markers.
He then clicked on a white triangle that indicated a destination on the planet.
Now he is unable to click on a different one because all of the markers all disappeared. He had to click back on the planet, and then back on a different white triangle to find out the name of that destination.
He did this over and over again trying to find Lorville. Nothing... at least as far as we could see.
Then he tried to rotate the map to find Lorville (guessing it was on the other side) and it stopped rotating. It wouldn't rotate any further like there was an artificial limitation in place. So he zoomed out and then back in and once again the planet disappeared.
Zoomed out, now there is nothing? Tried to click to drag back into the area of the map and ... nothing.
F2, F2 again, zoom in, rotate, stops again. Confirmed... from this minimap there was no way to see the markers on other side of the planet.
Instead he decided to jump to a nearby moon behind Hurston.
Then he jumped back to Hurston, then opened the map, and then he could finally see Lorville on the backside of the minimap! Yes!
He made the jump into Lorville, "oh, we've been here before. It's that place with the monorail and the elevators that teleport"
Initiated a comm to land, but got a blank screen filled with static and no response. Ooo! Exciting, maybe the station is under attack? (Nope, just more broken stuff)
Finally saw a strange wrench-looking(?) marker and a texture bug inside the rectangle where it seems he has been granted permission to land at.
He then advanced towards it with one of the most unintuitive overly-sensitive mouse-controlled VTOL . Seriously, what was wrong before? Why was the system made 20 times harder to land?
Closer to the hole, after a dozen or so code browns, VTOL mouse control caused unintended acceleration forward directly into the side of the entrance and then his ship exploded.
After a little over an hour of non-stop bug filled obstructions, he's now back at Crusader.
Accomplished nothing...
All the while, I am now in my own Anvil Hornet with it's cockpit also opening and closing by itself.
I got pulled out of jump to spend 20 minutes killing 2 Drake Dragonfly pirates and a small fighter of some sort. The experience wasn't fun, it didn't give me any sense of pride or loot to pick up. It was just long and annoying.
Finally I kill them, start a jump, get pulled out of the jump for an inspection. Passed.
Then I had to deal with the same exact as above just 7 million KM out. Nothing.
Unfortunately, I didn't have a ship explode trying to VTOL into a small hole.
Nope...
My ship instead VTOLed halfway through the geometry of the textures surrounding the hole.
No amount of on/off again, strafe, turning, vert/desc, and afterburner could free this ship from it's prison.
Then it started to vibrate violently.
I walk out the ship and land on ledge.
I am now stuck up above the landing area. There is no way to get down but jump.
So I did and I died.
Then I hear my ship explode above.
Now I am back at Crusader.
Sparing you from other few more hours of frustration, we finally arrived at Lorville.
We didn't see a way to set the habs to be our new home
We only discovered it works when he put on civilian clothing and choked to death near the habs.
He can walk around the station, even in the industrial areas, but apparently the air near where we live will kill US, but not the NPC wearing a beanie breathing in death.
Oh, and both quest givers completely ignored us.
TL:DR Verdict: Not fun yet and nothing but bugs and poorly implemented content. I'll be back for Squadron 42 and will try this again maybe two years from now.
 
I wonder if they will?

$500k vs the $2m in bond CIG were asking for, bet Crytek are relieved :)
The theory is that CIG made such a strong claim for how badly Crytek were in terms of finances the judge ruled that the 2 million asked for would bar Crytek from moving forward with the case. In other words, if the judge agreed to 2 million it would be the court blocking Crytek from the legal system.
 
I wonder if they will?

$500k vs the $2m in bond CIG were asking for, bet Crytek are relieved :)
Crytek got pretty much what they asked for — they didn't particularly object to the bond as such, only to the ridiculously high number. They got a much lower one instead. So… yeah.
 
Well, that's the choice CiG made - not everyone has to use a flight model like fdev. I'm more concerned that it seems a small slip while manoeuvring leads to such catastrophic ship loss, but it seems that happens a lot in SC with lifts / floors etc, so maybe players are used to it 🤷‍♀️
 
Top Bottom