Release Trade Computer Extension Mk.II

Version [1.7.5.6] released

Changelog:
- Fixed an EDDB-Relay issue when updating the star system states due to changes at the resource file of EDDB.
- Fixed an EDDB-Relay error when updating the minor faction states due to changes at the resource file of EDDB.
- Fixed a rare error when displaying the star system map at the Cartography panel.

Notes:
Either download the version above, install and transfer your old database, or use the auto-update function of the launcher.
Click the 'new version' notice at the bottom of the launcher.

If you find an error, please report and use the Report a Bug button at the launcher and don't forget to copy the error details and ErrorReportFile.7z archive.

I like to remind any user, who wants to use TCE in french, spanish or russian to help in translating the
latest interface phrases, common commodities and rare commodities at OneSky. Thanks in advance.
 
Version [1.7.5.7] released
Changelog:
  • Added the event 'MultiSellExplorationData' to the player journal monitor.
  • Fixed an error when changing manually the star system population at the Navigation panel.
  • Fixed a display issue on active explorations at the Destination display.
  • Fixed long launching times of TCE with large registered market and logbook databases.
  • Fixed a display issue of the row highlight and Summary Info panel at the Waypoint panel.
Notes:
Either download the version above, install and transfer your old database, or use the auto-update function of the launcher.
Click the 'new version' notice at the bottom of the launcher.

If you find an error, please report and use the Report a Bug button at the launcher and don't forget to copy the error details and ErrorReportFile.7z archive.

I like to remind any user, who wants to use TCE in french, spanish or russian to help in translating the
latest interface phrases, common commodities and rare commodities at OneSky. Thanks in advance.
 
Last edited:
Hi Eventure,

Long time no see. I haven't played since 3.3 beta dropped, and then just to poke around the beta. The last time I actually played was...dunno.

Anyway, I also have a new rig and reinstalled everything. All went fine, but I notice TCE launcher "settings" have "game log extended" in red. IIRC, that has to do with verbose logging, but didn't Frontier add that, or make that setting default or something at some point? I poked around and couldn't find a recent post that addressed that, so do we still need to add that for TCE?

*edit: I think I found the setting in ED, under network, it says "enable detailed network logging" and it's enabled by default. So maybe not the thing TCE is warning about?

**edit2: Ok, here's what I think happened. It detected the wrong path. I ran through the detection 3 step process when I installed, then imported my old db (this is where I think the correct path was overwritten by the old installation path). So when I clicked on "game log extended", it showed a path that ended "...elitedangerous64", which doesn't exist. That was old pathing. When I went through the path detection 3 step process a second time, it found a new path, which is the correct one. Warning cleared. An edge case for sure.

Thanks,
Abil
 
Last edited:
Hi Eventure,

Long time no see. I haven't played since 3.3 beta dropped, and then just to poke around the beta. The last time I actually played was...dunno.

Anyway, I also have a new rig and reinstalled everything. All went fine, but I notice TCE launcher "settings" have "game log extended" in red. IIRC, that has to do with verbose logging, but didn't Frontier add that, or make that setting default or something at some point? I poked around and couldn't find a recent post that addressed that, so do we still need to add that for TCE?

*edit: I think I found the setting in ED, under network, it says "enable detailed network logging" and it's enabled by default. So maybe not the thing TCE is warning about?

**edit2: Ok, here's what I think happened. It detected the wrong path. I ran through the detection 3 step process when I installed, then imported my old db (this is where I think the correct path was overwritten by the old installation path). So when I clicked on "game log extended", it showed a path that ended "...elitedangerous64", which doesn't exist. That was old pathing. When I went through the path detection 3 step process a second time, it found a new path, which is the correct one. Warning cleared. An edge case for sure.

Thanks,
Abil
Hi Abil,

thanks for the report, it is an edge case but I will close the gap with the next release.
 
@Eventure , Have you considered enhancing the functionality of the mission panel to indicate missions that have been completed and just not turned in yet? I'm talking like a massacre or pirate bounty mission, where you have to go back to the originating station to turn it in. It seems like TCE knows when these have been completed, because it removes them completely if I log out and back in, would be useful to have it live update though.

I realize this is not a trade function, so feel free to tell me to go away with such a suggestion. LOL Just figured it wouldn't hurt to ask.
 
Potentially unwanted behavior:

When attempting to sort the STAR SYSTEMS tab of the NAVIGATION panel near Professor Palin (I was actually in MAIA at the time), I knew for a fact that there were starports nearby (I was in a 57LY DBX, so I had it filtered to within one jump) with SHIPYARD facilities, yet when I attempted to filter by LOCATION SERVICES: SHIPYARD, all of the entries in my navigation panel disappeared, until I switched over to MARKET PLACES and ran the same filter.

I am currently at DECIAT, and the same filter appears to be properly showing systems which have starports containing shipyards. I do not know why the behavior would be different, but it seems to be.

Given the odd behavior in Maia, I thought it worth mentioning, as one would expect the Star Systems/Shipyard filter to show all star systems which have market places containing shipyards, and (in Maia, but evidently not Deciat) it did not.

Hope all has been well, and thank you as always for TCE.
 
Hi there.
While I really love TCE and think you deserve every coin people donate, the ingame message reminding of that can be kinda deadly, since it's in the middle of the screen and I think also focuses the overlay. If that happens in any critical situation, like landing on high G, just after jumping, facing the star, neutron star supercharging, tough combat situations, docking and many more, it can cost the ship. That's especially mean if you're exploring. I write this because I noticed that this is the reason I stopped using TCE since I'm out on DW2. If the reminder changed by now, that's great, otherwise it's a real threat.
I just donated, by the way, but please consider killing the note of death.
 
Hi Eventure
Frontier changed the exe the other day.
Don`t know if that`s the reason, but when I try to Connect after docking I get the Message "Not Docked".
If it`s a fault on my side I can send you an error Message.
If it` s a general bug may be it`s because of the New exe?
rgds
Wigean
 
@Eventure , Have you considered enhancing the functionality of the mission panel to indicate missions that have been completed and just not turned in yet? I'm talking like a massacre or pirate bounty mission, where you have to go back to the originating station to turn it in. It seems like TCE knows when these have been completed, because it removes them completely if I log out and back in, would be useful to have it live update though.

I realize this is not a trade function, so feel free to tell me to go away with such a suggestion. LOL Just figured it wouldn't hurt to ask.
Will add an indicator to show completed missions, thanks for the suggestion!
@Edit: After reviewing the code/game mechanic, there is no indicator to identify a successful mission without completing it game-wise.
Tracking it through TCE alone would be requiring extensive code work and be out of all proportion.
Sorry pal...


Potentially unwanted behavior:

When attempting to sort the STAR SYSTEMS tab of the NAVIGATION panel near Professor Palin (I was actually in MAIA at the time), I knew for a fact that there were starports nearby (I was in a 57LY DBX, so I had it filtered to within one jump) with SHIPYARD facilities, yet when I attempted to filter by LOCATION SERVICES: SHIPYARD, all of the entries in my navigation panel disappeared, until I switched over to MARKET PLACES and ran the same filter.

I am currently at DECIAT, and the same filter appears to be properly showing systems which have starports containing shipyards. I do not know why the behavior would be different, but it seems to be.

Given the odd behavior in Maia, I thought it worth mentioning, as one would expect the Star Systems/Shipyard filter to show all star systems which have market places containing shipyards, and (in Maia, but evidently not Deciat) it did not.

Hope all has been well, and thank you as always for TCE.
Thanks for the report, will check this for the next release.

Hi there.
While I really love TCE and think you deserve every coin people donate, the ingame message reminding of that can be kinda deadly, since it's in the middle of the screen and I think also focuses the overlay. If that happens in any critical situation, like landing on high G, just after jumping, facing the star, neutron star supercharging, tough combat situations, docking and many more, it can cost the ship. That's especially mean if you're exploring. I write this because I noticed that this is the reason I stopped using TCE since I'm out on DW2. If the reminder changed by now, that's great, otherwise it's a real threat.
I just donated, by the way, but please consider killing the note of death.
Sent you a PM.

Hi Eventure
Frontier changed the exe the other day.
Don`t know if that`s the reason, but when I try to Connect after docking I get the Message "Not Docked".
If it`s a fault on my side I can send you an error Message.
If it` s a general bug may be it`s because of the New exe?
rgds
Wigean
The message comes directly from EDMC in the back. Sometimes the API is a little laggy not noticing, you have already docked.
In some cases, opening an in-game panel, like the market or outfitting, resolve the problem with the API.

If all fails, you can open the market, outfitting and shipyard panel in the game. TCE updates the data shortly afterwards, without EDMC's help.
 
Last edited:
@Edit: After reviewing the code/game mechanic, there is no indicator to identify a successful mission without completing it game-wise.
Tracking it through TCE alone would be requiring extensive code work and be out of all proportion.
Sorry pal...
Aww, that's too bad. Thanks for at least considering it and investigating the possibilities!
Strange how TCE does remove them completely from the mission log if I restart it while completed (but not turned in) missions are there. I guess that's just because the game changes the "time remaining" to blank once they are done.
 
Version [1.7.6] released
Changelog:
  • Added the identification of the exact coordinates for planetary markets on docking.
  • Added new journal data to the 'Loadout' event (max. jump range, ship mass, max. fuel capacity, max. cargo capacity).
  • Added the subclass of scanned star's to the Cartography and Scan Protocol panel.
  • Fixed an issue when tranferring an outdated database, TCE not validating old path settings.
  • Removed the donation reminder screen.
Notes:
Either download the version above, install and transfer your old database, or use the auto-update function of the launcher.
Click the 'new version' notice at the bottom of the launcher.

If you find an error, please report and use the Report a Bug button at the launcher and don't forget to copy the error details and ErrorReportFile.7z archive.

I like to remind any user, who wants to use TCE in french, spanish or russian to help in translating the
latest interface phrases, common commodities and rare commodities at OneSky. Thanks in advance.
 
Hi Eventure,

I have a problem with the latest version as updating comes up with the following error.

I cannot use the report a bug option as it just sits there creating the report.

No Errorreortfile was found.

ee the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

** Exception Text **
System.IO.FileNotFoundException: File not found.
at Microsoft.VisualBasic.Interaction.Shell(String PathName, AppWinStyle Style, Boolean Wait, Int32 Timeout)
at Trade_Computer_Extension.TCE_Launcher_UI.Downloader_DownloadFileCompleted(Object sender, AsyncCompletedEventArgs e) in F:\Trade Computer Extension\Trade Computer Extension\TCE_Launcher_UI.vb:line 2874
at System.Net.WebClient.OnDownloadFileCompleted(AsyncCompletedEventArgs e)


** Loaded Assemblies **
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
Trade Computer Extension MK.II
Assembly Version: 1.7.5.0
Win32 Version: 1.7.5.0
CodeBase: file:///C:/Program%20Files%20(x86)/TCE/Trade%20Computer%20Extension%20MK.II.exe
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 10.0.0.0
Win32 Version: 14.7.3062.0 built by: NET472REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3353.0 built by: NET472REL1LAST_B
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3221.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3221.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Runtime.Remoting
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3221.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
System.Data
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3260.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
System.Numerics
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3062.0 built by: NET472REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll
----------------------------------------
System.Xml.Linq
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3062.0 built by: NET472REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll
----------------------------------------
Newtonsoft.Json
Assembly Version: 10.0.0.0
Win32 Version: 10.0.3.21018
CodeBase: file:///C:/Program%20Files%20(x86)/TCE/Newtonsoft.Json.DLL
----------------------------------------
System.Runtime.Serialization
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Serialization/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll
----------------------------------------
Snippets
Assembly Version: 0.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
Anonymously Hosted DynamicMethods Assembly
Assembly Version: 0.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/mscorlib/v4.0_4.0.0.0__b77a5c561934e089/mscorlib.dll
----------------------------------------
System.Data.SQLite
Assembly Version: 1.0.106.0
Win32 Version: 1.0.106.0
CodeBase: file:///C:/Program%20Files%20(x86)/TCE/System.Data.SQLite.DLL
----------------------------------------
System.Transactions
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3221.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll
----------------------------------------
System.EnterpriseServices
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3062.0 built by: NET472REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.EnterpriseServices/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll
----------------------------------------

** JIT Debugging **
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Thanks.
 
Hi Eventure,

I have a problem with the latest version as updating comes up with the following error.

I cannot use the report a bug option as it just sits there creating the report.

No Errorreortfile was found.

ee the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

Exception Text
System.IO.FileNotFoundException: File not found.
at Microsoft.VisualBasic.Interaction.Shell(String PathName, AppWinStyle Style, Boolean Wait, Int32 Timeout)
at Trade_Computer_Extension.TCE_Launcher_UI.Downloader_DownloadFileCompleted(Object sender, AsyncCompletedEventArgs e) in F:\Trade Computer Extension\Trade Computer Extension\TCE_Launcher_UI.vb:line 2874
at System.Net.WebClient.OnDownloadFileCompleted(AsyncCompletedEventArgs e)


Loaded Assemblies
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
Trade Computer Extension MK.II
Assembly Version: 1.7.5.0
Win32 Version: 1.7.5.0
CodeBase: file:///C:/Program%20Files%20(x86)/TCE/Trade%20Computer%20Extension%20MK.II.exe
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 10.0.0.0
Win32 Version: 14.7.3062.0 built by: NET472REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3353.0 built by: NET472REL1LAST_B
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3221.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3221.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Runtime.Remoting
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3221.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
System.Data
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3260.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
System.Numerics
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3062.0 built by: NET472REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll
----------------------------------------
System.Xml.Linq
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3062.0 built by: NET472REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll
----------------------------------------
Newtonsoft.Json
Assembly Version: 10.0.0.0
Win32 Version: 10.0.3.21018
CodeBase: file:///C:/Program%20Files%20(x86)/TCE/Newtonsoft.Json.DLL
----------------------------------------
System.Runtime.Serialization
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Serialization/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll
----------------------------------------
Snippets
Assembly Version: 0.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
Anonymously Hosted DynamicMethods Assembly
Assembly Version: 0.0.0.0
Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/mscorlib/v4.0_4.0.0.0__b77a5c561934e089/mscorlib.dll
----------------------------------------
System.Data.SQLite
Assembly Version: 1.0.106.0
Win32 Version: 1.0.106.0
CodeBase: file:///C:/Program%20Files%20(x86)/TCE/System.Data.SQLite.DLL
----------------------------------------
System.Transactions
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3221.0 built by: NET472REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll
----------------------------------------
System.EnterpriseServices
Assembly Version: 4.0.0.0
Win32 Version: 4.7.3062.0 built by: NET472REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.EnterpriseServices/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll
----------------------------------------

JIT Debugging
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Thanks.
Could be your AV app, otherwise, download the installer and transfer your database.
 
Hi Eventure,

It's not my av as it has never been a problem before and I have added TCE as an exclusion.

I will try the installer.

Thanks,
 
Hi Eventure,

I used the installer and copied over and verified the databases.

Sorry but I am still getting the same error message as above.8-((
in F:\Trade Computer Extension\Trade Computer Extension\TCE_Launcher_UI.vb:line 2874
Is the above correct as it looks a bit odd with the F drive?

Thanks,
 
Hi Eventure,

I used the installer and copied over and verified the databases.

Sorry but I am still getting the same error message as above.8-((

Is the above correct as it looks a bit odd with the F drive?

Thanks,
Please don't install it over, use a new folder!
 
Hi Eventure,

I'm an old hand when it comes to TCE.:cool:)

I renamed the old directory then used the installer to create a new TCE folder so I did not copy it over the top at all.

Then imported and verified the database.

On launching, I keep getting the error message, what does that error mean, please?

Also, I noticed this:-

Assembly Version: 1.7.5.0 should that be 1.7.6.0?


Thanks,
 
Last edited:
Hi Eventure,

I'm an old hand when it comes to TCE.:cool:)

I renamed the old directory then used the installer to create a new TCE folder so I did not copy it over the top at all.

Then imported and verified the database.

On launching, I keep getting the error message, what does that error mean, please?

Also, I noticed this:-

Assembly Version: 1.7.5.0 should that be 1.7.6.0?


Thanks,
Yes, 1.7.6 is the actual version, so you have installed an outdated version and trying to update.
Did you created an exception for the TCE_Update.exe (located at the \bin folder) in your AV too? Maybe that's the problem.

Check also the desktop shortcut, if it is linked to your latest installion folder.
 
Hi Eventure,

This is getting very weird!

I downloaded and use the version form dropbox as listed as 1.7.6.

Run TCE, login no problem, it shows TCE version is up to date and shows version 1.7.6 in the launch screen.

Then launch and the error appears with the 1.7.5.0 in the error list.

Yes, I have now added the TCE update to the exclusion but this did not solve the problem.

The creating report appears not to complete when run.

Could you please check the dropbox download in case it is wrong somewhere and I will try again with a new download and installation later tomorrow.

Just out of interest, you state that the download is 59.2mb but dropbox shows it as 90.71mb?

Thanks,
 
Last edited:
Small bug report:
When I hide the interface and then activate the FSS it reactivates itself. I guess because it just toggles the same function I manually use?
 
Top Bottom