Release Trade Computer Extension Mk.II

Hi Eventure,

Tried a fresh download twice but still getting the same error even when running as Administrator.8-((

Then launch and the error appears with the 1.7.5.0 in the error list.

Thanks,
 
Hi Eventure,

This is getting very weird!

I downloaded and use the version form dropbox as listed as 1.7.6.

Run TCE, login no problem, it shows TCE version is up to date and shows version 1.7.6 in the launch screen.

Then launch and the error appears with the 1.7.5.0 in the error list.

Yes, I have now added the TCE update to the exclusion but this did not solve the problem.

The creating report appears not to complete when run.

Could you please check the dropbox download in case it is wrong somewhere and I will try again with a new download and installation later tomorrow.

Just out of interest, you state that the download is 59.2mb but dropbox shows it as 90.71mb?

Thanks,
If you have a big database, it takes some time to compress the files, be patient.
I have check the files at dropbox, all up-to-date and no issues. The reported file size is the uncompressed (TCE_setup.msi) file.
The file 'TCE_MK.II_1.7.6_full.zip' is 59.2 mb in size.
No one else reported any installation issues as you, so the file can't be the issue.

Hi Eventure,

Tried a fresh download twice but still getting the same error even when running as Administrator.8-((

Then launch and the error appears with the 1.7.5.0 in the error list.

Thanks,
That is wired, because if you are launching with the 1.7.6 it can't change it's version number, so that might be the issue, there is something mixed up.

But to find a solution before releasing the next update, try the following:
1. Remove all downloaded files of TCE from your download folder, incl. the desktop shortcut for TCE and download the V1.7.6 installer again.
2. Find your latest working TCE installation folder and rename the folder to TCE.old.
3. Install TCE to a folder called TCE.176, start the launcher, let TCE find the ED folder or select it manually and launch without any changes to the database for a test.
4. When it works, exit TCE and thereafter transfer your old database with the launcher (Database tab).
5. Now launch TCE and check, if it is now working.

Hope that helps, but if not, send me a PM with more details.

Small bug report:
When I hide the interface and then activate the FSS it reactivates itself. I guess because it just toggles the same function I manually use?
Thanks for the report, it will be fixed with the next update.
There is a missing check, if the UI was manually hidden before.
 
Last edited:
Hi Eventure,
I have a small request.
Would it be possible to set the "start date" of an exploration at the date and time when it is activated (for the first time), instead of the creation time?
This would allow to create explorations in advance and start them whenever I want to. If I do this now, the start and total time needed to complete an exploration will be wrong.

Thanks

Homunk
 
Hi Eventure,
I have a small request.
Would it be possible to set the "start date" of an exploration at the date and time when it is activated (for the first time), instead of the creation time?
This would allow to create explorations in advance and start them whenever I want to. If I do this now, the start and total time needed to complete an exploration will be wrong.

Thanks

Homunk
Found the issue, the start date/time was set before activating the exploration. This happens only, if the start star system of an exploration equals the actual star system of your commander. Will be fixed with the next update.

Thanks for the report.
 
Last edited:
Version [1.7.6.1] released
Changelog:
  • Fixed an error with the 'Loadout' event data output of outdated journal files.
  • Fixed an error at the Commander screen of the Launcher.
  • Fixed an issue with the EDDB-Relay Star System update adding invalid characters to the faction state. Please redo an EDDB-Relay Star System update but activate the 'Rebuild Database' option once before to fix the issue in your database.
  • Fixed an issue when using the FSS scan and the UI was manually hidden before.
  • Fixed an issue with the creation of an exploration if the start system of the exploration equals your actual star system, the start date/time of the exploration was set before the exploration was started.
Notes:
Either download the version above, install and transfer your old database, or use the auto-update function of the launcher.
Click the 'new version' notice at the bottom of the launcher.

If you find an error, please report and use the Report a Bug button at the launcher and don't forget to copy the error details and ErrorReportFile.7z archive.

I like to remind any user, who wants to use TCE in french, spanish or russian to help in translating the
latest interface phrases, common commodities and rare commodities at OneSky. Thanks in advance.
 
Version [1.7.6.2] released
Changelog:
  • Updated the link of the 'Forum' button at the Launcher.
  • Fixed an error with the 'LoadGame' event data output.
  • Fixed an issue with the removal of the Auto Exploration status on loading.
Notes:
Either download the version above, install and transfer your old database, or use the auto-update function of the launcher.
Click the 'new version' notice at the bottom of the launcher.

If you find an error, please report and use the Report a Bug button at the launcher and don't forget to copy the error details and ErrorReportFile.7z archive.

I like to remind any user, who wants to use TCE in french, spanish or russian to help in translating the
latest interface phrases, common commodities and rare commodities at OneSky. Thanks in advance.
 
Well as a complete beginner this question may be obvious..... It says in the features that the database is imported and it is. Until I try the trade menu were the only info I can get is for the station I am in. Do I have to manually get the trade info? or should it already be there from the initial database? I have no errors, have the edmc working fine I just have no trade info at all.

Anyone fancy giving me a set of steps I should take if I expect it to work properly? I have tried importing,verifying,creating initial databases in about every order you can think of. I must be doing something wrong.

Any ideas would be great,unless of course I have to populate it manually! Thanks

I did get this error while trying to find stuff in the shopping tab, which is also empty apart from the stations I visit.
error.JPG
 
Well as a complete beginner this question may be obvious..... It says in the features that the database is imported and it is. Until I try the trade menu were the only info I can get is for the station I am in. Do I have to manually get the trade info? or should it already be there from the initial database? I have no errors, have the edmc working fine I just have no trade info at all.

Anyone fancy giving me a set of steps I should take if I expect it to work properly? I have tried importing,verifying,creating initial databases in about every order you can think of. I must be doing something wrong.

Any ideas would be great,unless of course I have to populate it manually! Thanks

I did get this error while trying to find stuff in the shopping tab, which is also empty apart from the stations I visit.
View attachment 129459
Hi Kingsk1n,

you can add markets along your road by visiting them one by one or use the EDDB-Relay at the Launcher to fill your database automatically with markets around your current position.

If you choose the second, enter the Extension tab of the Launcher and create an initial database. Before creating it, select the sphere range and the distance from the primary star within a star system.

Thereafter, you should add content to the markets, you have now in database by updating the markets. Select which content you like to add (Shipyard, Outfitting and/or Station details), beside the trade data. The 'Rebuild' option is only used, if your database contains wrong informations, so you didn't require this option in the beginning.

Hit the 'Update Trade Markets' button and TCE will do the rest. When finished, you will have plenty of market informations to find rich trades.
Redo the update every day you playing and your data will be up-do-date.

Regarding the error, please send my a bug report and describe how it happen, so I will be able to recreate it. Don't forget to add the ErrorReportFiles.7z from the root folder of TCE.

Thanks in advance!
 
Is it possible to build an initial database and then merge it with what I've personally visited? I didn't make one when I first started using TCE so I'm missing... A lot.
 
Version [1.7.6.3] released
Changelog:
  • Added two missing outfitting modules from the ED 3.4 patch to the database.
  • Added a small visual rework of the Extension tab at the Launcher.
  • Added automatic saving of selected options from the Extension tab at the Launcher.
  • Fixed an error when TCE detecting unknown outfitting gear by using the 'Connect' button.
Notes:
Either download the version above, install and transfer your old database, or use the auto-update function of the launcher.
Click the 'new version' notice at the bottom of the launcher.

If you find an error, please report and use the Report a Bug button at the launcher and don't forget to copy the error details and ErrorReportFile.7z archive.

I like to remind any user, who wants to use TCE in french, spanish or russian to help in translating the
latest interface phrases, common commodities and rare commodities at OneSky. Thanks in advance.
 
*Edit - Sorry I just noticed the Report a Bug button and followed those instructions.

Hey

I've been getting these error message over the last couple of updates
I tried a few times of loading the game, then loading TCE, or vice versa but no luck.

Happens when I jump into a new system and it scans.
Capture.PNG
 
Last edited:
*Edit - Sorry I just noticed the Report a Bug button and followed those instructions.

Hey

I've been getting these error message over the last couple of updates
I tried a few times of loading the game, then loading TCE, or vice versa but no luck.

Happens when I jump into a new system and it scans.
View attachment 129763
Hi Uggers,

thanks for your report. Found the issue and fixed it with the update below.
 
Version [1.7.6.4] released
Changelog:
  • Fixed a wrong initial array dimension of star data, if none existing in database before at the 'Scan' event.
Notes:
Either download the version above, install and transfer your old database, or use the auto-update function of the launcher.
Click the 'new version' notice at the bottom of the launcher.

If you find an error, please report and use the Report a Bug button at the launcher and don't forget to copy the error details and ErrorReportFile.7z archive.

I like to remind any user, who wants to use TCE in french, spanish or russian to help in translating the
latest interface phrases, common commodities and rare commodities at OneSky. Thanks in advance.
 
Hi Eventure. I have a couple of things I would like to pass on here.

Firstly I would like to say thanks for your continued support of the TCE. In my mind it is an essential tool for playing ED.

Secondly I seem to be having a little problem when I use the FSS. When I activate the FSS the TCE disappears as if it is an interception, which is good, but then does not reappear when I exit the FSS. I need to then press my show / hide TCE button to get the TCE to reappear. I currently have keysettings as;
Enter FSS = F2;
Exit FSS = F3; and
TCE show / hide Interface = F9.
 
Hi Eventure. I have a couple of things I would like to pass on here.

Firstly I would like to say thanks for your continued support of the TCE. In my mind it is an essential tool for playing ED.

Secondly I seem to be having a little problem when I use the FSS. When I activate the FSS the TCE disappears as if it is an interception, which is good, but then does not reappear when I exit the FSS. I need to then press my show / hide TCE button to get the TCE to reappear. I currently have keysettings as;
Enter FSS = F2;
Exit FSS = F3; and
TCE show / hide Interface = F9.
I have the same issue, except it is not that it does not show again after exiting FSS, but rather that it can take quite a while to show itself, especially if I had scanned a lot of bodies. I think it processes all of those messages before deciding to appear again.

When I'm exploring, it typically is perma hidden because I've jumped to the next system and started using FSS again before it re-appears.
 
I'm a bit confused on the "Data Age of Prices" setting in the launcher.

If I set it to 1-Day and then request to Update Trade Stations, can someone please tell me which of the following scenarios is correct?

A) All of my stations which are older than 1-Day are updated with whatever EDDB has.
B) All of my stations which are older than 1-Day are updated with EDDB information if EDDB is newer.
C) All of my stations which have updates on EDDB within the last 1-Day are updated.
D) Another option I've failed to describe.

Thank you.
 
Top Bottom