Release Trade Computer Extension Mk.II

"Update thereafter your databases by the EDDB-Relay and search again." I dont think I know how to do that -- Do you mean "verify"?

UPDATE -- ok I think I've got it. Extensions and then Update Trade Stations, Update Star Systems and Update Factions. Is that what you mean?

ANOTHER UPDATE -- Ok feeling kinda silly now, I updated at the Launcher EDDB and now have suggested routes. So I am happy with that. It didnt pick up the route im actually running, but I was able to plot it manually -- very pleased.

Question -- should I update from EDDB every time I launch TCE (TBH I had forgotten about that feature)?

I am sure that there are loads of features that I have not used, even after all the years that I have always had TCE running. Is there any chance of some video guides? It's a real shame not to be using all the tools that you have supplied us here in TCE.

Huge thanks to Eventure for always replying and sorting things for us. cheers 🍻
 
Last edited:
Question -- should I update from EDDB every time I launch TCE (TBH I had forgotten about that feature)?

I am sure that there are loads of features that I have not used, even after all the years that I have always had TCE running. Is there any chance of some video guides? It's a real shame not to be using all the tools that you have supplied us here in TCE.

Huge thanks to Eventure for always replying and sorting things for us. cheers 🍻
Thank you Scotty, always nice to hear!

Yes, update your databases once a day before launch. In case of guides, there are some great user-made ones,
but sometimes the UI can differ due the development of TCE and not all parts of TCE are covered entirely, I have to admit.

I suggest to use the wiki to checkout, what support all panels could give you while playing.
 
Last edited:
Is there a way to search this thread only? Usually is in forum software but I'm not seeing it here. Wanted to search back to see if this issue came up.

Anyway, I've been thinking about coming back to the game again. Haven't played since 2017. Went through updating all the tools I used to use and when logging into this one after upgrading I got hit with all these errors:
Trade_Computer_Extension_MK.II_2020-01-23_15-44-30.png


There used to be some upgrade process between TCE versions (have an old and new folder, convert databases over, process took quite some time), but that didn't seem to take place with this latest version.

I'm guessing things changed between my version from 2017 (16.x?) that renders the old stuff incompatible now? Is there any way to upgrade all my old data or are we forced to start fresh again?
 
Is there a way to search this thread only? Usually is in forum software but I'm not seeing it here. Wanted to search back to see if this issue came up.

Anyway, I've been thinking about coming back to the game again. Haven't played since 2017. Went through updating all the tools I used to use and when logging into this one after upgrading I got hit with all these errors:
View attachment 159933

There used to be some upgrade process between TCE versions (have an old and new folder, convert databases over, process took quite some time), but that didn't seem to take place with this latest version.

I'm guessing things changed between my version from 2017 (16.x?) that renders the old stuff incompatible now? Is there any way to upgrade all my old data or are we forced to start fresh again?
Please send me (use the 'Report a Bug' button) your old database (or TCE folder) and I will check, what's got wrong.
Please tell me also, what version number the old install has.
Thanks in advance.
 
I can't use the report bug thing because I can't login to the application. It just hangs on the start screen after all those errors. However, I was able to restore the folder back via Windows Shadow Copies (had overwritten the folder with the new install). Seems to be version v1.6.2.2.

The bug report button opens a new browser window that doesn't go anywhere, but looks like it generated something in the directory? Is it fine if I just post it here?

Installed the new version into a separate folder for testing. No errors, but obviously new settings (did keep my login weirdly enough). This version just hangs when clicking the 'bug report' button. Sits on "creating report" using a full CPU core indefinitely.

------

However, during writing this post I figured out how to transfer the old databases. Seemed odd that the default install directory was C:\TCE. Looks like I used to install the new version into the system root, move my old folder over to be named TCE_OLD, then go to the database section and transfer things/verify. Repeated that process now, everything all worked fine, even copied the program settings.

Crisis averted! Sorry to bother you.
 
Top Bottom