Release Trade Computer Extension Mk.II

Thanks for your reply, I activated the manual Focus option and configured shift + * as my keybind for focus interface and the problem persist, if i press the keybind it allows me to interact with the hud, but even if i don't press it i can still click any part of the hud.
Activate also the Remove UI Buttons on Focus Lost. As soon the buttons are removed, you can't interact with the TCE UI unitl you press the keybind for the UI Focus.
 
Last edited:
Activate also the Remove UI Buttons on Focus Lost. As soon the buttons are removed, you can't interact with the TCE UI unitl you press the keybind for the UI Focus.
Hmm you're right, I can't interact with the tce ui buttons but the mouse still appear in the top ui and make the game loss focus
 
Hmm you're right, I can't interact with the tce ui buttons but the mouse still appear in the top ui and make the game loss focus
Thanks for the feedback. Indeed, the focus is lost. Preparing a beta for you to test it. I will send you a message, when its ready to download.
I didn't use mouse control and most, if not all other users too, so it wasn't tested extensively.
 
Hello, I can’t seem to get scan protocol to register dss scans. Is this normal ? Also.. I can’t seem to get an imported exploration to work for my wife. (It seems to work for me) but for her…. It skips the first destination, so doesn’t clipboard the next jump.

I’m sure it’s me doing something wrong, probably in both instances.. but I need help please :)
 
Hello, I can’t seem to get scan protocol to register dss scans. Is this normal ? Also.. I can’t seem to get an imported exploration to work for my wife. (It seems to work for me) but for her…. It skips the first destination, so doesn’t clipboard the next jump.

I’m sure it’s me doing something wrong, probably in both instances.. but I need help please :)
I need a little more informations about the issue!
First, please create a bug report by clicking the "Report a bug" button in the launcher or in the options panel. Attach the ErrorReportFiles.7z to the report. With this I can check how you have configured TCE.
Second, attach the route file you created (from the \Routes folder) so I can try to recreate the problem for your wife.

Thanks in advance.
 
I need a little more informations about the issue!
First, please create a bug report by clicking the "Report a bug" button in the launcher or in the options panel. Attach the ErrorReportFiles.7z to the report. With this I can check how you have configured TCE.
Second, attach the route file you created (from the \Routes folder) so I can try to recreate the problem for your wife.

Thanks in advance.
ok mate I’ve sent that info through with your error report as requested.
Sorry I thought they might have been some standard issues that I was just doing something wrong.
Thank you for your time !
in love with TCE :)
 
Version [1.8.9.8] released
Changelog:
  • Fixed an issue with mouse flight controls where the game could lose focus.
  • Fixed a rare issue when EDDB-Relay updated the databases on the fly.
Notes:
Either download the version above, install and transfer your old database, or use the auto-update function of the launcher.
Click the 'new version' notice at the bottom of the launcher.

If you find an error, please report and use the Report a Bug button at the launcher and don't forget to copy the error details and ErrorReportFile.7z archive.
 
I don't know what I'm doing wrong. I have TCE 1.8.9.8 installed but the EDDB relay service doesn't seem to be adding the markets to my database. I have the EDDB-relay service turned on, Database Update is set to automatic, Trade Markets marked as "all in range" and both option boxes (cache buffering and dynamic cpu core usage) ticked.

However, while the database list under the database tab has the markets listed as being known, in game the market finder will only find the market for the station I'm currently at. I'm not sure what I'm doing wrong but the TCE launcher says the markets are registered and they don't show up when the TCE is launched in game making it impossible to plan any trade routes. If I could get advise on what I'm doing wrong/how to rectify this, I would appreciate it.

Thank you for your hard work!
 
I don't know what I'm doing wrong. I have TCE 1.8.9.8 installed but the EDDB relay service doesn't seem to be adding the markets to my database. I have the EDDB-relay service turned on, Database Update is set to automatic, Trade Markets marked as "all in range" and both option boxes (cache buffering and dynamic cpu core usage) ticked.

However, while the database list under the database tab has the markets listed as being known, in game the market finder will only find the market for the station I'm currently at. I'm not sure what I'm doing wrong but the TCE launcher says the markets are registered and they don't show up when the TCE is launched in game making it impossible to plan any trade routes. If I could get advise on what I'm doing wrong/how to rectify this, I would appreciate it.

Thank you for your hard work!
Please check the filter settings of Route Finder, especially the data age. if it should be set to Actual, it will only find stations whose data are not older than 24 hours. Increase the value to 2 to 3 days and routes should then be displayed.
 
I'm having problems with the current version of TCE (1.8.9.8) on windows 10 with dual monitor (elite runs in full screen on monitor 1), font type is set to the default sans serif in the settings -> font type section on the TCE launch screen.

If you look at the red highlighted bits you can see the font is so small its illegible. I have tried picking all of the 3 "pizza boxes" options that change the displayed info on the location / destination and it makes no difference to the font size.

Does anyone have any idea how to fix this problem?

Thanks



small font.jpg
 
I'm having problems with the current version of TCE (1.8.9.8) on windows 10 with dual monitor (elite runs in full screen on monitor 1), font type is set to the default sans serif in the settings -> font type section on the TCE launch screen.

If you look at the red highlighted bits you can see the font is so small its illegible. I have tried picking all of the 3 "pizza boxes" options that change the displayed info on the location / destination and it makes no difference to the font size.

Does anyone have any idea how to fix this problem?

Thanks
Hard to tell, the default size is 11. Please send me a bug report, so i can inspect your monitor setup and settings.
Do you have the windows desktop screen scaling active?
 
Hard to tell, the default size is 11. Please send me a bug report, so i can inspect your monitor setup and settings.
Do you have the windows desktop screen scaling active?
I have my screen scale set to recommended 100% and ive sent you a link to my error report
 
Version [1.8.9.9] released
Changelog:
  • Fixed an issue with the displayed font size of the classic UI HUD.
  • Fixed another rare issue when EDDB-Relay updated the databases on the fly.
Notes:
Either download the version above, install and transfer your old database, or use the auto-update function of the launcher.
Click the 'new version' notice at the bottom of the launcher.

If you find an error, please report and use the Report a Bug button at the launcher and don't forget to copy the error details and ErrorReportFile.7z archive.
 
Version [1.8.9.9] released
Changelog:
  • Fixed an issue with the displayed font size of the classic UI HUD.
  • Fixed another rare issue when EDDB-Relay updated the databases on the fly.
Notes:
Either download the version above, install and transfer your old database, or use the auto-update function of the launcher.
Click the 'new version' notice at the bottom of the launcher.

If you find an error, please report and use the Report a Bug button at the launcher and don't forget to copy the error details and ErrorReportFile.7z archive.
WOW, just WOW what a speedy fix. I really love using TCE and to get a fix from a developer within such a quick time frame is amazing, especially for such a random bug.

I can confirm that this latest patch does fix my small font issue.

Again many thanks for your great work. (y)👏
 
Hi Eve - After yet another lengthy break I have installed 1.8.9.8 but seem to be missing something Give me a clue please.
Hi Perses and welcome back,
I don't know, how long your break was, but if there is something missing (whatever you mean by that), install the latest version into new folder and transfer your database with the launcher of TCE to the new version from your old TCE installation. If you have encountered a problem, send me bug report and I will see, what I can do for you. ;)
 
Please check the filter settings of Route Finder, especially the data age. if it should be set to Actual, it will only find stations whose data are not older than 24 hours. Increase the value to 2 to 3 days and routes should then be displayed.
Sorry for the delay, I've checked the route finder's settings.
My Search Range is set to 1000LY, Data Age is set to 7 days, and I have no excluded commodities. No trade routes are being shown.

Not sure what I'm doing wrong
 
Hi Perses and welcome back,
I don't know, how long your break was, but if there is something missing (whatever you mean by that), install the latest version into new folder and transfer your database with the launcher of TCE to the new version from your old TCE installation. If you have encountered a problem, send me bug report and I will see, what I can do for you. ;)
So many files for the x64 no idea if I have the right one. (Was incapacitated). Seen enough of hospitals to last the rest of my lifetime.
 
Send me a bug report and I will check what the problem is.
At some point since updating TCE, the database has moved the majority (all but 2) markets back to unknown. I'm seeing if I can rectify this and if the issue persists. If it does, I'll send the bug report.

Apologies for being a pain

Edit: I don't know what exactly I did, a lot of verifying, and reverifying the databases mostly. I also adjusted Market distance to 1000LY as 50 was giving me nothing. It's working now though, thank you
 
Last edited:
Top Bottom