Update 1.0.4 caused major lag and freezing

So after about 3 days of not playing the mini patch came out which was....Yesterday I think? I just saw on Twitter that the new challenge was with Cheetah's so I figured I'd give it a go bcuz Cheetah are easy to breed and they can have upto 5 babies. SO. I load my zoo and for some reason it's freezing for like 2 seconds everytime a notification comes up or if I click on one of the tabs and occasionally when I'm moving my camera. This never happened before the 1.0.4 update. Is anyone having the same problem? When It freezes I automatically think that it's about to crash bcuz that's how it happens. Freeze = crash. But it's actually just freezing for a few seconds as if the notifications take too much effort to load up what are you doing? 🤨🤔

EDIT: I've just tried saving and exiting the game and it was stuck on the saving screen for like a minute when it usually takes about 10 seconds. Also when I did a general save it took around 20 seconds when it usually takes about 5 seconds. This update seems to have slowed it down somehow. 🤔

EDIT 2: After restarting the game and updating my GeForce....This is major lag since the update. My game is just unplayable. I have to pause the game just to get around and even then, clicking on tabs is slow. The game is messed up right now. Also I am stuck on the loading screen now after exiting to the main menu. I can't even ALT + F4 or CTRL + ALT + DEL. I've had to restart my computer. Fantastic.
 
Last edited:
I've tried starting a new sandbox zoo on two separate occasions recently, and both times within a few minutes of just creating the entrance paths it crashes to desktop. Very frustrating indeed!
 
Top Bottom