Weights, bones, Influencer? is it a sickness?

After uploading my object, I've got this note:

"Weights for influencers should sum to one [Bad Bone Weights]".

Can anyone tell me what that exactly means, resp. what I did wrong?

Thx in advance for your help. ;)
 
I get the same error when I try to up load an animated model created in 3D Max. I have yet to find an answer to this problem.
 
I can answer this for Blender at least, but maybe it'll give a hint for 3D Max too. When you're weighting the parts of your mesh to bones in your armature, it's assigning a value of 0 (no influence), 1 (total influence), or somewhere in between to each vertex. It seems like all vertices must be assigned to at least one bone, even if it's just a static "this item doesn't move" bone.

Using weight paint in Blender is kind of imprecise for this, but in edit mode, you can see the actual weight value for each vertex in the right-hand properties menu (which you open by pressing N from the standard 3D view). Each vertex will need to be assigned a total of 1 weight to one or more bones (1 to 1 bone, or 0.5 each to 2 bones, or 0.25 to one bone and 0.75 to another, etc.). No vertex can be assigned a total of more than 1. Here's what it looks like (I also have "Show Weights" enabled, which can be found further down that same menu, under Mesh Display):

weights.JPG

I hope I'm explaining this right - I'm still rather new too, but this is how I fixed this error for mine!

Also, I believe this check and error is kinda new, as I had a model that had vertices with no assigned bone which was working a few days ago, but suddenly stopped working with this same error until I fixed the weights.
 
Hi everyone,

I to get the same error.
I think I've upload it more then 10 times. and i check my model and all the vertex are assigned to a bone.
I dont know what im doing wrong anymore.

kind regards
raptor-88
 
Last edited:
Great explanation. I had no idea the static part of my asset also had to be assigned a bone/weight until I found this post. Thanks!
 
Hello planet coasters,

i have made an animated stargate, see (completed selection) and when i apply the bones its building without errors. but then when i animated the bones it gives the following error: Weights for influencers should sum to one [Bad Bone Weights]
"Weights for influencers should sum to one :"
The pre-build checks failed. [ugcPreBuildFailed]
"Prebuild failed. :"
Build process failed. [ugcBuilderFailed]
"Conversion process returned a non zero exit code: 1"

does anyone know what i am doing wrong ?

kind regards,
Raptor-88
 
For folks still having trouble with this error (in Blender, anyway), I found something else that can cause it. If it's an item you've been working on for a while, or maybe started based on another functioning object, there might be leftover data that is causing a problem. Check in the Object Data tab to see if there are more vertex groups than there should be.

For example, I started a new piece based on one of my signs, and was getting this error. The piece only has one bone, and all vertices were attached to it 100%.

However, when I checked the Object Data tab, my mesh still had vertex groups from previous bones that I had since deleted. Like so:

extra_v_groups.JPG

Since my armature only has one bone (labeled "Bone" because I'm creative like that), the other two were causing problems. (Making the influencers sum to more than 1). So, I deleted the extra vertex groups by selecting them and pressing the minus sign next to the box. So now I have this:

extra_v_groups2.JPG

And now the object uploads without the error. (Make sure you check all of your meshes and all LOD levels.)

I hope this helps someone!
 
hi thanks for the info.
unfortunately that don't work for me.
I have multiple objects in the scene and eatch object is assign to a bone.
Do you have to make vertex groups ?

kind regards,
Raptor-88
 
Top