Can't Log In On Xbox? Here's What To Do!

Status
Thread Closed: Not open for further replies.
Hey folks, been a hot minute since I posted but here goes:

Some of you may know me, others, not so much. For those of you who do and have been flying with me, (or trying to) I have been experiencing login issues for about 6 months now. Recently, they got worse, with me not even being able to connect to the Frontier Servers or log in to the game. Being rewarded with blackscreens, lockups, and a completely broken social feed as well as Squadron menu when I actually did manage to log in was fairly commonplace. So I did what most people did, I submitted a ticket to Frontier.

The TL;DR of our correspondence is that regardless what I tell them, or do, they are going to tell me, and you, and everyone else who is experiencing these issues, is that it might be your UpNP, or your cache, or your internet, or your router, or something on YOUR end, something YOU have set up incorrectly, or something that YOU didn't know or see. Additionally, they likely won't even bother to send you a message that doesn't contain copypasta of some form or another. This is unacceptable, and instead of troubleshooting the problem or fixing it, they are expecting us to do it for them.

They also asked if I would be willing to delete my Commander Profile, resulting in the loss of 2 NPC pilots, which they claim they cannot recreate. This is despite the fact that we know full well they can, and have recreated pilots for people before. 'Member the "Flying Skimmer" issues? There are multiple people in my PMF that have had their pilots replaced.

Being lied to sucks Fdev. Being treated like your problem is your fault does too.

But I digress, and I do indeed have a solution.

Myself and TooBones have been in contact for a while, both experiencing the same issues, and frustration, and levels of "we don't really give a crap" from Fdev, and during our correspondence, he managed to not only trace the source of the problem, but figure out a fix.

DELETE YOUR PRIVATE GROUP.

I tried for nearly an hour to log on last night, fought thru the lockups, and the infinite loading, and the blackscreens, and my game is working just fine. This is after hard resets, dashboarding, and just quitting and restarting. There are no issues. Unfortunately I can only confirm this has worked for TooBones and myself, so if it doesn't work to solve your issue, please do not hunt me down and throw piles of flaming bog-spaniel excrement at my ship.

As a final note, I'd like to express my frustration with Frontier Developments, and unfortunately, their customer support team, which until now had a pretty good reputation for being fast, friendly, and efficient in my books.

As a result, I am going to be organizing my group, the Leviathan Scout Regiment, to boycott any and all purchases from the Frontier store until such a time as Fdev sees fit to stop issuing cookie-cutter-responses, and actually decides to take a look at the problem and solve it. The fact that we are expected to not only troubleshoot the problem and deal with not being able to play, but to sit here and be asked questions regarding our connections that the developers clearly know the answers to already is trash. If you would like to show your support for the boycott, get in touch with us in the LSR on our discord, through Inara, on here or on Reddit.

Let Fdev know. Speak with your wallet. They don't deserve our money if this is the way they treat their players and fans.

I hope the band-aid fix we have provided in the meantime works for those of you reading this and for the rest of us poor souls on Xbox who can't even play.

o7
XxHyde840xX
Commanding Officer
Leviathan Scout Regiment

P.S. - Thank TooBones of RoTV for the fix when you see him.
 
Last edited:
Glad you figured it out. Hope you passed what you discovered on to Fdev so they can add it to their copy paste replys, or even figure out how your private group could be so corrupting. Not going to join a boycott. I will certainly toss them a bone when they release a Mamba body kit. (Not raider based)
 
While this is useful info I'm not sure it applies to everyone. I personally don't have a Private Group myself (I am a member in other groups, though) yet yesterday I also encountered the same problems. First the game just didn't want to load, it was the four orange square screen rotating indefinitely. Then the game decided I had "new purchase detected" so the game restarted itself then couldn't connect to the Frontier servers. For the third time it finally worked. Given how Frontier regularly does server maintenance I would guess these problems are related to those firstly, and only personal network setup afterwards. I am through with a very long message exchange with Frontier Support myself (from a few years ago) where they changed the game in an update then insisted the problem was on my end. The bottom line is that such complex online-only games are extremely vulnerable due to the fragmented nature of worldwide networks and devices. And I wouldn't necessarily blame Support only, as it can be very hard to determine what exactly causes a given problem. Maybe if the game gave us different error codes or more detailed description of an error instead of "couldn't connect" these problems would be easier to solve.
 
I was having issues at the stated that time OP. Random buzz crashes, adjudication server errors & freezing without a buzz. Went through the usual cache clear and router reset. Check server status of ED & XBL. The issues persisted so I gave up for the evening and went back to my pixel cars.

Upon checking my Twitter feed the following morning I see a tweet from FD citing having some problems, which are now resolved. It's been working like a charm thus far.

While I'm not putting into question your issues, experience or perceived responses from FD. Is it not possible that there is a level of circumstance involved? I've also known cases where another CMDR at the other end of the UK is having issues that I'm not, due to a different route to the "Cambridge galaxy" and a different ISP.

Deleting your private group seems a trite unlikely as a solution and rather brash. But I'm glad that it seems to have worked for you.


EDIT: Please, see post below. ⬇
 
Last edited:
As a follow up post: I have just eaten my hat. As the saying goes. 🤪

My issues began manifesting again, principally random freezing and buzz crashes. After cache clear, router reset, XBL profile reset & a reinstall and re sync of my save. Toggling quality mode & resolution, etc. It's still doing it. 😡

So I figured what the heck and disbanded my private group that hasn't been used for I don't know how long. As of yet, NO ISSUES. Quality mode turned back on as well.

So, although it doesn't make much sense, it may seem to have some legs. Thanks for the tip! 🥳
 
Last week I was unable to log on because I had a mission and (I think) the adjuducation server was unable to load it. Solved it by hotspotting my phone and connecting through that. Found the game then loaded and I was able to complete the mission, after which I could log on again through my router.
 
Don't have a private group, but this problem just began happening today for me. Infinite "New Purchase Detected" loop.
Did anyone figure out what was behind it or how to fix it?
It's pretty certainly a problem with either Frontier's servers or XBox Live (Guessing likely the latter, but the XBox Live service status page shows no issues) since literally nothing changed at my end, it just literally started happening 12 hours into a play session, and this is the only game with any issues.
 
Oh wait, my network settings page just changed

From
Wired / IPv4 / NAT Type Open / All Services Available
To
Wired / IPv4 / NAT Type Open / XBox Live is currently unavailable

So I guess something's gone down, will try switching to accessing via my mobile connection on a different network to see if it's XBox Live or my ISP


EDIT

Confirmed, exactly the same issue when using another network, so yeah, looks like one possible cause of this is 100% XBox Live experiencing issues.
Which makes absolute sense since that'd explain how it loses the ability to recognise licenses on your account.
 
Last edited:
Ditto big down in the UK... "New Purchase Detected" loop........ crrently watching the HD restored Apollo 11 EVA on YT, has got me thinkin 'bout space legs lol.
 
Last edited:

BongoBaggins

Volunteer Moderator
I've forwarded the original issue to support in case they weren't aware, but the problems yesterday were caused by an unrelated Xbox Live outage.
I'll close this thread to prevent further confusion (mostly mine)
 
Status
Thread Closed: Not open for further replies.
Top Bottom