Release Elite G19s Companion app (with simulated space traffic control)

Your fix is in the mail ;-) I think something stole all the spaces from your AppConfig.xml file. Easy to fix, just sent you a version with spaces. Let me know if it solves your issue.
 
:) Send me your file, sutex, I'd be happy to take a look.


I deleted ( moved it too desktop first , then shot it ) AppConfig.xml ran the FD installer and it re-required the files so ALL the TOOLS now work, what a pain that was ..... AppConfig.xml getting corrupted
 
Your fix is in the mail ;-) I think something stole all the spaces from your AppConfig.xml file. Easy to fix, just sent you a version with spaces. Let me know if it solves your issue.

Thanks a bunch really good of you... but as you can see from my reply , I jumped the gun , and went for the delete file and re-require it
 
Your fix is in the mail ;-) I think something stole all the spaces from your AppConfig.xml file. Easy to fix, just sent you a version with spaces. Let me know if it solves your issue.
I have that space error as well... once I fixed it EDDI started working too
 
I have that space error as well... once I fixed it EDDI started working too


We need a pristine FILE ( image) so we can see what it should look like , figure something was wrong with it , but , had no idea what too add or take away
 
We need a pristine FILE ( image) so we can see what it should look like , figure something was wrong with it , but , had no idea what too add or take away
There are several 3rd party that change it, and some without telling you they do, so having a "working" one available sort of works but there are possible changes every time there is a update from FDev. (Not that they would actually DO anything, but to share one of the game files is against game policy.)
 
There are several 3rd party that change it, and some without telling you they do, so having a "working" one available sort of works but there are possible changes every time there is a update from FDev. (Not that they would actually DO anything, but to share one of the game files is against game policy.)



AppConfig.xml , needs some protection if its too stay robust I think APP DEV have too start using a Local config.xml to store write data too.
these crucial files , need to be left alone, as much a possible , if that's possible
 
AppConfig.xml , needs some protection if its too stay robust I think APP DEV have too start using a Local config.xml to store write data too.
these crucial files , need to be left alone, as much a possible , if that's possible
Hehe... nope. FDev resets it every time there is a updates. So you still have to follow their rules on how it sees the files :)
As far as I have heard they are only planning on using using AppConfig.xml because the 32bit and AppConfigLocal.xml for 64bit, but that changed some setting as well.
 
Firstly, I'd like to say congratulations and very well done - this is an EXCELLENT app, and one I now use all the time :)

I have added a few radio streams of my own by editing the options.json file, however, I'd like to modify the twitch streams and add one or two- but I can't find any entry for Twitch in that file - can I do this?

Thanks in advance, CMDR.
 
Is there a way we can change the voice chatter to sound more 'manly' ? Or a mix of both would be even better.
 
Very cool. Working on the iPad like a charm. Data sources are somewhat outdated though. Any chance to connect it with the ED-Market Connector or its export-Files (Market)?
 
The App silently crashs after startup.
I also don't get why we can't get a regular Setup-File for it. It's up to the user to decide where a program is supposed to be installed, not to the Dev.
Uninstalled for now.
 
Last edited:
I have added a few radio streams of my own by editing the options.json file, however, I'd like to modify the twitch streams and add one or two- but I can't find any entry for Twitch in that file - can I do this?
Good point. Right now it just picks up the current top 8 Elite Dangerous streamers, but I suppose this can be configurable. I'll try to add it in to the next version!
Is there a way we can change the voice chatter to sound more 'manly' ? Or a mix of both would be even better.
Also, good point. I am using the available text-to-speech voices that you have installed in Windows. Usually that's just a couple. On my Windows 10 install it's two female and one male voice. So to mix things up, I add filters that change the pitch etc.
Unfortunately, text-to-speech voices are difficult to find, or cost money (Ivona for instance). So, I just work with what's available.
Data sources are somewhat outdated though. Any chance to connect it with the ED-Market Connector or its export-Files (Market)?
Hm, I grab a daily export from EDDB.io, but lately don't see many changes in prices either. Let me look into this, maybe I am doing something wrong!
 
I also don't get why we can't get a regular Setup-File for it.
Hey there BlankFX! I use ClickOnce because it makes life easier for me and because I love things that auto-update. But maybe you have a different opinion and that's fair.

So, I made a portable version of the app. Here is the ZIP file that you can unzip to any folder you like: http://apps.magicmau.nl/EliteG19s-v2/Portable/EliteG19s.zip

Just run the EliteG19s.Windows.exe application to run the app. It will not automatically update, but I'll try to keep the above link updated with the latest version.

It will still use the AppData folder to store its preferences, but if you make a shortcut and use --portable as a command line option, options will be stored in the same folder as the .exe file. If you supply a folder after the portable option (for instance: EliteG19s.Windows.exe --portable "C:\Temp\EliteG19s") it will store the configuration file there.

And if you run into any trouble, please let me know and I'll try to help you get it working!
 
Last edited:
I have a suggestion:

using EdProxy you can set a link to the IP addess that shares the logs files to any authorized other machine...
Then you can use the g19 standalone on any machine including making a Android app out of it.
I think you can't include the EdProxy in the package, just tell people it needs to be placed on the game install machine (I could be wrong, but I can't see how)
Check out these

https://forums.frontier.co.uk/showthread.php?t=167688
http://edcodex.info/?m=tools&entry=255
 
I have a tablet , which I use a second screen to access the apps tools browsers for games , and the G19 , is great because I can use it via the Tablet , as well as seeing it on my G19 keyboard , very good app
 
Last edited:
Top Bottom