Having trouble binding certain combos

I play on a gamepad, so I've got lots of A/B/X/Y+D-pad/shoulder combos. But I wanted more, so I tried binding some stuff to A/B/X/Y+triggers.

But it doesn't work right. Say X is bound to hardpoints, and X+RT is headlights. If I press and hold X, pause, and then hit RT, it triggers my headlights as expected. But if I press X+RT together, I get hardpoints and headlights. If I hold X, pause, and hit RT twice quickly, the first click triggers headlights, the second hardpoints and headlights. It feels like hitting any button in the combo starts a brief cooldown, and if I hit another before it runs out, I get an extra X press.

I also tried binding stuff like A+X+D-pad left, and had the same problem. Holding down A+X is fine, but if I hit Left too soon, then it acts like I just hit both A and X separately.

"Enable Context Menu" is turned on, if that matters. I've googled a fair bit, and found a few people having similar problems, a few more people saying it works fine for them, and no solutions either way.

Is there any way to fix this?
Top Bottom