Logging in

Status
Thread Closed: Not open for further replies.
Today, when I activated the launcher, instead of the game starting, I got a large orange square with a rotating blue circle in the middle and it says "logging in" at the top of the screen. What do i have to do to solve that and play the game?
 
same here……. Cant loggin, Launcher says in grey "install" after killing ED exe with Task Manager to Interrupt 10 minutes the orange loginsquare….
20 Minutes later it worked again as intented
 
Last edited:
After more than 5000 hours playing the game, that's the first time I've seen that screen. It must be something new. I went away for an hour or so, and when I came back, it had logged on ready to play.
 
Well, it's an old issue rearing its head again. Played earlier today fine. Now it wants an update that never comes. Tried verifying file integrity, which it did without failure, but to no avail. Still wants an update. That's on steam right now.
 
Steam seems to be having issues with its store front (at least where im sitting) Since frontier changed their steam/ED login process, maybe the issue is linked. Something wrong with steam servers?

---

Steam store just kicked in.....

SUMMER SALE.....!!

 
Status
Thread Closed: Not open for further replies.
Top Bottom