Problem with mixed(?) Horizons/Odyssey mission

The problem is I received a Horizons-style mission (via message) to fetch some cargo (military plans, 3 units) from a degraded emissions space POI, and deliver them to an Odyssey settlement (Dino Outpost in Vesper-M4). Going into the in-ship mission board dhows the blue triangle on the mission board button in the "select mission board" menu, but once in the actual mission board, there's no option to complete the mission.

Of course, I tried Horizons, but because it's an Odyssey settlement rather than a Horizons settlement, the game tried to put me back in orbit (so I abandoned that path).

@sallymorganmoore I haven't done up a bug report yet (because I may have simply missed something that should be obvious), but I could do with some advice.
 
It could be this....

 
This is exactly why I hadn't filed a report, as I very strongly suspect that is what I overlooked. I'll check as soon as I can (maintenance). Thank you.
I'm not saying it will work, but it's worth checking - I was about to raise an issue about another mission being impossible when I spotted it was in the depot list.
 
I can find no depot button (which screen should it be in?). I do seem to remember seeing (and using) such once before, but.... I checked the factions and there is a mismatch: outpost is owned by "Revolutionary Vesper-m4 Liberals", but the mission was given by "Nationals of Vesper-m4".
 
I can find no depot button (which screen should it be in?).
Mission board - it's on the right - under the 'completed missions' button (if that's there)

Edit: I think they're probably broken by the 'wrong faction' issue, but was worth a check :)
Edit: For future reference : Like this - it goes amber, not blue ....

1634196828562.png
 
Last edited:
Yeah, found the depot button thanks to a different mission (data delivery to a station). Thanks for the info on what to look for, though. Very much appreciated.
 
Hello! Just wanted to say I'm here having a watch. Let me know if there's anything I majorly need to run with in terms of being stuck in a pickle - but the confusion part is massively interesting in itself as something to look into, so don't think I've not noticed :)
Thanks sally! Ideally the 'depot' button would go blue when there is something interesting there maybe? We're already trained to look for blue of the 'completed missions' button - might be worth feeding back to the devs. But those missions you pick up in space seem to have extra issues as well :)
 

sallymorganmoore

Community Manager : Elite Dangerous
Frontier
Thanks sally! Ideally the 'depot' button would go blue when there is something interesting there maybe? We're already trained to look for blue of the 'completed missions' button - might be worth feeding back to the devs. But those missions you pick up in space seem to have extra issues as well :)

Beautiful additional thoughts for me this early into coffee morning. Appreciate you, Factabulous!!
Got a fair few mission bits under my belt so will make sure to hone in on any new noises in that area based off this. Just to make sure.
 
The problem is I received a Horizons-style mission (via message) to fetch some cargo (military plans, 3 units) from a degraded emissions space POI, and deliver them to an Odyssey settlement (Dino Outpost in Vesper-M4). Going into the in-ship mission board dhows the blue triangle on the mission board button in the "select mission board" menu, but once in the actual mission board, there's no option to complete the mission.

Of course, I tried Horizons, but because it's an Odyssey settlement rather than a Horizons settlement, the game tried to put me back in orbit (so I abandoned that path).

@sallymorganmoore I haven't done up a bug report yet (because I may have simply missed something that should be obvious), but I could do with some advice.

Got one mission from the space blue POI - fetch some cargo to settlement X.
Did that, but landing at the settlement, while having the blue corner on the mission button, showed no mean to deliver that cargo
The Completed Missions and Cargo Depot were simply missing.
 
The Completed Missions and Cargo Depot were simply missing.
I do wonder if the Depot button is assuming it will be visible - but is actually only added when the 'Completed' one is present or something. I don't think I've even seen many space missions (other than Tip Offs, I have plenty of those :) )

Edit: Though most probably it is just the mismatched factions.
 
Hello! Just wanted to say I'm here having a watch. Let me know if there's anything I majorly need to run with in terms of being stuck in a pickle - but the confusion part is massively interesting in itself as something to look into, so don't think I've not noticed :)
Thanks, Sally. I guess the big thing to pass onto devs (not far of what @Factabulous said) is to ensure the mission and depot buttons are always visible, and to either ensure that the destination is owned by the mission providing faction, or to allow deliveries across factions.
 
I do wonder if the Depot button is assuming it will be visible - but is actually only added when the 'Completed' one is present or something. I don't think I've even seen many space missions (other than Tip Offs, I have plenty of those :) )

oh well, maybe next time i should try to complete a random mission too...
 
The problem is I received a Horizons-style mission (via message) to fetch some cargo (military plans, 3 units) from a degraded emissions space POI, and deliver them to an Odyssey settlement (Dino Outpost in Vesper-M4). Going into the in-ship mission board dhows the blue triangle on the mission board button in the "select mission board" menu, but once in the actual mission board, there's no option to complete the mission.

Of course, I tried Horizons, but because it's an Odyssey settlement rather than a Horizons settlement, the game tried to put me back in orbit (so I abandoned that path).

@sallymorganmoore I haven't done up a bug report yet (because I may have simply missed something that should be obvious), but I could do with some advice.
I can confirm that I have encountered this exact bug before, in update 6. I did not make a bug report about it because i was tired of making bug reports and had no time. But i took some screenshots.

20210831003624_1.jpg

20210831003635_1.jpg


Missing the last screenshot but I couldn't find any option to actually turn it in beyond this screen.
 
Top Bottom