TMTK Update old item issue

Has anyone else experienced this, and if so how did you fix it ?
I've raised the issue with Steam Support, but they just pushed it back and said it was a PlanetCoaster issue, so Frontier need to sort it out.

Basically, I have an item I've trying to update - but it's on about page 3 or 4 of my past items.
But when I try to navigate to the other pages, it just hangs and says "loading" in the bottom right, and never changes to other pages.
I've tried selecting the page I want, and also tried just clicking the right chevron arrow - but makes no difference.
And sometimes I get the error box popup saying that Planet Coaster has stopped responding, and do I want to close the application.

Just to add, this is happens on 2 completely different installations - one on Desktop, and one on Laptop - so it's not an install issue. It's something to do with the backend service.
yes this has been an issue scents the beginning of tmtk, most of us just make a comment in the original file letting users know the object has been updated and provide a link. then after a month we delete the original post of the object. by then any one using it should have the newer version.
Top Bottom