Patch Notes Update Update 3.3.05

Better.

But you don't know the complexity of CheckIfAlreadyScanned() nor Say(). Nor the restrictions placed on your event handlers (ie, what the context of the calling code is). Depending on existing locks you could quickly end up in a deadlock situation. You also don't check the return value of lock()/unlock()... so you have no idea whether or not you actually got the lock. Naughty!

Basically, -anything- is trivial to fix in isolation. It rapidly becomes non-trivial in a real software project which has multiple engineers working on it. And multiple includes yourself from a week ago, the details of which you've forgotten as you've moved onto another task in the meantime.
LOL - so err yeah, my cunning plan to prove that coding even the seemingly simplest of functions in a complex system is difficult worked perfectly! [yesnod] :p
 
As you well know, keybindings are *not* in that xml file.

I don't mess with the default bind files, either.

I'm all too aware that I get steamrollered with each update.

We should *not* have to create our own persistent files.

I have had about four years and three months experience of Frontier blowing up things with every patch.

Please do not treat me as a child.
I don't treat you as a child nor do I imply that these things are trivial and I absolutely agree with you that these things should be much better supported by the game client. What I do not understand though is your stubbornness that let you suffer for years instead to accept the things how they are and adapt to it. In this regard you actually do react like a little angry and stubborn child, yes.
 
Not sure how you've set up your system, but it's been ages since I've lost my binds (on both laptop and PC).

I still back them up after making changes just in case, but haven't had to restore them in a long time.

The only thing that bugs me is that the key binds refuse to load if my EdTracker doesn't get detected by Windows (which happens randomly, I'm sure it's related to Windows patches, sometimes it breaks for months on end, other times it works for a while). My last-selected binds should always load, and just pop up a dialog saying that one (or more) devices could not be found and would I like to continue or choose a different binds file.
I have a very similar problem with EDTracker, has nothing to do with Windows updates though (was from day one) and happens always on reboot of the PC: It does not recognize the EDTracker unless I re-plug the USB jack. I'm suspecting a weak USB implementation of my mainboard as the culprit.

edit:
Forgot to mention that in this case, without re-connecting the USB plug, my keybindings are also not recognized. This suggests that potentially every broken or shaky periphery that is stored in your bindings file can cause this effect. That's certainly not high quality industry standard of programming as the user should at least be informed about what specific periphery can't be found and not just silently(!) fall back to default settings.
 
Last edited:
Blimey; breaking something to fix something else? That's not good software engineering, I'm sorry to say. And I can't think of a situation where that would be necessary (typically very vague response in there). But then again I don't know the complexities of the software. I know how easy it can be to program yourself into a dead-end when you don't have all the requirements at the start, and at some point fixing some edge cases becomes a case of diminishing returns. As always fixing something for the majority has to take precedence over something impacting only a few.

But that's why I love open source projects - everybody has the opportunity to fix their particular edge case if they so wish while the project owners can go ahead with major feature development. Don't tend to see that often in commercial products though.
 
I have a very similar problem with EDTracker, has nothing to do with Windows updates though (was from day one) and happens always on reboot of the PC: It does not recognize the EDTracker unless I re-plug the USB jack. I'm suspecting a weak USB implementation of my mainboard as the culprit.
For the last couple of months that was the case for me too. For the last week or two, EdTracker has been recognised on bootup so I've not had to replug it. As far as I know, the only thing that's changed is some minor Windows updates. (Running Win10 Pro 1803)
 
For the last couple of months that was the case for me too. For the last week or two, EdTracker has been recognised on bootup so I've not had to replug it. As far as I know, the only thing that's changed is some minor Windows updates. (Running Win10 Pro 1803)
Yes, there was a Windows update just recently. Did that too but didn't help. The only time it was mysteriously fixed was after an nvidia driver update some time ago but didn't last all too long. Could not reproduce this behavior - I still have to plug off plug in the USB jack everytime after booting my PC. But if I don't, I can very well reproduce how the game fails to use my own (renamed!) custom configuration file: it's invisible then in the Controls menu!
 
I don't treat you as a child nor do I imply that these things are trivial and I absolutely agree with you that these things should be much better supported by the game client. What I do not understand though is your stubbornness that let you suffer for years instead to accept the things how they are and adapt to it. In this regard you actually do react like a little angry and stubborn child, yes.
Thank you, Doctor.

Your application for Beige Squadron has been accepted.
 
Last edited:
Yes, there was a Windows update just recently. Did that too but didn't help. The only time it was mysteriously fixed was after an nvidia driver update some time ago but didn't last all too long.
Eh, interesting; I hadn't considered NVidia Driver version to have an impact; this could be the case too. I'll (try to remember to) pay attention next time I update the driver to see if it impacts EdTracker...


Could not reproduce this behavior - I still have to plug off plug in the USB jack everytime after booting my PC. But if I don't, I can very well reproduce how the game fails to use my own (renamed!) custom configuration file: it's invisible then in the Controls menu!
Yep, but then replugging shows my custom binds. No need to restart the game.

It would really be awesome if a controller could either be marked "optional" or just let the user load the file no matter what. Seriously, the worst is that some inputs aren't available, and like I mentioned, a small warning message to let the person know would suffice. Then the person can either change control schemes if the missing input is important enough, or just go ahead if it's optional like a head tracker.
 
Greetings Commanders,

The Elite Dangerous servers will be offline for PC at 13:00 (UTC) today for approximately 5 minutes to apply the 3.3.05 patch.

This patch will address the crash that can occurring from dropping out of Supercruise (either by choice, or after an interdiction).

We’re aiming to roll out the Xbox One and PlayStation 4 fix for this on 21 Thursday. More information about that when we have it.

Thank you for your understanding!
thx for the interdiction bug fix can't wait but will the patch address some of my ships jump range shortening i have a 26ly jump range(cutter) but can only jump 9ly max whether laden or unladen.
 
Yes let's thank them to deliver a patch to correct the mess from previous patch.... As always with FD....
just being polite but i will have to wait for a patch to fix what breaks with this one today they said they employed 100 extra personnel how many were testers 0 should have been 105 we should also have a option to delete the download if its a bust and still play the game it is a classic case of the left hand does not what the right hand is doing.
 
LOL - so err yeah, my cunning plan to prove that coding even the seemingly simplest of functions in a complex system is difficult worked perfectly! [yesnod] :p
Why would you even use locking for the issue at hand. To me this seems to be a state of the Player object, so all responsibility for managing the state lies with the Player object. So no need for a global at all, just an update to the Player object.
 
Last edited:
TIP:

For anybody that is still having crashing issues to desktop, I've found that installing Net Framework 3.5 will help. Just go to Control Panel -> Turn Windows features on or off, then
expand the + sigh and check the 2 items. This will enable your windows updates and patches to install properly.
 
just being polite but i will have to wait for a patch to fix what breaks with this one today they said they employed 100 extra personnel how many were testers 0 should have been 105 we should also have a option to delete the download if its a bust and still play the game it is a classic case of the left hand does not what the right hand is doing.
er er I fort it wer " The left hand does not know what the other left hand is doing " ??? maybe I Iz rong.
 
Hard Drives lost in space.

A while back (.05) I waxed lyrical about the removal of the Help The Destitute Black Marketeers fix in which the Pickup Lost Hard Drives missions never completed - allowing the ammassing of lots of Hard Drives that can only be sold on the Black Market.:cool: (several other like missions were the same - never completing) - well I picked up a nice hard drive mission an BINGO it refused to complete, but I will have to make quite a few trips to the black Marketeer to get my money - GRRRR
How do I complain about it to FDEV ? (tickets seem to be voberten now).
T.I.A. Mijk
 
THANK YOU!!!
After months of not being able to play this is fixed. I have just had one incident with disconnect. And that was nothing like the usual disconnects so I did not even bother to report it. I have mined, been pirate hunting, beeing interdicted, jumped in and out of USS and not one single disconnect! So great work :)

I can mention that the disconnect I got was on a mission I was not able to complete. I hunted down the pirate, but the pirate had not status "Mission target", so after killing him 6 times with a great bounty on each kill I gave up, and the mission timed out. It was when I abandoned that mission I got a disconnect "could not connect to adjudication server". But this time it disconnected instantly. The second I pushed the button and confirmed, the game disconnected - no waiting at all. And after reloading the game i was able to abandon the mission with no disconnect.
 
Top Bottom