At the end of my wits with connection issues..

Hi everyone,

no idea what's going on here but I can't maintain a connection to Elite for enough to have even the most simplest of play sessions. I can start (and endlessly restart) the game with zero issues but I get constant 'connection error = could not connect to the matchmaking server. Press OK to return to main menu'.

As soon as I return to main menu it immediately reconnects to the server and lets me start the game again.

Here's where it most often occurs (this could just be because it's what I'm trying to do right now);

  • drops when supercruising.. usually closer to my destination (causing me to respawn at the starting point of my journey... incredibly frustrating when I'm going for something 10k+ LS away)
  • shortly after using and exiting FSS
  • when exiting supercruise
  • when I'm at my most emotionally vulnerable and trying to score just ONE GODDAMN CHEMICAL PROCESSOR TO FINISH MY G3 FSD what are you doing
Not sure what else to add... I have NBN (Australia's 'fast' network) and no other issues. I've deleted local saves on the xbox, my UPNP is definitely switched on in my router. I'm also in a party most of the time (but it does happen when solo).

Absolutely tearing my hair out, I don't want to play anything else!

Anyone have any ideas?
 
Last edited:
I remember when I had connection problems with the Mission Board (basically any time I opened it the game lost connection) I exchanged messages with Frontier Support. This went on for months and there was no solution. The final solution was that I replaced my router with a much more expensive, stronger and faster one. (Note that I tried the game on both wired and wireless connection). That solved it, although before a given update the game worked perfectly for years with my older router, too. The same story happened to my friend. He also had to exchange his router and that solved it for him, too.

The only advice I can give you apart from the obvious things (try wired and wireless, make sure NAT is open, restart every network device etc) is that if all else fails, replace your router, or somehow try the game on another router (possibly at a friend's place or something). Or borrow another device to try. Because even though it was Frontier who changed something, in the end it might be you who have to adapt to something new in order to be able to play properly.
 
I remember when I had connection problems with the Mission Board (basically any time I opened it the game lost connection) I exchanged messages with Frontier Support. This went on for months and there was no solution. The final solution was that I replaced my router with a much more expensive, stronger and faster one. (Note that I tried the game on both wired and wireless connection). That solved it, although before a given update the game worked perfectly for years with my older router, too. The same story happened to my friend. He also had to exchange his router and that solved it for him, too.

The only advice I can give you apart from the obvious things (try wired and wireless, make sure NAT is open, restart every network device etc) is that if all else fails, replace your router, or somehow try the game on another router (possibly at a friend's place or something). Or borrow another device to try. Because even though it was Frontier who changed something, in the end it might be you who have to adapt to something new in order to be able to play properly.
I had a similar situation with the mission server and a new router solved it. One thing I did try before that was setting my phone as a wireless hotspot and connecting my Xbox through that. Once I saw that worked I concluded it was most likely my modem/router to blame.
 
I know this made sound elementary and overly simple, but, just plug the Xbox in. I had issues for a long time connecting wirelessly to my router/modem. I just assumed it was on FDev's end...then one day, I got fed up and thought, I wonder would these issues go away if I hardwired the XBox into the router/modem. Since that day, it's a night and day difference.

Plug it in.
 
I'm still having constant errors. Takes 2-3 attempts to start the game (solo or open), and then I can't access mission boards (always times out with a "unable to connect to server" message). Tried to just head off and do some mining, and every time I use my FSD the game hangs and crashes when I try to come out of it, regardless of whether it's a jump to a new system or supercruise. Message is always a failure to connect to the adjudication server. Once it's crashed me back to the main menu, I have to exit to the home screen, manually close Elite, and then restart it, or I'm unable to start a new session.

It's been unplayable all year, and I've no idea what to try. I've got a 350Mb connection, the Xbox is wired, I've reinstalled, changed storage, cleared caches, restarted and factory reset my router, pretty much everything I can think of.
 
I crash to dashboard a solid 30% of the time when travelling a whopping 90ls from the hazres to my home station.

Didn't wanna spawn back at the Haz?

Too bad.
 
I had a similar situation with the mission server and a new router solved it. One thing I did try before that was setting my phone as a wireless hotspot and connecting my Xbox through that. Once I saw that worked I concluded it was most likely my modem/router to blame.
I used that method for a while, too. It cost me quite some money, though, thanks to the mobile net being more expensive than gold in my country. However, I refused to blame my old router. The game itself changed in some way that made Mission Boards unusable right after an update. Prior to that it was just fine. Anyway, I replaced my router and it works ever since.

To the OP: If you can, try connecting through your mobile phone (network tethering or whatever the function is called). According to my measurements Elite uses ~30 MB of data per hour on average. If you can buy some mobile data, try it to see if it works.
 
I didn't hotspot my phone for long, just to experiment.

What I discovered was that the times I was completely unable to connect to the adjudication server and enter the game, were also times when I had an active mission on my account.

When I connected my xbox through my phone and handed in the mission I was then able to enter the game again via my router, which made me think having the mission on my account was what was preventing me from connecting through my router.

Something evil going on with that mission server.
 
I had to stop playing on Xbox around 2.3-ish because of constant connectivity issues. Multiple emails to support got nowhere. Worked fine on PC.

Finally found that was something to do with IPv6 - elite started supporting it as did my ISP, and for reasons still beyond me it just doesn’t work on (my) Xbox. Solution: asked ISP to put me back on IPv4. Instant fix. Wish I had discovered this a year ago!
 
I didn't hotspot my phone for long, just to experiment.

What I discovered was that the times I was completely unable to connect to the adjudication server and enter the game, were also times when I had an active mission on my account.

When I connected my xbox through my phone and handed in the mission I was then able to enter the game again via my router, which made me think having the mission on my account was what was preventing me from connecting through my router.

Something evil going on with that mission server.
I had exactly the same problem with having an open mission and getting the adjudication server error, tried the 4g phone connection which worked and now working fine on WiFi, so best not leaving game with open missions if possible.
 
I remember when I had connection problems with the Mission Board (basically any time I opened it the game lost connection) I exchanged messages with Frontier Support. This went on for months and there was no solution. The final solution was that I replaced my router with a much more expensive, stronger and faster one. (Note that I tried the game on both wired and wireless connection). That solved it, although before a given update the game worked perfectly for years with my older router, too. The same story happened to my friend. He also had to exchange his router and that solved it for him, too.

The only advice I can give you apart from the obvious things (try wired and wireless, make sure NAT is open, restart every network device etc) is that if all else fails, replace your router, or somehow try the game on another router (possibly at a friend's place or something). Or borrow another device to try. Because even though it was Frontier who changed something, in the end it might be you who have to adapt to something new in order to be able to play properly.
I’ve just replied on another thread about this and totally agree with you
Hi everyone,

no idea what's going on here but I can't maintain a connection to Elite for enough to have even the most simplest of play sessions. I can start (and endlessly restart) the game with zero issues but I get constant 'connection error = could not connect to the matchmaking server. Press OK to return to main menu'.

As soon as I return to main menu it immediately reconnects to the server and lets me start the game again.

Here's where it most often occurs (this could just be because it's what I'm trying to do right now);

  • drops when supercruising.. usually closer to my destination (causing me to respawn at the starting point of my journey... incredibly frustrating when I'm going for something 10k+ LS away)
  • shortly after using and exiting FSS
  • when exiting supercruise
  • when I'm at my most emotionally vulnerable and trying to score just ONE GODDAMN CHEMICAL PROCESSOR TO FINISH MY G3 FSD what are you doing
Not sure what else to add... I have NBN (Australia's 'fast' network) and no other issues. I've deleted local saves on the xbox, my UPNP is definitely switched on in my router. I'm also in a party most of the time (but it does happen when solo).

Absolutely tearing my hair out, I don't want to play anything else!

Anyone have any ideas?
ive already replied on another thread on these problems and totally agree with you. This is a frontier created problem and only they can solve this not us attempting to carry out other posters solutions, by the way I’ve done them all, they don’t work the same issues have been occurring regularly since 12/2018 for me and I played the game for a significant amount of time without issue before that. So like my other post and there are plenty others ... FIX IT frontier 😡😡😡
 
Things I'd recommend to avoid like the plague with ELITE :

- UPnP (dubbed "Universal Plug & Pray")
Can cause a huge amount of problems and disabling it typically works wonders for improving instancing and removing almost or even all types of distinct lags or Server disconnects.

- WLAN
Nothing beats a good old LAN Cable attached to the Device, plus it's far more secure.

Other than that, in freak cases (Provider blocking, re-routing or slowing UDP Packets from Port numbers it doesn't recognize) one can contact the Provider's Customer Support and have this checked out. Depends on the quality of the Provider though, so there's no guarantee to even get a professional response.
 
It’s still broken ... despite the new thread about a possible fix, my router was already set correctly. I still believe this has nothing to do with the Xbox, router but is everything to do with ED servers, yes there may be the odd person that seems to have a genuine problem at their end but the amount of cmdrs complaining about this says it’s not our hardware. Why do I not have this problem with other games it’s only this one that drives you mad 😡
FD you can always call in the white mice from Bagpuss they’re probably our best hope now 😳
 
It’s still broken ... despite the new thread about a possible fix, my router was already set correctly. I still believe this has nothing to do with the Xbox, router but is everything to do with ED servers, yes there may be the odd person that seems to have a genuine problem at their end but the amount of cmdrs complaining about this says it’s not our hardware. Why do I not have this problem with other games it’s only this one that drives you mad 😡
FD you can always call in the white mice from Bagpuss they’re probably our best hope now 😳
So what did support say? Or are you still following the voodoo and witchcraft on here?
 
Top Bottom