Detailed DK2/CV1 Setup Guide with Oculus Runtime 1.3+

drkaii

Volunteer Moderator
CV1

1) Uninstall your Oculus runtime and other software and restart. [NB: If upon restart your desktop is weird and no windows open, your Oculus needs to be turned off (in some cases it becomes the primary screen)]
2) Download the software here: https://www.oculus.com/en-us/setup/
3) Run it and let it begin downloading the drivers
4) Download the latest Nvidia Drivers and install them in the meantime. Don't restart until the drivers have finished downloading on Oculus
5) Go through the wizard, setting up an account etc. When you get to the bits about setting up the CV1, plug it in, wait for it to detect, then follow all instructions about position, comfort, calibration etc. - they are very clear
6) The Home will open - put the CV1 on
7) In the DESKTOP version of Home (both are always open), go to settings > general > Allow unknown sources - switch this last on*
8) Run Elite, switch to HMD (Speakers/Headphones) and you might need to restart after this
9) Start the game, if it bugs out don't worry, start it again and second time should be fine.

*You can get a key to switch the game to the oculus store, and you won't need to do this step.


I don't actually have a CV1, but this was all pretty obvious from setting up the DK2. Feel free to correct or add to this if I am wrong :)

Getting mine in MAY!

If you get the error:
RESTART COMPUTER
Sorry, we encountered an error during installation.



  1. Open the start menu and run regedit
  2. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Oculus VR, LLC
  3. Right click Oculus VR, LLC, and click Permissions
  4. You should get a dialog about permissions being incorrectly ordered. Click Reorder
  5. Click OK in the other dialog that pops up
  6. Try installing again
https://forums.oculus.com/community/discussion/32370/unofficial-workaround-for-access-control-list-not-in-canonical-form-error-during-oculus-setup

(thanks SyFy: https://forums.frontier.co.uk/reputation.php?do=addreputation&p=3720152)

p.s. if you ever find yourself in the situation where you simply cannot install it at all, it downloads and then fails each time, delete the two above keys (make sure to export them first)
 

drkaii

Volunteer Moderator
Getting the DK2 working with Oculus Runtime 1.3

DK2

1) Uninstall your Oculus runtime and other software and restart. [NB: If upon restart your desktop is weird and no windows open, your Oculus needs to be turned off (in some cases it becomes the primary screen)]
2) Download the software here: https://www.oculus.com/en-us/setup/
3) Run it and let it begin downloading the drivers
4) Download the latest Nvidia Drivers and install them in the meantime. Don't restart until the drivers have finished downloading on Oculus
5) Go through the wizard, setting up an account etc. When you get to the bits about setting up the CV1, just skip most of it, including the bit where you have to plug in your rift and get it to detect etc. IGNORE THE WARNINGS ABOUT NOT DETECTED/NOT IN USB 3.0 PORT - just skip
6) The Home will open and you'll get a warning about the DK2 not being supported. Put the DK2 on and you will see that is not the case.
7) In the DESKTOP version of Home (both are always open), go to settings > general > Allow unknown sources - switch this last on
8) Run Elite, switch to HMD (Speakers/Headphones) and you might need to restart after this
9) Start the game, if it bugs out don't worry, start it again and second time should be fine.

Also, see this thread for getting it working beautifully otherwise, and for future tweaks etc.

https://forums.frontier.co.uk/showthread.php?t=121355

If you get the error:
RESTART COMPUTER
Sorry, we encountered an error during installation.

See post above this one

RUNTIME SWITCHER!:
https://www.reddit.com/r/oculus/comments/4ckm38/oculus_runtime_switcher_0506070813_with_gui/
 
Think I messed up. I downloaded the new SDK, followed the on screen instructions and rebooted before downloading the new nvidia drivers.

Now when I boot up, my desktop icons are gone, the only things visible is my desktop wallpaper and my task bar icons along the bottom of the screen. Not even the clock or bottom right icons are there.

When I click on a task bar icon, like firefox, Google, GeForce experience etc, the program opens but its not visible on my monitor. So I can't interact with anything.

Same as when I try to access regedit, I can load it, but can't see the screen to do anything in it.

Any help will be appreciated.
 
Think I messed up. I downloaded the new SDK, followed the on screen instructions and rebooted before downloading the new nvidia drivers.

Now when I boot up, my desktop icons are gone, the only things visible is my desktop wallpaper and my task bar icons along the bottom of the screen. Not even the clock or bottom right icons are there.

When I click on a task bar icon, like firefox, Google, GeForce experience etc, the program opens but its not visible on my monitor. So I can't interact with anything.

Same as when I try to access regedit, I can load it, but can't see the screen to do anything in it.

Any help will be appreciated.
Most likely, your desktop icons and programs are all being displayed on the rift.
 
So...
Drivers installed: Check
Oculus Home Installed: Check
Allow unknown sources: Check
Elite configured for HMD: Check

Then...

Why do I get a window in desktop with the game in low rez and headtracking but nothing on my DK2? :(
 

drkaii

Volunteer Moderator
So...
Drivers installed: Check
Oculus Home Installed: Check
Allow unknown sources: Check
Elite configured for HMD: Check

Then...

Why do I get a window in desktop with the game in low rez and headtracking but nothing on my DK2? :(
That is...unusual. Try all the usual reconnect cables/restart everything one by one/reinstall?
 
Just installed it and it works awesome in Ultra on GTX 980 and DK2 - super smooth. Only problem was sensor, hmd and hdmi were not recognised during setup and I had to choose skip. Nevertheless, once setup was complete all was working ok even though it said my sensor was plugged into a USB 2 port when it's definitely USB 3.
 
Just installed it and it works awesome in Ultra on GTX 980 and DK2 - super smooth. Only problem was sensor, hmd and hdmi were not recognised during setup and I had to choose skip. Nevertheless, once setup was complete all was working ok even though it said my sensor was plugged into a USB 2 port when it's definitely USB 3.

Same set up and situation as Bosh-Ra. Working like a champ with no perceptible judder. I downloaded the Nvidia drivers first then rebooted. Next step was the new Oculus software where the HMD and and sensor were not recognized. Skipped them and then rebooted. Still a little wonky so I re-read the thread and realized I needed to check "allow unknown sources" as mentioned above. Rebooted a 3rd time, started ED and I knew it was set right because my centering button lined up my view perfectly. This change to version 1.3 had me spooked but its working better than ever.
 
Nevertheless, once setup was complete all was working ok even though it said my sensor was plugged into a USB 2 port when it's definitely USB 3.
I was really confused by this during setup, until I realized that it's the DK2 sensor that's USB 2, which is keeping the port at that speed so long as it's plugged in.
 
CV1

1) Uninstall your Oculus runtime and other software and restart NB: If upon restart your desktop is weird and no windows open, your Oculus needs to be turned off (in some cases it becomes the primary screen)
2) Download the software here: https://www.oculus.com/en-us/setup/
3) Run it and let it begin downloading the drivers
4) Download the latest Nvidia Drivers and install them in the meantime. Don't restart until the drivers have finished downloading on Oculus
5) Go through the wizard, setting up an account etc. When you get to the bits about setting up the CV1, plug it in, wait for it to detect, then follow all instructions about position, comfort, calibration etc. - they are very clear
6) The Home will open - put the CV1 on
7) In the DESKTOP version of Home (both are always open), go to settings > general > Allow unknown sources - switch this last on*
8) Run Elite, switch to HMD (Speakers/Headphones) and you might need to restart after this
9) Start the game, if it bugs out don't worry, start it again and second time should be fine.

*You can get a key to switch the game to the oculus store, and you won't need to do this step.


I don't actually have a CV1, but this was all pretty obvious from setting up the DK2. Feel free to correct or add to this if I am wrong :)

Getting mine in MAY!
Thanks drkaii! As usual good and useful information from you :) I just wanted to mention that the latest Nvidia drivers (released yesterday, 28th) messed up some of my other games which is why I rolled back to 364.51, which seem to work perfectly fine for me in both ED and those other games.

It's really super smooth on my DK2 now, with all settings on max and (ingame) DSR on 1.5x (running on my GTX 980 Ti SLI), it's a real joy now :D
 
DK2

1) Uninstall your Oculus runtime and other software and restart NB: If upon restart your desktop is weird and no windows open, your Oculus needs to be turned off (in some cases it becomes the primary screen)
2) Download the software here: https://www.oculus.com/en-us/setup/
3) Run it and let it begin downloading the drivers
4) Download the latest Nvidia Drivers and install them in the meantime. Don't restart until the drivers have finished downloading on Oculus
5) Go through the wizard, setting up an account etc. When you get to the bits about setting up the CV1, just skip most of it, including the bit where you have to plug in your rift and get it to detect etc.
6) The Home will open and you'll get a warning about the DK2 not being supported. Put the DK2 on and you will see that is not the case.
7) In the DESKTOP version of Home (both are always open), go to settings > general > Allow unknown sources - switch this last on
8) Run Elite, switch to HMD (Speakers/Headphones) and you might need to restart after this
9) Start the game, if it bugs out don't worry, start it again and second time should be fine.

Also, see this thread for getting it working beautifully otherwise, and for future tweaks etc.

https://forums.frontier.co.uk/showthread.php?t=121355
Thanks man, followed your guide and got everything working on the first attempt. It works really well now.
 
Sorry to report a failure on this. I get the error
RESTART COMPUTER
Sorry, we encountered an error during installation.
Please restart your computer and try running Oculus Setup again. If you still experience issues, contact Oculus Support.
QUIT

I have cleared up all old files, run as administrator updated all Nvidia drivers, followed some useful info in the video here: http://www.vrspies.com/2016/03/OculusRiftSetup.html?m=1

No luck. I just have to download 842Mb each time then it fails.

Please help

---------------

Edit. Resolved. I looked in C:\Users\Appdata\Oculus\ where I found a setup log file (%LOCALAPPDATA%\Oculus\OculusSetup.log). In there I identified the same issues with "[h=1]access control list not in canonical form"[/h]or [Error] [29/03/2016 08:40:57] Uncaught exception!System.InvalidOperationException: This access control list is not in canonical form and therefore cannot be modified.
at System.Security.AccessControl.CommonAcl.ThrowIfNotCanonical()
at System.Security.AccessControl.CommonAcl.AddQualifiedAce(SecurityIdentifier sid, AceQualifier qualifier, Int32 accessMask, AceFlags flags, ObjectAceFlags objectFlags, Guid objectType, Guid inheritedObjectType)
at System.Security.AccessControl.DiscretionaryAcl.AddAccess(AccessControlType accessType, SecurityIdentifier sid, Int32 accessMask, InheritanceFlags inheritanceFlags, PropagationFlags propagationFlags)
at System.Security.AccessControl.CommonObjectSecurity.ModifyAccess(AccessControlModification modification, AccessRule rule, Boolean& modified)
at System.Security.AccessControl.CommonObjectSecurity.AddAccessRule(AccessRule rule)
at Dawn.Setup.InstallLibrarianStep.CreateRegistryKeys()
at Dawn.Setup.InstallLibrarianStep.InstallImpl()
at Dawn.Mixins.SafeCallMixin(Func`1 func, String title, String caller)

This matches the issue shown in the following link which gives the correct work around.

https://forums.oculus.com/community/discussion/32370/unofficial-workaround-for-access-control-list-not-in-canonical-form-error-during-oculus-setup

It is to do with badly ordered permissions in the registry, which can be resorted by regedit.
good luck!
Stu
 
Last edited:
So...
Drivers installed: Check
Oculus Home Installed: Check
Allow unknown sources: Check
Elite configured for HMD: Check

Then...

Why do I get a window in desktop with the game in low rez and headtracking but nothing on my DK2? :(
I get a similar. It's like Elite refuses to detect my DK2. Not even any head tracking. I don't even get the option to configure the HMD.

EDIT: After rebooting I get exactly the same. The game displays on the monitor in low rez with head tracking.

EDIT2: I'm wondering if this is because I don't have a correct spec Video card. I'm currently running a GTX770. Note though that the Oculus store runs perfectly.
 
Last edited:

drkaii

Volunteer Moderator
Unfortunately I don't work with Frontier or Oculus so I don't know how to get round all these problems off hand but I will help you by doing some research and seeing if there are any solutions.


I think I'll also re-install it, but on my wife's laptop and record each step as that might help some people. Keep an eye on this thread :)
 
Sorry to report a failure on this. I get the error
RESTART COMPUTER
Sorry, we encountered an error during installation.
Please restart your computer and try running Oculus Setup again. If you still experience issues, contact Oculus Support.
QUIT

I have cleared up all old files, run as administrator updated all Nvidia drivers, followed some useful info in the video here: http://www.vrspies.com/2016/03/OculusRiftSetup.html?m=1

No luck. I just have to download 842Mb each time then it fails.

Please help
https://forums.oculus.com/community/discussion/32370/unofficial-workaround-for-access-control-list-not-in-canonical-form-error-during-oculus-setup


  1. Open the start menu and run regedit
  2. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Oculus VR, LLC
  3. Right click Oculus VR, LLC, and click Permissions
  4. You should get a dialog about permissions being incorrectly ordered. Click Reorder
  5. Click OK in the other dialog that pops up
  6. Try installing again
 
CV1

1) Uninstall your Oculus runtime and other software and restart NB: If upon restart your desktop is weird and no windows open, your Oculus needs to be turned off (in some cases it becomes the primary screen)
2) Download the software here: https://www.oculus.com/en-us/setup/
3) Run it and let it begin downloading the drivers
4) Download the latest Nvidia Drivers and install them in the meantime. Don't restart until the drivers have finished downloading on Oculus
5) Go through the wizard, setting up an account etc. When you get to the bits about setting up the CV1, plug it in, wait for it to detect, then follow all instructions about position, comfort, calibration etc. - they are very clear
6) The Home will open - put the CV1 on
7) In the DESKTOP version of Home (both are always open), go to settings > general > Allow unknown sources - switch this last on*
8) Run Elite, switch to HMD (Speakers/Headphones) and you might need to restart after this
9) Start the game, if it bugs out don't worry, start it again and second time should be fine.

*You can get a key to switch the game to the oculus store, and you won't need to do this step.


I don't actually have a CV1, but this was all pretty obvious from setting up the DK2. Feel free to correct or add to this if I am wrong :)

Getting mine in MAY!
Thanks. I had just done this pretty much as you described before jumping into the forum and it all worked fine.

USB 2 thing threw me as well as setting other apps to be able to use the Rift but all OK in the end apart from forgetting to save my custom colours in ED.

Very annoying... as I've been waiting for 1.3 to upgrade to Win 10 I did a full fresh install prior to doing all this. Funny how I didn't notice when playing in 2D on my monitor over the weekend but the minute you get the Orange colours in the Rift you can tell it's a poor choice for VR.
 
Can I just ask what performance and setting people are using?

I have 980Ti-4690K-8GB, and I have to dial back shadows and a few other things (especially planet terrain settings) in order to keep a decent frame rate.

Even still have to overclock the card to 1400mhz to get fluid gameplay.
 
Top Bottom