Detailed DK2/CV1 Setup Guide with Oculus Runtime 1.3+

drkaii

Volunteer Moderator
https://forums.oculus.com/community/discussion/32370/unofficial-workaround-for-access-control-list-not-in-canonical-form-error-during-oculus-setup


  1. Open the start menu and run regedit
  2. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Oculus VR, LLC
  3. Right click Oculus VR, LLC, and click Permissions
  4. You should get a dialog about permissions being incorrectly ordered. Click Reorder
  5. Click OK in the other dialog that pops up
  6. Try installing again

Thanks, adding to main post +1 rep
 
So...
Drivers installed: Check
Oculus Home Installed: Check
Allow unknown sources: Check
Elite configured for HMD: Check

Then...

Why do I get a window in desktop with the game in low rez and headtracking but nothing on my DK2? :(
I have the same issue here.

All drivers installed OK, latest (AMD) graphics drivers installed, the Oculus app tells me that everything is connected & happy - but can't get anything to actually display in the DK2 headset. :(

I also have a message saying that my computer is below spec & the DK2 is unsupported. I'm wondering if it's complaining about my AMD 7870 graphics card.
 
The oculus runtime link in the OP installs v1.0 and not v1.3!
If we are not developers, is the runtime v1.0 fine or do we need to also install V1.3 SDK?


Edit: Sorry my mistake it is v1.3, it's only the CV1 hardware setup window/page that was showing 1.0.
 
Last edited:
Can I just ask what performance and setting people are using?

I have 980Ti-4690K-8GB, and I have to dial back shadows and a few other things (especially planet terrain settings) in order to keep a decent frame rate.

Even still have to overclock the card to 1400mhz to get fluid gameplay.

I'm on an i7 and GTX 980 and it's running smooth in Ultra and VR High modes - I can't really tell the difference between the two modes except maybe there is some cool temporal visual shifts on planetary bodies when jumping in Ultra mode that I haven't seen in other modes.. All seems to be working superb - only snag is that now Steam VR appears to be broken so none of my other VR games like Project Cars etc are working any more on my DK2.
 
Drkaii, thanks for this. I have got my DK2 running using SDK 1.3. Before I was using SDK 0.8 and SteamVR, as per your previous set of instructions. I have to say the VR makes the game, and I would not have managed this without your help. Thanks, and I will rep you when I can.

Now able to send you a rep, so I did.
 
Last edited:
Thank you very much for your guide drkaii! Worked great for my DK2. After about a year i'm enjoying Elite with the rift again!
Great!!!
 
Thanks to the OP for the detailed instructions.

I've followed those. I have also transferred my Elite over to Oculus Home. I'm running a DK2, with a GTX 980 and latest drivers on Windows 10.

In the HMD all I see is a space backdrop splash screen (which looks pretty horrible) and a frozen hourglass. The game is running fine on the desktop.

Other content is running perfectly well through Oculus Home on the DK2.

I note that one of the previous tricks to gettin the DK2 to run Elite with 0.8 was to set the monitor refresh to 75Hz. I'm clutching at straws here but my (realtively old Dell) monitor will only support 75Hz at like 1200x800 tops.

I'm tempted to install Windows 7 on another drive.

Cheers
 
I am using my dk2 with the new runtime. My problem is that it is unplayable because I materialize behind the chair and my view is obscured by it and my headless body!

Any ideas how I can fix that with the new runtime? Any help welcomed...
 
I am using my dk2 with the new runtime. My problem is that it is unplayable because I materialize behind the chair and my view is obscured by it and my headless body!

Any ideas how I can fix that with the new runtime? Any help welcomed...
Have you tried tapping the "F12" key once you are in-game? That (certainly on my rig) resets the centering for your headset.
 
After installing the OH verison of Elite Dangerous, both the Steam and the OH work just fine with the DK2. Go figure?
 
Last edited:
Yay! i got my DK2 working... thanks for instructions.... Still can't get the rift to work in SteamVR with other games though (anyone have this problem?), but Elite Dangerous works just fine, in fact, i used to get serious judder the last time i tried it but it's as smooth as butter now so someone has improved things a LOT (either FD or the new 1.3 drivers). It's actually really really playable now :) Happy days.
 
It's been a painful few days for me getting this working but I'd like to submit an addendum to people with non standard setups, mainly game installs on a different drive to the OS.

  • If you don't want to use the Oculus store option, Elite must be on the C: drive (well not true, one could use symlink. I didn't) and as noted above, Select Unknown Source in the Oculus Settings page.
  • If you move Elite from a different drive to C:\Program Files (x86)\ don't forget to set the launcher to run as administrator and verify the files - no need to delete and reinstall.
  • The Oculus store version has no sound...
  • If your view is spinning when in the station, Set Vehicle Maintain Horizon Camera to Off - https://forums.frontier.co.uk/showthread.php?t=239747 (Yup I had this issue too)
 
Last edited:
So close .... Using DK2

I am at the rift "loading" screen after starting ED with the HMD selected - the one where it tells you the DK2 is unsupported etc, and just says "Loading" with a sprinning icon. ED is running, I can hear it and I can traverse the in game menus (I only know this because I can hear it).

Any ideas please ?
 
Hey guys! Thanks @thebadmf for your post, it got me on the right path.

I had no sound at all, but after setting ED to run as admin and doing the "verify files" thing it is fixed!
 
Last edited:
Interesting note: Setting Oculus Home to run as administrator PREVENTED it from working! Now there is a first! When I tried launching Home I got a quick flash of the window and then it disappeared and wasn't available. Turned OFF "run as administrator" on Oculus Home shortcut and boom, instantly started working again. How weird is that?!
 
So close .... Using DK2

I am at the rift "loading" screen after starting ED with the HMD selected - the one where it tells you the DK2 is unsupported etc, and just says "Loading" with a sprinning icon. ED is running, I can hear it and I can traverse the in game menus (I only know this because I can hear it).

Any ideas please ?
You must skip the "rift" setup! The "rift" they are refering to is for the CV1. Just go to oculus home, settings,devices and you should see the DK2 detected there. If not unplug the usb's(and aux power to DK2) and re-insert/re-power.
 
Top Bottom