Release EDDI - Windows app for immersion and more

Status
Thread Closed: Not open for further replies.
The next beta release of EDDI is now available. Details have been updated in the original post.

This release bring a lot of changes, but the most notable one is that VoiceAttack support is back. Please note that this does require the latest beta version of VoiceAttack to work, and brings a much simplified setup and configuration process to using EDDI inside VoiceAttack.

Please give it a go and let me know how you get on. Bug reports and general suggestions are welcome.
 
Hi,
I've been playing with the latest beta of Eddi in VA and have two questions. First is how do I tell Eddi that i've changed ship. It seems Eddi thinks i'm flying my Anaconda which is the first ship in the list but i'm actualy in my Asp Explorer. I've changed ship and then back to the Asp but Eddi still thinks i'm in my Anaconda. In the old version I'ld have to use the "ship handed over" command so i copied that to the new Eddi vap but that didn't work.
My second question is about the call sign. Looks like Eddi wants to use the call sign like it is in ED traffic control but I think there's a problem. My CMDR name is the same as my name here on the forum "J. Calvert (Joshua)". In ED my call sign (for the Anaconda) is "Faulcon Delacy Julliet Alpha Charlie" but if I look at the Ship information command in Eddi it says "Faulcon Delacy J.". I think Eddi should ignore the full stop and the space so it gets JCA instead of J.
 
Hi,
I've been playing with the latest beta of Eddi in VA and have two questions. First is how do I tell Eddi that i've changed ship. It seems Eddi thinks i'm flying my Anaconda which is the first ship in the list but i'm actualy in my Asp Explorer. I've changed ship and then back to the Asp but Eddi still thinks i'm in my Anaconda. In the old version I'ld have to use the "ship handed over" command so i copied that to the new Eddi vap but that didn't work.
My second question is about the call sign. Looks like Eddi wants to use the call sign like it is in ED traffic control but I think there's a problem. My CMDR name is the same as my name here on the forum "J. Calvert (Joshua)". In ED my call sign (for the Anaconda) is "Faulcon Delacy Julliet Alpha Charlie" but if I look at the Ship information command in Eddi it says "Faulcon Delacy J.". I think Eddi should ignore the full stop and the space so it gets JCA instead of J.
On the first ite I need to take take a look and see what's going on. It might be that the issue is due to the companion app API still pointing to the production server (due to there being no beta companion app API) and so it reading the data from there. That said, there should be enough information in the handover info for me to at least be aware that the ship has changed and provide the basic information (model, name etc.) from the local data store. Of course, if you're running this against production rather than beta then it's a different issue; please let me know if this is the case.

Regarding the callsign: yes the code just takes the first three characters whatever they are, so in your case it's "J. ". I'll update the code to take the first three alphanumeric characters instead so that it provides a proper callsign. Thanks for reporting these.
 
Of course, if you're running this against production rather than beta then it's a different issue; please let me know if this is the case.
Thanks for looking into it. I'm testing in ED Beta.

Update: you're right I think, I changed my ship in 2.1 to my Asp and went back to Beta and Eddi says i'm in my Asp.
The same goes for the station you're docked at. My ship in 2.1 is docked in Ashby City and wherever I travel to in Beta when I dock Eddi says I'm in Ashby City (I've added that to the docked-script) and gives the same tips about commodities that are on sale in Ashby City.
 
Last edited:
jgm,

2.0 beta up and running! Just getting used to the new set up, will start purposely testing program logic this weekend.

The Configuration UI is very clean and intuitive. Only comment is that the variables and their description are not consistently separated by hyphens in the 'Variables' window when editing an event in the 'Speech Responder' tab.

I do have a QoL thought and possible request. Given that VA profiles have access to plugin variables/data, is the reverse true? Can a plugin access a list of a running profile's delcared/set variables, including variable names and values? If so, then the ability to save and/or restore a profile's 'state' would be very useful. Couple that with a 'LoadGame' event, a user could pickup where they left off from one playing session to the next without serious profile script calisthenics.

Thoughts?
 
Last edited:
jgm,

2.0 beta up and running! Just getting used to the new set up, will start purposely testing program logic this weekend.

The Configuration UI is very clean and intuitive. Only comment is that the variables and their description are not consistently separated by hyphens in the 'Variables' window when editing an event in the 'Speech Responder' tab.

I do have a QoL thought and possible request. Given that VA profiles have access to plugin variables/data, is the reverse true? Can a plugin access a list of a running profile's delcared/set variables, including variable names and values? If so, then the ability to save and/or restore a profile's 'state' would be very useful. Couple that with a 'LoadGame' event, a user could pickup where they left off from one playing session to the next without serious profile script calisthenics.

Thoughts?
Good spot on the variables window, I'll tidy that up.

Regarding profile state, VoiceAttack is able to persist variables by checking the "Save value to profile" option when setting a variable. Rather than using VoiceAttack as a persistent store you'll be better off using this to persist state.
 
Thanks for looking into it. I'm testing in ED Beta.

Update: you're right I think, I changed my ship in 2.1 to my Asp and went back to Beta and Eddi says i'm in my Asp.
The same goes for the station you're docked at. My ship in 2.1 is docked in Ashby City and wherever I travel to in Beta when I dock Eddi says I'm in Ashby City (I've added that to the docked-script) and gives the same tips about commodities that are on sale in Ashby City.
I'm working through handling the ship changeovers based on event log and will also take a look at stations. Should be tidied up in the next day and I'll push out a new beta version.
 
Regarding profile state, VoiceAttack is able to persist variables by checking the "Save value to profile" option when setting a variable. Rather than using VoiceAttack as a persistent store you'll be better off using this to persist state.
Thanks for bringing that feature to my attention... still learning.

A "Loadgame" event would indeed be very useful to utilize "Restore saved value" commands for specific variables saved to the profile.

Something you would be amenable to adding to your 'todo' list?
 
Last edited:
Thanks for bringing that feature to my attention... still learning.

A "Loadgame" event would indeed be very useful to utilize "Restore saved value" commands for specific variables saved to the profile.

Something you would be amenable to adding to your 'todo' list?
There is already one - "Commander continued".
 
I've just released 2.0.0b3 of EDDI. This beta fixes a number of issues with the fact that the companion API contains production data rather than beta data, and so was providing incorrect information at times.

Note that because of the lack of a beta companion API some features, such as trading information about commodities, will probably not work correctly. There's not a lot that can be done here, we'll have to wait for 2.2 to go live before this functionality will work as intended.
 
Hi,
Been playing with Eddi 2.0.0b3 (in ED Beta 5) and my problems with the previous beta are solved, changing ships works and my call sign is made for JCA now instead of just J because of my Cmdr beginning with "J. "
I've tried the link with EDSM but that doesn't seem to work yet, the short trip i made didn't show up in EDSM.
Furthermore I've noticed that after starting VA (or EDDI2 standalone) for the first time and then starting ED i'm greeted with the Welcome Commander but right after that the info of my last jump is repeated.
At the moment i'm docked in Daedulus (Mercury) but after startup Eddi says Welcome, you're heading to Sol (and the rest of the info), you are docked at Deadulus. This seems to only happen after the first start of VA (or EDDI2 standalone). When I restart ED (or swith from Solo to Open) while Eddi is already running it leaves out the jump info so it says Welcome, you're docked in Deadulus.
Hope this makes sense to you.
The last thing I've noticed is when Alt-tabbing to VA (latest Beta) to edit the profile sometimes VA freezes and can only be ended through taskmanager. Could be a coincidence of course but I think it started happening after importing EDDI2 into VA. Maybe it's a problem with VA beta but just wondering if you've noticed this too.
 
Last edited:
Hi,
Been playing with Eddi 2.0.0b3 (in ED Beta 5) and my problems with the previous beta are solved, changing ships works and my call sign is made for JCA now instead of just J because of my Cmdr beginning with "J. "
I've tried the link with EDSM but that doesn't seem to work yet, the short trip i made didn't show up in EDSM.
Furthermore I've noticed that after starting VA (or EDDI2 standalone) for the first time and then starting ED i'm greeted with the Welcome Commander but right after that the info of my last jump is repeated.
At the moment i'm docked in Daedulus (Mercury) but after startup Eddi says Welcome, you're heading to Sol (and the rest of the info), you are docked at Deadulus. This seems to only happen after the first start of VA (or EDDI2 standalone). When I restart ED (or swith from Solo to Open) while Eddi is already running it leaves out the jump info so it says Welcome, you're docked in Deadulus.
Hope this makes sense to you.
The last thing I've noticed is when Alt-tabbing to VA (latest Beta) to edit the profile VA freezes and can only be ended through taskmanager. Could be a coincidence of course but I think it started happening after importing EDDI2 into VA. Maybe it's a problem with VA beta but just wondering if you've noticed this too.
I've also been having problems with the latest VA Beta (v1.5.12.24 prerelease) & EDDI 1.4 but not EDDI Beta2.0.0b3


I can get EDDI 2 Beta running fine it seems but if I change back to EDDI 1.4 anytime I try to run any EDDI 1 script I get this error

12:52:14 - Plugin execution exception: Error reading JObject from JsonReader. Current JsonReader item is not an object: String. Path '', line 1, position 6.
12:52:14 - Recognized : 'ship handover complete'
12:52:01 - Plugin 'EDDI 1.4.0' initialized.

Not sure exactly what I'm doing wrong probably something simple I'm not seeing right. I've uninstalled and reinstalled old version of VA and seems to work. So I think it maybe VA Beta thats having issues with EDDI 1.4



I can get EDDI 2 Beta running fine it seems but if I change back to EDDI 1 anytime I try to run any EDDI 1 script I get this error
 
I've tried the link with EDSM but that doesn't seem to work yet, the short trip i made didn't show up in EDSM.
I'll take a look at the EDSM integration. Is there anything in the logs around the time that you jump to another system?

Furthermore I've noticed that after starting VA (or EDDI2 standalone) for the first time and then starting ED i'm greeted with the Welcome Commander but right after that the info of my last jump is repeated.
At the moment i'm docked in Daedulus (Mercury) but after startup Eddi says Welcome, you're heading to Sol (and the rest of the info), you are docked at Deadulus.
Does it definitely say that you are heading to Sol, or that you are in Sol? The latter should happen when you first log in, as a re-orientation for you.

The last thing I've noticed is when Alt-tabbing to VA (latest Beta) to edit the profile sometimes VA freezes and can only be ended through taskmanager. Could be a coincidence of course but I think it started happening after importing EDDI2 into VA. Maybe it's a problem with VA beta but just wondering if you've noticed this too.
Do you have any more detail on exactly what you are doing when VA freezes? I've played around with the beta a bit but can't recreate this.
 
Well I just spent the last few hrs making my first couple of scripts. Basically voicing what I've just scooped up/collected, cargo or materials and the amount. First few steps in an engineer cookbook I've had an idea on but I'm no programmer/script writter that's for sure :/
 
I've also been having problems with the latest VA Beta (v1.5.12.24 prerelease) & EDDI 1.4 but not EDDI Beta2.0.0b3


I can get EDDI 2 Beta running fine it seems but if I change back to EDDI 1.4 anytime I try to run any EDDI 1 script I get this error

12:52:14 - Plugin execution exception: Error reading JObject from JsonReader. Current JsonReader item is not an object: String. Path '', line 1, position 6.
12:52:14 - Recognized : 'ship handover complete'
12:52:01 - Plugin 'EDDI 1.4.0' initialized.

Not sure exactly what I'm doing wrong probably something simple I'm not seeing right. I've uninstalled and reinstalled old version of VA and seems to work. So I think it maybe VA Beta thats having issues with EDDI 1.4



I can get EDDI 2 Beta running fine it seems but if I change back to EDDI 1 anytime I try to run any EDDI 1 script I get this error
There have been some changes to EDDI's on-disk structures for EDDI 2, so EDDI 1 won't be able to import them properly. I assume that this is the issue you are seeing.
 
Anyway I can get them both working together in the mean time? I flick from beta to live ED but can only get EDDI working in one not the other
 
Status
Thread Closed: Not open for further replies.
Top Bottom