Release EDDI - Windows app for immersion and more

Status
Thread Closed: Not open for further replies.
Anyway I can get them both working together in the mean time? I flick from beta to live ED but can only get EDDI working in one not the other
EDDI 2 should work in live. You'll need to change the netlog path in EDDI's UI but that's all.

Otherwise you'll have to swap out your %APPDATA%\EDDI directory when you move from beta back to live (you did copy it to EDDI-production like I suggested in the OP, right?)
 
I'll take a look at the EDSM integration. Is there anything in the logs around the time that you jump to another system?



Does it definitely say that you are heading to Sol, or that you are in Sol? The latter should happen when you first log in, as a re-orientation for you.



Do you have any more detail on exactly what you are doing when VA freezes? I've played around with the beta a bit but can't recreate this.
EDSM: in the old EDDI I sometimes have my EDSM flight logs open on my Ipad and when I make a jump I refresh and the system appears. With EDDI2 nothing happens (I enabled the EDSM plugin and my EDSM Api key this morning) I also did a download from EDSM (obtain logs) and that seemed to work (I saw the systems mentioned while it was downloading) but when flying to Sol Eddi says it's my first visit.
-
EDDI startup: it varies, I just tested a couple of times and it sometimes says "jump in progress, your Python is in transit to Sol" or "Destination confirmed ..."
Here is a link to my Eddi.log in case you want to check it out: https://dl.dropboxusercontent.com/u/9590837/eddi.log
-
VA freezing: not sure exactly, sometimes when switching profiles, sometimes when trying to open the editor, it varies.
 
EDDI 2 should work in live. You'll need to change the netlog path in EDDI's UI but that's all.

Otherwise you'll have to swap out your %APPDATA%\EDDI directory when you move from beta back to live (you did copy it to EDDI-production like I suggested in the OP, right?)
I think I did but screwed up somewhere as EDDI and EDDI-Production look the same structure wise. Can I ust delete these folders in %APPDATA%\EDDI and start from scratch?

or how can I just start this all over from nothing again?
 
Last edited:
I think I did but screwed up somewhere as EDDI and EDDI-Production look the same structure wise. Can I ust delete these folders in %APPDATA%\EDDI and start from scratch?

or how can I just start this all over from nothing again?
If you remove the contents of %APPDATA%\EDDI then you'll start again from scratch.
 
If you remove the contents of %APPDATA%\EDDI then you'll start again from scratch.
Removed the contents and reinstalled 1.4 but now getting this in VA 1.5.12.24 (prereleased)

15:36:36 - UNABLE TO INVOKE PLUGIN. PLUGIN NOT VALID FOR THIS VERSION OF VOICEATTACK.

Sorry to be bothering you with all this as I truly wanted to help out with your awesome plug in and may would have tried to make some scripting myself but this is just confusing me even more that I can't even get the thing running like it was before. Seems the new beta of VA don't like EDDI 1.4

I may just downgrade everything before beta and wait for the release :/
 
Having a lot of fun using the EDDI events in Voice Atack to improve profile performance/immersion... all seems to be working as intended.

One difference I've noted since updating to beta-3 is that the EDDI voice is MUCH louder in-game. I'm able to adjust loudness in the EDDI TTS tab and hear the effect when 'testing', but it has no effect in game. The TTS adjustments in VA apparently (obviously?) have no effect on EDDI voices.

Suggestion - provide a mechanism in the speech responder tab for copying/replacing individual events from one 'personality' to another. This provides some helpful flexibility/short cuts plus makes it easy to get back to a 'zero point' if you get too far off the reservation when modifying a speech responder script.
 
Last edited:
Removed the contents and reinstalled 1.4 but now getting this in VA 1.5.12.24 (prereleased)

15:36:36 - UNABLE TO INVOKE PLUGIN. PLUGIN NOT VALID FOR THIS VERSION OF VOICEATTACK.

Sorry to be bothering you with all this as I truly wanted to help out with your awesome plug in and may would have tried to make some scripting myself but this is just confusing me even more that I can't even get the thing running like it was before. Seems the new beta of VA don't like EDDI 1.4

I may just downgrade everything before beta and wait for the release :/
I suggest that you stick with the EDDI beta and the latest version of VoiceAttack, as that's where the updates will be coming and it's most likely to have fixes for any problems. But if you do want to fall back to the release version of both EDDI and VoiceAttack it should work fine as long as you restore your %APPDATA%\EDDI directory to a non-beta state.
 
Having a lot of fun using the EDDI events in Voice Atack to improve profile performance/immersion... all seems to be working as intended.

One difference I've noted since updating to beta-3 is that the EDDI voice is MUCH louder in-game. I'm able to adjust loudness in the EDDI TTS tab and hear the effect when 'testing', but it has no effect in game. The TTS adjustments in VA apparently (obviously?) have no effect on EDDI voices.

Suggestion - provide a mechanism in the speech responder tab for copying/replacing individual events from one 'personality' to another. This provides some helpful flexibility/short cuts plus makes it easy to get back to a 'zero point' if you get too far off the reservation when modifying a speech responder script.
Interesting on the voice volume. I tried to reproduce this but it seemed that the voice that came out of VoiceAttack was the expected volume. Could you let me know exactly what you were doing in VoiceAttack that caused the louder voice? Was it a VoiceAttack command, response to an EDDI command, or something from the speech responder?

I can ensure that the 'reset' button on the edit dialog for scripts to return to the default, rather than the unedited, version of the text. That was actually its original purpose so not quite sure when I changed my mind on that, but 'cancel' does that job well enough.
 
OP updated with a new video showing the docking process. The speech responder has some delays in it now to avoid talking over the station announcer.
 
Interesting on the voice volume. I tried to reproduce this but it seemed that the voice that came out of VoiceAttack was the expected volume. Could you let me know exactly what you were doing in VoiceAttack that caused the louder voice? Was it a VoiceAttack command, response to an EDDI command, or something from the speech responder?
It was from the speech responder. No amount of adjusting in either EDDI or VA made a difference. Took a computer re-boot to 'fix' it. Best guess is during updating EDDI to b3 and VA to 1.5.12.24, I may have had both inadvertently running at same time, which confused TTS.


I can ensure that the 'reset' button on the edit dialog for scripts to return to the default, rather than the unedited, version of the text. That was actually its original purpose so not quite sure when I changed my mind on that, but 'cancel' does that job well enough.
I tried something simple like deleting the script in 'Docking Request' event and closed/saved. Reopening the script, 'Reset' had no affect.

'Reset' performing a restoration to the default EDDI scipt would definitely do the trick, but I still think a 'Duplicate' type function to paste/replace individual event scripts from any personality to another personality would be very useful.

Very small UI suggestion... allow read-only viewing of the default EDDI scripts, negating the need to copy the entire personality to see the scripts. Change 'Edit' buttons to 'View' for default EDDI scripts.
 
Last edited:
It was from the speech responder. No amount of adjusting in either EDDI or VA made a difference. Took a computer re-boot to 'fix' it. Best guess is during updating EDDI to b3 and VA to 1.5.12.24, I may have had both inadvertently running at same time, which confused TTS.
Possible. If you see it again please let me know.

I tried something simple like deleting the script in 'Docking Request' event and closed/saved. Reopening the script, 'Reset' had no affect.

'Reset' performing a restoration to the default EDDI scipt would definitely do the trick, but I still think a 'Duplicate' type function to paste/replace individual event scripts from any personality to another personality would be very useful.

Very small UI suggestion... allow read-only viewing of the default EDDI scripts, negating the need to copy the entire personality to see the scripts. Change 'Edit' buttons to 'View' for default EDDI scripts.
I'm trying to understand where seeing the default scripts would be of use. Assuming that you're editing a different profile then to do this you would need to shut down your edit window, switch personality, then view the required script. Would it be easier to have a 'View default' button in the edit script that popped up the default script in a separate window? That way you could use it as a reference whilst continuing to work on your edits.
 
Possible. If you see it again please let me know.



I'm trying to understand where seeing the default scripts would be of use. Assuming that you're editing a different profile then to do this you would need to shut down your edit window, switch personality, then view the required script. Would it be easier to have a 'View default' button in the edit script that popped up the default script in a separate window? That way you could use it as a reference whilst continuing to work on your edits.
Agreed, having the default script opened in another window as a reference would be superior. Thanks.
 
Last edited:
Oh I just had another little idea. The servers are about to go down for maintenance what about EDDI 2 announcing they will be going down? Sometimes I don't always remember and just keep on going even though there is a big text on the screen. Maybe able to make customisable with say or sound bites
 
Oh I just had another little idea. The servers are about to go down for maintenance what about EDDI 2 announcing they will be going down? Sometimes I don't always remember and just keep on going even though there is a big text on the screen. Maybe able to make customisable with say or sound bites
I don't believe that this information is available anywhere outside of flashing up on the screen, but if you know differently let me know and I'll take a look.
 
ok no worries, just thought I'd put the idea out there incase anyone knew as I thought it would be a good idea.

Trying to get the landing pad voice profile (after I saw your latest video) in my VA but doesn't seem to want to work, well it's not saying anything and not giving errors other than
10:11:40 - Recognized : 'pad 2' (derived command) Can't register on the VA forums as I would ask there as it doesn't like my email address for some reason :'(

actually scratch that, seems that VA isnt saying anything on any script thats using the say command directly in VA

TOTALLY loving the shut up command now :D
 
Last edited:
ok no worries, just thought I'd put the idea out there incase anyone knew as I thought it would be a good idea.

Trying to get the landing pad voice profile (after I saw your latest video) in my VA but doesn't seem to want to work, well it's not saying anything and not giving errors other than
10:11:40 - Recognized : 'pad 2' (derived command) Can't register on the VA forums as I would ask there as it doesn't like my email address for some reason :'(

TOTALLY loving the shut up command now :D
That's coming in the next release, which I'll push out today once I've tested against beta 6.
 
jgm - FYI, entered an issue on your github site regarding the 'Jumped' event not executing in either the EDDI speech resonder or VoiceAttack ((EDDI Jumped)), following a completed jump. I expect its not a configuration issue because I'm using other VA event commands successfully. I also don't think it's due to case sensitivity because ((EDDI Entered supercruise)) and ((EDDI Entered normal space)) work fine. But it can also be due to 'user stupidity'.
 
Status
Thread Closed: Not open for further replies.
Top Bottom