EDProfiler - A New Display Switcher/Robust Settings Profiler/Switcher/Detector!

Woot woot!

Beer money incoming :cool:

@drkaii I am unaware of any hack to get on foot gameplay to work in VR. Currently fdev will present you with a flatscreen to play on foot while staying in VR. Everything else is already VR.
Thanks! Although please make sure it's working before converting any gratitude into beer please, first and foremost let's make sure it's working great!
 
Hi

Terrain Sampler Quality is not applied, is this a known issue?

Also,You've previously requested Mouse Cursor settings, are there any plans to add them?
I also need this.
 
Any chance that the profiler supports Horizons AND Odyssey (via a toogle?)?
The latest profiler version saves settings in "Custom.4.0.fxcfg" (which is for Odyssey).
Horizons is using "Custom.3.8.fxcfg"....

Best regards,
Manuel
 
Anyone else getting this error when using Profiler to start EDO? It then closes. Opening through the Frontier Launcher works fine.

Untitled123.png
 
Any chance that the profiler supports Horizons AND Odyssey (via a toogle?)?
The latest profiler version saves settings in "Custom.4.0.fxcfg" (which is for Odyssey).
Horizons is using "Custom.3.8.fxcfg"....

Best regards,
Manuel
I have just updated it with the new settings, and have done it like this yes ^
Hi

Terrain Sampler Quality is not applied, is this a known issue?

Also,You've previously requested Mouse Cursor settings, are there any plans to add them?
I also need this.
Not a known issue no, I will look into it soon. Let me know if this update fixed it. Mouse Cursor settings, I still don't know where they are saving! Do you?
Anyone else getting this error when using Profiler to start EDO? It then closes. Opening through the Frontier Launcher works fine.

View attachment 229393
What do you mean start EDO?
 
So I am getting this error when trying to save a new profile now that I removed my one drive account. Any ideas as to how to fix this? I have already tried uninstalling and reinstalling and that isn't working. I also am not able to add the one drive account to that directory either.
Not sure, but you can try changing the profiles location here: \Documents\EDProfiler\Defaults\Paths.xml
Hi folks,

Unless I start ED using the Steam URL method, I can't get the auto-login (account linking) to work. How can I tell ED Profiler to use the Steam URL method?

Here is the method I mean, if it were in a Batch file:

start "" "C:\Users\sqltest\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Steam\Elite Dangerous.url"

I tried to find where the EDProfiler settings are located, and can't seem to find them. I looked in the Registry as well as the AppData folder.

Does anyone know how to make it work with the Steam launcher? Thanks.
Try right clicking on the Launch button (or ctrl-right clicking) and setting it to a batch file. Then right click it from now on.
I've noticed that if I use EDProfiler to switch to my non-VR config it doesn't work with Odyssey so I'm assuming there is a separate config file/location for the alpha test. I created a 2nd Elite Dangerous desktop link and added /novr to the end of the execution line to fix for now.
Should be sorted now
hi CMRDs,

i have massive issues with the app.
when launching Odyssey it will always open SteamVR.

even with disabled that
View attachment 218598

and disabled also in the EDProfiler.exe.config

View attachment 218601

what else please has to be done, to get rid of that annoying behaviour, without to rename the steamvr.exe?

if i remember correctly, there was an option to disable that in the SteamVR app. but now in current v1.17.5 Beta there isnt such that anymore.
Please help.

Thanks!

cheers, o7
Can't reproduce. What version of ED are you using?
I am trying to install but it is stuck during the Preparing Application stage. I have gone through all 65 pages of this forum trying all different options but i still can not get past this stage and it has been sitting here for over an hour.
View attachment 225806
Sorry, I am not sure about this, could be an anti-virus issue, or window smartscreen issue or maybe try installing from IE instead of other browsers? You'll have to clear the EDProfiler folder under %localappdata%\Apps\2.0 (do a search there for edp) to try the latter
 
Hey Doc, I made a few white themes. Hope they help fellow pilots :) If you like them please include in the next update, cheers.

Subtle Royale (Yam HUD, Cyan friendlies, Yellow shields, Red hostiles)

<MatrixRed> 0.2, 0, 0 </MatrixRed>
<MatrixGreen> -0.2, 1.8, 2 </MatrixGreen>
<MatrixBlue> 2, -0.2, -2 </MatrixBlue>

View attachment 198707

Citrus on White (White HUD, Lime friendlies, Orange shields, Yam hostiles)

<MatrixRed> 0.7, 0.5, 0.8 </MatrixRed>
<MatrixGreen> 0.25, 1.4, -0.5 </MatrixGreen>
<MatrixBlue> 1, -0.6, -1 </MatrixBlue>

View attachment 198708

Red on White (Beige HUD, Cyan friendlies, Red shields, Brown hostiles)

<MatrixRed> 0.5, 0.2, 0.1 </MatrixRed>
<MatrixGreen> -0.7, 2, 2 </MatrixGreen>
<MatrixBlue> 1, -1.5, -2 </MatrixBlue>

View attachment 198711
Cheers! I wish I had the time to add these. Email me to remind me and maybe I will soon
drkaii, could you setup HTTP on the site you are serving the download for your application installer from.

Or at the very least add it to winget so WPM can at least do a checksum verification from a trusted source.
You mean in case the ftp gets hacked? I'll look into this.
To be Honest, it was not there. None of the normal Uninstall Tools Worked, neither was there an entry. Im Used to Windows since it was ther First Time available in good old DOS Times with Windows 1.1, so i know how to unistall the normal way. Searched the whole disk and deleted everything i found, fixed the registry, looks like it worked!
Check my previous message, last response.
Tone Mapping Problems

The 'Enable' grey out and unchecked so I cannot open my Mapping Tone settings. Any idea why? i have try reisntall and delete elite dangerous graphic folder and EDProfiler file locationView attachment 211011
This feature is dead thanks to Frontier disabling it on their end. Sorry!
 
I have just updated it with the new settings, and have done it like this yes ^

Not a known issue no, I will look into it soon. Let me know if this update fixed it. Mouse Cursor settings, I still don't know where they are saving! Do you?

What do you mean start EDO?

. \ AppData \ Roaming \ Frontier Developments \ Elite Dangerous \ Options

Isn't the mouse cursor setting in fsave_options011?

The contents here are changed when the mouse cursor setting is changed.
 
Hey guys, keep up the faith :)
I have updated the tool. It should basically work now, although I still have to add the two new options, as well as check if anything else has changed like bindings etc, which I will do on Sunday. Keep an eye out for that and let me know if there are any issues via kaii@dr.com - much faster to get hold of me! This forum NEVER lets me know anything via email, no matter what I do.

I will get to your questions then too!

Sorry, took me a while to get Odyssey. I won't be playing it directly without VR. I hear there's a hack to get basic VR working even on foot?
Awesome work mate, thanks for updating - I sent you some beer money via paypal yesterday :) 🍻 One thing that doesn't work for me is the "Texture filter Quality" in Odyssey mode: The dropdown works, but selecting anything other than trilinear does nothing, it always snaps back to trilinear.

Again, thanks for putting all the time and effort into developing this great tool!
 
Works fine! Thanks @drkaii.



What do you think about the location of the mouse cursor settings?
Yes, I'll try and work it in soon! Thanks for the find
Awesome work mate, thanks for updating - I sent you some beer money via paypal yesterday :) 🍻 One thing that doesn't work for me is the "Texture filter Quality" in Odyssey mode: The dropdown works, but selecting anything other than trilinear does nothing, it always snaps back to trilinear.

Again, thanks for putting all the time and effort into developing this great tool!
Thanks so much! And thanks for pointing out to me, I'll fix that soon
 
Ok I just released an update that fixes @Der Trainer 's issue and another issue, as well as added a GUI template image specifically for Odyssey as per @rootsrat 's request

. \ AppData \ Roaming \ Frontier Developments \ Elite Dangerous \ Options

Isn't the mouse cursor setting in fsave_options011?

The contents here are changed when the mouse cursor setting is changed.
I can't find this file, please can you email (or here) me a screenshot of what you mean?
 
I can't find this file, please can you email (or here) me a screenshot of what you mean?
I'm playing Elite Dangerous on Steam.

Is it because of the difference in playing environment?

Whether it's Horizons, Odessey, VR or nonVR, the files content are the same for each settings.
 

Attachments

  • Cursor_settings.zip
    50.6 KB · Views: 5
Last edited:
Top Bottom