PSA for SteamVR Users! 'Manually override' Resolution to 100% or turn off in-game SS/HMD Image Qual.

drkaii

Volunteer Moderator
As the title says, go into SteamVR Settings >Video tab > check the Manual Override box and set the slider to 100%

or

Set your in game SS and HMD Image Quality to 1x

Why?

Basically, SteamVR is now either choosing a scaled up resolution for you based on your video card and HMD, or if you are manually overriding it, unless you are setting it to 100%, it is applying to Elite and therefore combining with whatever settings you have in game. This will mean that you could be doing much better than you think you are doing, it's just there are "hidden" factors from SteamVR that are sapping your performance without you realising.


Basically

  • 100% resolution in SteamVR = 1.4x native resolution (as explained here)
  • 150% is roughly the equivalent of setting in game HMD Image Quality to 1.25x
  • 200% resolution is approx 2x native resolution
  • 225% is roughly equivalent to setting in game HMD Image Quality to 1.5x
  • 300% resolution is just under 2.5x native resolution, and is roughly equivalent to setting in game HMD Image Quality to 1.75
  • 400% resolution is approx 2.8x native resolution (twice 1.4, the equivalent of setting in game HMD Image Quality to 2x)
  • 500% is approx 3x native resolution
It's all very confusing but this is why it's best to set SteamVR to 100% and then leave all scaling to the in game setting HMD Image Quality. It performs the same, but has the advantage of being adjustable during play, without having to restart, so you can turn it down in stations, up in the deep dark of space and so on. But ultimately, up to you!
 
As the title says, go into SteamVR Settings >Video tab > check the Manual Override box and set the slider to 100%

Why?

After reading it a bit closer today, I saw that it said that when you check the "Manually Override" box, it overrides all games. To do it for specific games, go to the Applications tab. So I thought, why not, let's turn it to 100%. Lo and behold, after booting up, I got all the performance I ever dreamed of with this GPU and CPU out of Elite. Able to crank up the HMD Image Quality to 2x and getting BETTER performance than I was with 1.5x only yesterday.

HOW ABOUT THAT! Remeber the key point, turning it from 200% to 100% made ZERO quality difference in game, but a MASSIVE performance difference. Try it 'n see! Leaving it in the Application tab at 100% gets overridden by SteamVR whether on manual override or not, so unfortunately this is the only way around it at time of writing!

So if you happen to have the above set of issues, I hope this helps.
Pretty weird , for ED since 1 year I'm using Steam VR ( always updated) Resolution 400% ( Vive , Gtx 1080ti OC , i7 8700k OC) in game HMD Q 1.0 , SS 1.0 , low shadows , AA off, others setting ultra/high and I'm hitting 90 fps in space , RES, CZ, planets ( except eng. base where async kicking). Happy with quality and performace.
Steam VR res 400% ( around 3000x3300 pixels ) is old SteamVR SS 2.0 and equal to HMD Q 2.0 in game.
 
Last edited:

drkaii

Volunteer Moderator
Pretty weird , for ED since 1 year I'm using Steam VR ( always updated) Resolution 400% ( Vive , Gtx 1080ti OC , i7 8700k OC) in game HMD Q 1.0 , SS 1.0 , low shadows , AA off, others setting ultra/high and I'm hitting 90 fps in space , RES, CZ, planets ( except eng. base where async kicking). Happy with quality and performace.
Steam VR res 400% ( around 3000x3300 pixels ) is old SteamVR SS 2.0 and equal to HMD Q 2.0 in game.
Please turn SteamVR res to 100% and then go in game and turn HMD Image Quality to 2x and see if you notice a quality difference.

It could very well be that there is something idiosyncratic with my rig, or yours, but my findings are 100% confirmed for me.
 
last time when I checked that wasn't any viusall quality difference , meybe even the oppostive in terms of performance... but will do some tests tomorrow in Ed 3.3 beta
are you using Vive Pro or Rift ?
 
Last edited:

drkaii

Volunteer Moderator
I just tried doing it your way and yeah, your way seems equivalent to my way. I guess this setting does seem to have some effect on the game. Still, I prefer to have SteamVR set to 1x resolution scaling so I can do all the scaling in Elite, being able to change it when needed.

It's very confusing though, as the resolution of 100% is more than 100%, but not the 1.4x written as the default scale, and etc etc it's very confusing!

I am using Vive Pro
 
As the title says, go into SteamVR Settings >Video tab > check the Manual Override box and set the slider to 100%

Why?

For me, I noticed minimal quality difference in game between 100% and 200%* (which is what mine was 'automatically' set to by 'recommendation'), but I DID notice a massive performance difference.
For me recommended setting of steam VR SS works just right it sets to 20% and this is perfect value that my GPU can still handle without bottlenecking.
 

drkaii

Volunteer Moderator
For me recommended setting of steam VR SS works just right it sets to 20% and this is perfect value that my GPU can still handle without bottlenecking.
Yes, but that would mean no in-game HMD Image Quality, which is something I personally like to keep within play-range, and I assumed most people did too - the source of my confusion.
 
Yes, but that would mean no in-game HMD Image Quality, which is something I personally like to keep within play-range, and I assumed most people did too - the source of my confusion.
I see, yes I use HMD and SS in game set both to 1. Steam VR SS does not check settings in game so it cant adjust SS based on in game settings (first steam VR start's up and after that ED starts up).
 
Drkaii,

Wow - this is just what the patient needed! I am a long-time vr user in Elite (Vive, Odyssey and now Odyssey+). I've been running a 2080ti and been frustrated with my framerates in and out of Elite. I did exactly what you said and now I can run my Elite HMD quality up to 2.0 (was at 1.5 before with some stutter - I tried 2.0 last weekend and was getting about 33 FPS on average in stations). Now, with the simple click of that box in SteamVr and with the magic of WMR/Steamvr new reprojection, I sit a silky smooth 45FPS in stations and 90 elsewhere, clarity is perfect and I'm feeling very happy with my recent purchases. Thanks for all that you do for the community (EdProfiler is a life-saver for tweaking and dialing everything in)! Fly safe 07
 

drkaii

Volunteer Moderator
Drkaii,

Wow - this is just what the patient needed! I am a long-time vr user in Elite (Vive, Odyssey and now Odyssey+). I've been running a 2080ti and been frustrated with my framerates in and out of Elite. I did exactly what you said and now I can run my Elite HMD quality up to 2.0 (was at 1.5 before with some stutter - I tried 2.0 last weekend and was getting about 33 FPS on average in stations). Now, with the simple click of that box in SteamVr and with the magic of WMR/Steamvr new reprojection, I sit a silky smooth 45FPS in stations and 90 elsewhere, clarity is perfect and I'm feeling very happy with my recent purchases. Thanks for all that you do for the community (EdProfiler is a life-saver for tweaking and dialing everything in)! Fly safe 07
Great! At least on person saved from the hell of bad performance!

I have amended the OP now to be a bit more accurate too, after the ensuing discussion
 
It's very confusing though, as the resolution of 100% is more than 100%, but not the 1.4x written as the default scale, and etc etc it's very confusing!

I am using Vive Pro
Its worth looking at the resolution per eye setting the slider gives you. You'll notice that 100% on a Vive Pro is greater than the Vive Pros per eye resolution. If you want 1:1 so you can then adjust SS in ED and have it scale correctly you'll need to lower SteamVR setting below 100% to match your res per eye.

I don't think that slider detects if you have a Vive Pro over a standard Vive, hence 100% is actually not correct, its over 100%.
 

drkaii

Volunteer Moderator
Its worth looking at the resolution per eye setting the slider gives you. You'll notice that 100% on a Vive Pro is greater than the Vive Pros per eye resolution. If you want 1:1 so you can then adjust SS in ED and have it scale correctly you'll need to lower SteamVR setting below 100% to match your res per eye.

I don't think that slider detects if you have a Vive Pro over a standard Vive, hence 100% is actually not correct, its over 100%.
Yes, as I said, it's very confusing. It seems 50% is the same as the Vive Pro. 200% is double, not 100%. It's very weird, like a logarithmic scale. Either way, I think 100% is the same value as it's always been. There's something about always upscaling a certain amount to take advantage of the difference in pixel densities across the screen or somesuch.

I am sure there is some boffin who has read all the releases about this stuff and can clarify, but for now it's very important to know.

I got my new GPU the moment this came through, so I was bitterly disappointed with the performance until I figured this out. Hopefully can help others
 
Yes, as I said, it's very confusing. It seems 50% is the same as the Vive Pro. 200% is double, not 100%. It's very weird, like a logarithmic scale. Either way, I think 100% is the same value as it's always been. There's something about always upscaling a certain amount to take advantage of the difference in pixel densities across the screen or somesuch.

I am sure there is some boffin who has read all the releases about this stuff and can clarify, but for now it's very important to know.

I got my new GPU the moment this came through, so I was bitterly disappointed with the performance until I figured this out. Hopefully can help others
I was aware of the need to downscale to "100%" for some time, but now I'm thoroughly confused. Wouldn't dropping it to 50% net us a performance gain without any significant loss visually? Because honestly, if I switched my setting to 150%, I wouldn't really see any significant difference.

Also, in all my tweaking earlier today, I never got around to checking whether or not motion smoothing should be always on like reprojection. What are your thoughts on that setting? Always on motion smoothing or just enable?
 

drkaii

Volunteer Moderator
I was aware of the need to downscale to "100%" for some time, but now I'm thoroughly confused. Wouldn't dropping it to 50% net us a performance gain without any significant loss visually? Because honestly, if I switched my setting to 150%, I wouldn't really see any significant difference.

Also, in all my tweaking earlier today, I never got around to checking whether or not motion smoothing should be always on like reprojection. What are your thoughts on that setting? Always on motion smoothing or just enable?
I am still testing, I feel very ignorant and I am sure someone out there knows all the answers. But from what I can tell, 100% feels like the old 100% even though the resolution is more than 100%...If I set it to 50% which gives me the 1440 x 1600 of my supposed Vive Pro, the game on HMD Image Quality 1.0x looks like I am playing with a DK2. So yeah, I am going to leave it at 100% now. I won't go more than that so I can let all the setting changes happen in game. I agree though, switching between 100% and 200% doesn't look very different to me in game for some reason and remember 200% isn't 2x... (did I say confusing?) - I have just ammended the OP with more detailed analysis

As for motion smoothing, no it should not be always on. I think it should be left on as normal in game unless you are consistently getting less than 45fps. Once it goes below 45fps, the artefacts get really bad, but above that, and especially if you are only rarely dropping below 90 or close to 90, it actually looks really good. It makes turning your ship in game butter smooth, planets move past so smoothly. Adds a lot to immersion.

EDIT: Did a quick calculation and 100% is the vive pro resolution times 1.4x, which is what I read about here: https://www.reddit.com/r/Vive/comments/9f5wdd/why_is_the_default_100_setting_on_steam_vr/e5u150r


HTC Vive has two screens 1080x1200 per eye or 2160x1200 combined . However, the default/100% supersampling is actually 1.4 times that in each direction 1512x1680 per eye or 3024x1680 combined.

The short answer is the lens distorts the image which he have to account for. So we do the opposite distortion to the image we display on the screen which compresses the edges of the image and loses fine detail. So in order to preserve the detail we do a bit of supersampling to account for what is lost because of the lens. I suggest you watch this video for more details.
 
My Oculus CV1 workaround which also results in a clear and butter smooth experience : 1080Ti and 7700k stock and OCl'd @4.8

In Elite;
HMD = 2
SS = 0.5
SMAA
Shadows off, jet cones min, Blur off, Ambient occlusion Med.
All other settings ultra/Max
Terrain Work slider > max to the Left. (decreases GPU terrain work load to minimum).

THEN with Oculus Debug tool, which must be opened before Oculus main application and remain open for session;
Set Pixel Per Display Override to 1.9 (max is 2.0): (decrease value for less powerful GPU's).
ASW = Auto

And bingo, perfect clarity smooth as butter. If you want to see FPS and GPU performance in game set Oculus HUD overlay in Oculus debug tool.
 
Last edited:

drkaii

Volunteer Moderator
Interesting, I never found turning SS down to accommodate more HMD IQ (which you are basically cranking up to 4x) do anything different to just keeping it the same and halving the HMD settings. Also, the difference with SMAA on or off is so minuscule in VR I just leave it off for the few FPS it gains me.

Also ambient occlusion is heavy, even on medium, and it's so barely noticeable (only if you look at your shirt basically), that I just turn it off. Then I can have shadows on Low, which means my cockpit can get dark, especially if the star is behind me, thus wont shine through my ship like it's not there.

I guess we all have our own preferences and notice things others don't
 
Also ambient occlusion is heavy, even on medium, and it's so barely noticeable (only if you look at your shirt basically), that I just turn it off. Then I can have shadows on Low, which means my cockpit can get dark, especially if the star is behind me, thus wont shine through my ship like it's not there.
I set Ambient Occlusion to off and Shadows to Ultra, great idea thank you, this gave my GPU a little bit more headroom and the visuals are great, smooth and sharp.
 
has anyone tried to turn off interleave reprojection lately in steam VR, the options have disappeared. nightmare for me wanting to turn it off
 
Top Bottom