Release Trade Computer Extension Mk.II

Found the issue with entering an unknown star system for TCE and the won't save my selected hotkey. The write protection on the database isn't ever happened here, but maybe it is system specific, in case of how long it takes to import a database. I'm using SSD and now an M2 SSD. Will add a fix for it too. Releasing an update this evening to fix all reported issues.

But I'll lose all my current exploration data already collect with older release of 1.5.3

You won't loss any exploration data, if you accumulated all data by scanning. They will reappear, if you let TCE process all unprocessed journal files on loading.
Even all pictures can be used, but you have to copy all created screenshots from the Cartography folder of your old V1.5.3 folder to the new installation.

If your have added manually some stars and planets, you can copy the TCE_Cartography.db file from your old V1.5.3 into your old V1.5.2+ installation by hand, including the Cartography folder and transferring thereafter the database.
 
Last edited:
Update [1.5.3.1] released:

Changelog:
- Fixed an error when approaching a star system, which is not in the database.
- Fixed an issue with saving the selected hotkey for the Factions panel.
- Fixed an issue that shows more than one sort indicator at the Factions panel.
- Fixed a rare error reporting of a locked database.
- Fixed an issue with the State of Knowledge dropdown not showing at the Navigation panel.
- Fixed an issue not showing the Factions, Notes and Planetary Map panel in the panel position selection dropdown at the Option panel.

Note:
Copy all files and folders from the update into your TCE installation folder to update your version.

I like to remind any user, who wants to use TCE in french, russian or spanish, to help in translating the
latest commodities and interface phrases at OneSky. Thanks in advance.

Elite Dangerous Beta Notes:
To all, who wants to test TCE and the ED beta, I suggest the following:
1. Install a beta-dedicated TCE version to your drive and name it so, like D:\TCE.beta
2. Transfer your database from your current TCE version to the beta-dedicated version by the TCE launcher, if you want to use your current database.
3. Don't forget to select the beta version of ED at the launcher of TCE.
4. After starting TCE, you can ignore or allow to process all unprocessed journal file, because TCE will ignore the non-relevant journals (all non-beta), if you have selected the ED beta in step 3.
5. EDMC is not working in beta, so the Connect button is not usable.
 
Last edited:
Found the issue with entering an unknown star system for TCE and the won't save my selected hotkey. The write protection on the database isn't ever happened here, but maybe it is system specific, in case of how long it takes to import a database. I'm using SSD and now an M2 SSD. Will add a fix for it too. Releasing an update this evening to fix all reported issues.



You won't loss any exploration data, if you accumulated all data by scanning. They will reappear, if you let TCE process all unprocessed journal files on loading.
Even all pictures can be used, but you have to copy all created screenshots from the Cartography folder of your old V1.5.3 folder to the new installation.

If your have added manually some stars and planets, you can copy the TCE_Cartography.db file from your old V1.5.3 into your old V1.5.2+ installation by hand, including the Cartography folder and transferring thereafter the database.

Renaming the current TCE folder to TCE_Old, installing the latest release 1.5.3 and using the database transfer worked perfectly. It even copied over the cartography folder also, so no loss of the pictures taken. Running the verify after DB transfer came up with error which I was able to run the repair option and verifying again and it gave the all clear.
 
hey all,

when i loaded up newest version today, i go to navigation tab and i have only 1 visited system, the system i am in at the moment, is there or has there been a problem with transferring my information, i know i have visited lots of systems ? how do i get the info back again ?

thanks :|
 
hey all,

when i loaded up newest version today, i go to navigation tab and i have only 1 visited system, the system i am in at the moment, is there or has there been a problem with transferring my information, i know i have visited lots of systems ? how do i get the info back again ?

thanks :|

Did you installed the new V1.5.3 and transferred your old database?
 
Did you installed the new V1.5.3 and transferred your old database?

yes installed new version then transferred then installed update for new version then played ?

thanks for quick reply Eventure :)

edit, also noticed when i jump to a system i've already visited the star class is reset to unknown and i cant set it via the summary panel dropdown (dropdown doesn't appear when i click on unknown)
 
Last edited:
Wow only now did I notice this

TCE is using the clipboard to store star system names in it, so if TCE is directing you to the next trade station, open the galaxy map of ED and paste the name of the star system into the search box to quickly set up as your destination.

This app is really amazing this should be part of the original game.
 
Last edited:
yes installed new version then transferred then installed update for new version then played ?

thanks for quick reply Eventure :)

edit, also noticed when i jump to a system i've already visited the star class is reset to unknown and i cant set it via the summary panel dropdown (dropdown doesn't appear when i click on unknown)

Hmm, maybe you send me an error report, incl. database. Did you using the ED Beta? Attach also the database, from where you transferred your data.
Thanks.
 
Hmm, maybe you send me an error report, incl. database. Did you using the ED Beta? Attach also the database, from where you transferred your data.
Thanks.

thanks again, sent the databases for old and new and no i dont use ED Beta

also the dropdown does appear on summary panel but it takes a while and then when i click on the star class i want to set, it takes a few seconds to set it (so never mind that problem :)

thanks again for your efforts Eventure :) Awesome :D
 
Hmm, maybe you send me an error report, incl. database. Did you using the ED Beta? Attach also the database, from where you transferred your data.
Thanks.

i have re-transferred my database as you requested but i still have only 1 visited system again, the system i am currently in was visited and now its not and i scanned a whole system earlier today which has now disappeared from my cartography panel :(

2h3v9kl.jpg

can this be fixed ?

thanks again :)

edit : after running my TCE-OLD version 1.5.2.2 my data is back to normal again ?

2mxsm.jpg
 
Last edited:
i have re-transferred my database as you requested but i still have only 1 visited system again, the system i am currently in was visited and now its not and i scanned a whole system earlier today which has now disappeared from my cartography panel :(


can this be fixed ?

thanks again :)

edit : after running my TCE-OLD version 1.5.2.2 my data is back to normal again ?


Found the issue, will be fixed with the next version. Will send you the fixed database per mail.
 
tryed faction panel, got data , i selected a faction, which appeared in the button at top, was (unselected) , got a error when i pressed that button...
also "current star system " is showing stored factions list ,, after i looked in stored factions.

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Data.SQLite.SQLiteException (0x80004005): SQL logic error or missing database
near " ": syntax error
at System.Data.SQLite.SQLite3.Prepare(SQLiteConnection cnn, String strSql, SQLiteStatement previous, UInt32 timeoutMS, String& strRemain) in c:\dev\sqlite\dotnet\System.Data.SQLite\SQLite3.cs:line 1470
at System.Data.SQLite.SQLiteCommand.BuildNextCommand() in c:\dev\sqlite\dotnet\System.Data.SQLite\SQLiteCommand.cs:line 388
at System.Data.SQLite.SQLiteCommand.GetStatement(Int32 index) in c:\dev\sqlite\dotnet\System.Data.SQLite\SQLiteCommand.cs:line 395
at System.Data.SQLite.SQLiteDataReader.NextResult() in c:\dev\sqlite\dotnet\System.Data.SQLite\SQLiteDataReader.cs:line 1434
at System.Data.SQLite.SQLiteDataReader..ctor(SQLiteCommand cmd, CommandBehavior behave) in c:\dev\sqlite\dotnet\System.Data.SQLite\SQLiteDataReader.cs:line 123
at System.Data.SQLite.SQLiteCommand.ExecuteReader(CommandBehavior behavior) in c:\dev\sqlite\dotnet\System.Data.SQLite\SQLiteCommand.cs:line 872
at System.Data.SQLite.SQLiteCommand.ExecuteReader() in c:\dev\sqlite\dotnet\System.Data.SQLite\SQLiteCommand.cs:line 884
at Trade_Computer_Extension.Panel_Factions.QRY_FactionSystems(String FactionName) in F:\Trade Computer Extension\Trade Computer Extension\Panel_Factions.vb:line 787
at Trade_Computer_Extension.Panel_Factions.BTN_Faction123_Click(Object sender, EventArgs e) in F:\Trade Computer Extension\Trade Computer Extension\Panel_Factions.vb:line 695
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Label.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1637.0 built by: NETFXREL3STAGE
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
Trade Computer Extension MK.II
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/TCE/Trade%20Computer%20Extension%20MK.II.exe
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 10.0.0.0
Win32 Version: 14.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1637.0 built by: NETFXREL3STAGE
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1638.0 built by: NETFXREL3STAGE
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Data
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1636.0 built by: NETFXREL3STAGE
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
System.Xml.Linq
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll
----------------------------------------
System.Data.SQLite
Assembly Version: 1.0.99.0
Win32 Version: 1.0.99.0
CodeBase: file:///C:/TCE/System.Data.SQLite.DLL
----------------------------------------
System.Transactions
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll
----------------------------------------
System.EnterpriseServices
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/System.EnterpriseServices/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll
----------------------------------------
System.Numerics
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll
----------------------------------------
System.Management
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Management/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Management.dll
----------------------------------------
Accessibility
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0 built by: NETFXREL2
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
System.Windows.Forms.DataVisualization
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1586.0
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms.DataVisualization/v4.0_4.0.0.0__31bf3856ad364e35/System.Windows.Forms.DataVisualization.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
 
Last edited:
hey again :) you Sir are awesome :D thanks for your continued hard work and many big efforts to fix peoples problems Eventure :)
 
Last edited:
tryed faction panel, got data , i selected a faction, which appeared in the button at top, was (unselected) , got a error when i pressed that button...
also "current star system " is showing stored factions list ,, after i looked in stored factions.

Please use the Report an Error button at the launcher, so I can check, what data is available. What is the name of the faction, you selected?
Thanks
 
Last edited:
does it matter if i restart TCE i can't send via error button, i don't use a mail handler
faction selected was Hutton Orbital Truckers
 
Last edited:
Top Bottom