Release v1.2.0 elgato stream deck button plugin for elite dangerous

Oh well got an minor but important issue-ish.

gif won't work when use as ON image and OFF imagine in your plugin....

made a set of simple ED style gif and found out it won't animated, it seems it can only use the first frame of the gif as a static picture for some reason.

Is there any possible fix on this? Many thanks!
 

Attachments

version 1.8.0

Added 3 FSD related buttons:
  • Toggle FSD, also shows Remaining Jumps In Route
  • Supercruise
  • Hyperspace Jump, also shows Remaining Jumps In Route
These FSD buttons have 3 images:
  • engaged : supercruise/hyperspace is active
  • enabled : supercruise/hyperspace is inactive
  • disabled : supercruise/hyperspace is blocked because : Docked, Landed, LandingGearDown, CargoScoopDeployed, FsdMassLocked, FsdCooldown, HardpointsDeployed

 
version 1.9.0

added limpet controller button
The button works with any type of limpet controller.
The button also shows the current number of limpets in the cargo hold. (The same value is shown on all buttons).

There is no specific keybind for any type of limpet controller.
Instead, you need to set up a fire group letter and primary or secondary fire button.

 
Awesome program! I just bought the Stream Deck 3x5 pad, downloaded and installed the plugin from here: https://github.com/mhwlng/streamdeck-elite/releases, grabbed the images from the source code. and things seems to be working. I have these buttons working as expected: Cargo, Lights. Analysis, Landing Gear. However, the Night Vision is not working .. I bound it to 'I', and when pressing 'I', the night vision right-panel feature toggles, as well as the on/off image for Night Vision on the Stream Deck panel. However, pressing the Stream Deck button does nothing. I added 'R' as a second binding as an experirment, and my keyboard works for both, but not the Stream Deck. Any ideas?
 
Last edited:
If that button is only linked to a joystick button or controller button then it won't work.
It needs a (secondary) keyboard binding.

This is what my binding file looks like :

<NightVisionToggle>
<Primary Device="Keyboard" Key="Key_N" />
<Secondary Device="{NoDevice}" Key="" />
</NightVisionToggle>


If I press the stream deck button, then I see the night vision in the right panel toggle :



I am currently docked at a station and the button state image doesn't change.
Perhaps that is normal in a situation where night vision is not functional in the game (e.g. docked)..
I will verify later today, when I am not at work.
 
Last edited:
No, I am out in an asteroid belt, and NV is bound only to key(s). However, I completely exited from ED and tried again and thie Night vision is now working. Cannot explain ....
 
I am not sure how some of these functions are intended to work from the github doc. Is this normal behavior?
  • "Limpet" properly shows my inventory of collector limpets, the ON image is always shown, and does not do anything when pressed. I have the Fire Group and Primary/Alternate set correctly
  • The "Hard Points" button turns ON and OFF as I select hardpoints with joystick button or kbd shorcut ['], but does not do anything when pressed
  • The "SCB" button doesn't change colors and does nothing when pressed. SCB is bound to [Z] which works fine
I must be missing something basic here...
 
Last edited:
1) If a button is only linked to a joystick button or controller button then it won't work.

2) note that when you change any key binding in ED, you will need to restart the streamdeck software (right click tray icon : quit streamdeck).

3) the scb button only lights up when you are under attack and your shields are down

4) for limpet controller button to work, you need these 4 key bindings

<PrimaryFire>
<Primary Device="231D0127" Key="Joy_1" />
<Secondary Device="Keyboard" Key="Key_K">
<Modifier Device="Keyboard" Key="Key_LeftAlt" />
</Secondary>
</PrimaryFire>
<SecondaryFire>
<Primary Device="231D0127" Key="Joy_27" />
<Secondary Device="Keyboard" Key="Key_L">
<Modifier Device="Keyboard" Key="Key_LeftAlt" />
<Modifier Device="Keyboard" Key="Key_RightControl" />
</Secondary>
</SecondaryFire>
<CycleFireGroupNext>
<Primary Device="T16000MTHROTTLE" Key="Pos_Joy_RZAxis" />
<Secondary Device="Keyboard" Key="Key_L">
<Modifier Device="Keyboard" Key="Key_LeftAlt" />
<Modifier Device="Keyboard" Key="Key_RightShift" />
</Secondary>
</CycleFireGroupNext>
<CycleFireGroupPrevious>
<Primary Device="T16000MTHROTTLE" Key="Neg_Joy_RZAxis" />
<Secondary Device="Keyboard" Key="Key_L">
<Modifier Device="Keyboard" Key="Key_LeftAlt" />
</Secondary>
</CycleFireGroupPrevious>


Also hardpoints need to be deployed to be able to fire a limpet.
the plugin does not do this for you.
I have 'auto deploy hard points on fire' activated, so this is automatic.

5) for hardpoints to work you need this key binding

<DeployHardpointToggle>
<Primary Device="{NoDevice}" Key="" />
<Secondary Device="Keyboard" Key="Key_M">
<Modifier Device="Keyboard" Key="Key_LeftAlt" />
<Modifier Device="Keyboard" Key="Key_RightControl" />
</Secondary>
</DeployHardpointToggle>


6) for SCB you need this key binding

<UseShieldCell>
<Primary Device="{NoDevice}" Key="" />
<Secondary Device="Keyboard" Key="Key_Q">
<Modifier Device="Keyboard" Key="Key_LeftAlt" />
<Modifier Device="Keyboard" Key="Key_RightShift" />
</Secondary>
</UseShieldCell>
 
Last edited:
Ok the Collector Limpets were still not working for me (details below). In troubleshooting I think that the L_ALT modifier is not being used by your program. I bound the Secondary Fire to [L] and that worked.

Error description follows....
  1. "Firing deploys hardpoints" in ON.
  2. The Collector Limpet controller is assigned to B-Secondary as well as L_ALT+L. Keyboard and Joystick work..l,.l,.l,.l,
  3. Hardpoints are deployed in Analysis mode with "COLLECTOR" showing on left weps axis
  4. I have restarted Elite, restarted Stream deck, and completely rebooted to no avail.
  5. When I press the Stream Deck Limpet button, I see the ship's Wep display flash over to the correct group (B).
I have 2 Collector Limpet controllers, and both are assigned to the same wep button/group, but it didn't help to only use one.

Here are the relevant bindings:

Rich (BB code):
My bindings:
<PrimaryFire>
    <Primary Device="Keyboard" Key="Key_K">
        <Modifier Device="Keyboard" Key="Key_LeftAlt" />
    </Primary>
    <Secondary Device="ThrustMasterTFlightHOTASX" Key="Joy_1" />
</PrimaryFire>
<SecondaryFire>
    <Primary Device="Keyboard" Key="Key_L">
        <Modifier Device="Keyboard" Key="Key_LeftAlt" />
    </Primary>
    <Secondary Device="ThrustMasterTFlightHOTASX" Key="Joy_2" />
</SecondaryFire>
<CycleFireGroupNext>
    <Primary Device="Keyboard" Key="Key_Period" />
    <Secondary Device="ThrustMasterTFlightHOTASX" Key="Joy_3" />
</CycleFireGroupNext>
<CycleFireGroupPrevious>
    <Primary Device="Keyboard" Key="Key_Comma" />
    <Secondary Device="{NoDevice}" Key="" />
</CycleFireGroupPrevious>
 
Last edited:
Top Bottom