Amazingly Realistic Immersion Mod

Thank you everyone for doing the hard work here.
I wish these tweaks were available out of the box in ELITE itself.

I tried the mod out, but at some point I got so lost in tweaks and re-tweaks to the point of my lightning getting bugged, so I just reverted back to vanilla.
I'll be returning in a couple months maybe

BTW thank you for HUD modification tutorial. I'm using my blue color scheme all the time
 
PrototypeLightingBalancesEnabled to 0

@Old Duck thanks for previous reply. Is there any way to toggle this setting in-game, perchance? I realise it’s in the graphicsconfig.xml and not the 3dx.ini. But, when flying sometimes the mod makes the planet super bright and the ship by contrast super dark. Thanks :)

CA0F6728-C2C1-40B2-B4CA-D4787D218516.jpeg



This is what the other guy sees looking back at me on Vanilla settings:

F451B2B5-30FB-4F62-80AD-D5956A1F727A.jpeg
 
Last edited:
@Old Duck thanks for previous reply. Is there any way to toggle this setting in-game, perchance? I realise it’s in the graphicsconfig.xml and not the 3dx.ini. But, when flying sometimes the mod makes the planet super bright and the ship by contrast super dark. Thanks :)

View attachment 197853


This is what the other guy sees looking back at me on Vanilla settings:

View attachment 197854
Try the F4 key to toggle ambient lighting, which should fix the "your ship is too dark on planet surfaces and rings" effect.
 
Yep, that worked perfectly, thank you. Sort of embarrassed I didn’t try that myself actually as I know that toggle exists. Just never used it or thought to. Cheers @Old Duck
 
I added 3Dmigoto today.

I'm now seeing a green overlay:

VS:0/0 PS:0/0 CS:0/0
Stereo disabled

Is there a way to disable this overlay?
 
The last 2 client upgrades deleted all my 3dmigoto stuff from the ED folder, as well as my edited .ini file. Looks like the upgrade process now purges unknown files!

So, word to the wise, back up your stuff once you have it the way you like it.
 
Can't imagine why this thread is not pinned to the top of discussion.

I find myself bookmarking it. I'm sure some go thread hunting to find it again.

Two pinned pictures threads, one the best of and one FAQ thread at the top of discussions, but no HUD Mod!

How about it Moderators. This one deserves a pin.
 
I added 3Dmigoto today.

I'm now seeing a green overlay:

VS:0/0 PS:0/0 CS:0/0
Stereo disabled

Is there a way to disable this overlay?
I get the same thing on my second account (free one from Epic), pops an error saying D3DCOMPILE_47.dll isn't installed and those green texts overlay the game. This doesn't happen on my Steam version. I don't know if there's a particular issue between the two, I just run the second account for my gf so she doesn't use the mod anyway. =]p
 
I uninstalled the mod and had steam to verify the files then copied the mod files over again with the ini file and it worked without the green text. It worked except the interior ship lights were off and the interior was dark except the panels & sensor. Is there a setting in the ini that can be changed to allow for the ship's interior lights?
 
This is great, i have been playing around with it and i love it but the problem is it doesn't work in every system.
the skybox will switch back to vanilla in some systems.
 
Trying to wrap my head around what to do to bring the original color scheme back and still make use of the mod. From what I've read in previous posts I should just be able to remove color matrix entries from graphicsconfiguration.xml file right?
 
Apologies if this has been asked before (and double apologies if this was by me!) but, in night vision, I'd like to make the lines thinner and more subtle. In the most recent mod, there is this shaderfix file: 0f2b92ba5625c61f-ps_replace

In here, there is this code:

Code:
  // Attenuate "Tron" lines
  // TODO - something more elegant (I'm just experiment at the moment)
  if (o0.a > 0.2) o0.a /= 20;
  else if (o0.a > 0.08) o0.a /= 5;
Can anyone explain exactly how this works?

Many thanks! :)

EDIT: Nevermind, see here, the fantastic Old Duck already replied to this exact question: https://forums.frontier.co.uk/threads/amazingly-realistic-immersion-mod.535240/post-8596047

... and it was me who asked the question! (Shame face: on)
 
Last edited:
Trying to wrap my head around what to do to bring the original color scheme back and still make use of the mod. From what I've read in previous posts I should just be able to remove color matrix entries from graphicsconfiguration.xml file right?
That and remove any shaders that are related to the HUD.

Sorry for delayed reply, I haven't been doing much with ED lately.
 
is there a way to get rid of the night vision and have the the planet surface at night be rendered as it was before some stupid on the forum moaning for the lack of realism?
 
is there a way to get rid of the night vision and have the the planet surface at night be rendered as it was before some stupid on the forum moaning for the lack of realism?
Yes turn off prototype lighting and turn on ambient lighting (covered in detail earlier in this thread).
 
Top Bottom