Patch Notes Update April Update - Patch 1

Hey Commanders, thank you for letting us know about vanishing missions (both new and old). The team are already working on this, and we'll provide you an update when we have more info!

Thank you for also using the Issue Tracker to report this to us, the information provided there alongside screenshots is super helpful in assisting our team to track down issues!

Updated issue title/description to include missions that were accepted before the patch.

In the meanwhile, the frame drop problem seems to be gone, at least I've experienced it near stations (approaching entry) before, but it looks smooth now.
 
I patched game via steam but still cant log in. I have new orange messagebox with loggin in text and after that new message about failed connection. I dont even see main menu. Game is exiting to launcher.
 
  1. Patched via Steam (got "Update available" right after ~30min after servers went down)
  2. Ran Launcher and entered game
  3. Confirm all good so far (most importantly: modules priorities bug fixed, 10cr bug fixed, no FPS drop with FX on High).

"The Imperial Navy thanks Frontier Developments for understanding the importance of continued and unconditional excellence, and wants to ensure that all security personnel stationed in this facility also keeps such excellence in their highest regard."
 
Last edited:
I patched game via steam but still cant log in. I have new orange messagebox with loggin in text and after that new message about failed connection. I dont even see main menu. Game is exiting to launcher.

What's your client version? It's working OK for me with this: 0.4.6576.0 (0.4.6568.0 Server)
 
And actually I'm not that far behind you...!

Anyway, rebooting my PC worked, the upgrade is installing now.
Young whippersnappers bleating, I'll just wave my pension book at you as I scoot by in my Courier....

Power management settings now holding, restock is fine, graphics good again... I could almost like this game :)
Now for some comic BH in the Courier...

Thanks Devs, looking good to me!
 
POWER PRIORITIES still BROKEN for Guardian Shield Reinforcement Package !!
There is NO indication at all ... there goes the power into the drain !?

Note: I had the starting tip stating that module power priorities are important :)
 
Display of 'Next' in nav panel is a bit b0rked

es9bvar.png

Yep, I can confirm this, seems to only happen on the last jump:
myDLrQV.png


I've created a new issue tracker here if you haven't already:
 
Hi All,

is there an option in FSS to avoid centering on main object when zooming out ?

It was not like that before the patch, so I'm wondering if it is an option, or a bug, or a new feature.
 
Nice, framerate is back to normal on PS4 when near and inside stations.

I am still experiencing micro-freezes on PS every 15 seconds or so when zooming around on a planet surface in my SRV. I am in a PG where I am the only one logged in. I am wondering if an uninstall/reinstall of ED on my PS would remedy it.
 
I am still experiencing micro-freezes on PS every 15 seconds or so when zooming around on a planet surface in my SRV. I am in a PG where I am the only one logged in. I am wondering if an uninstall/reinstall of ED on my PS would remedy it.

You could try do a rebuild of the database on your PS4.
 
Do the frame rate issues in console where solved? I'm on X1X and the lag was noticeable.

Hi.

On XB1X I was getting an unsmooth performance when panning in the in-cockpit camera mode (as opposed to the external camera mode), when in stations. Since this fix today I am getting smooth panning now, even on 4K Quality.
 
Was doing the first Ram Tah mission for the first time. Was halfway through. That mission is gone. :( And 2 private groups I joined yesterday are gone too.
 
Top Bottom