Graphics Mod to Remove Haze

Following the recent patch to ED I have updated the mod to use the most recent version of 3DMigoto. If you are using an earlier version of the mod there is no need to update it unless you are experiencing problems (error messages) since the recent ED patch.

The mod contains the same options as the earlier versions, which are:

  • Remove particles (star streaks) in supercruise.
  • Remove particles (dust) in normal flight.
  • Remove vertical lines from the cockpit in supercruise.
  • Remove streaks from ship windscreen.
  • Remove the haze from inside of starports.
  • Remove the haze when on planet surfaces.
  • Remove external "circle", object and target placeholders and orbital lines (hard mode).
The mod options can be enabled or disabled to your liking. All mod options are enabled by default except hard mode which is for CMDRS wanting a more challenging play mode.

The mod was tested in 2D and VR using un-modded standard game settings in "ultra". A PC version of ED purchased through the Frontier Developments or Steam Store is required. The mod may work with a PC version of Elite Dangerous purchased through the Oculus Rift Store, but some issues have been detected by CMDRS using that version of the game. Testing the mod on my rig (Win 10, Nvidia graphics card) did not throw up any loading errors and all of the mod options appeared to work as intended.

If you would like to try the mod or update an earlier version of the mod, then:

1. Uninstall any existing version of 3DMigoto using the "uninstall.bat" file (found in the existing installation directory).

2. Download 3DMigoto (version 1.3.14) from GitHub.

3. Extract the archive into a temp directory.

4. Copy all of the contents of the X64 directory to the same directory as your ED executable (the game directory will end in something like "C:\ … \Products\elite-dangerous-64").

5. Download the attached .txt file and rename it "d3dx.ini" (without quotes).

6. Place modded d3dx.ini file in the same directory that you installed 3DMigoto (to replace the default d3dx.ini file).

That's it. Ready to go! Just play ED as you normally do.

NOTE: Don't forget to refresh your game shaders after installation of the mod using the game settings (which allow you to reload the shaders on startup). :)

ATTACHED FILE: View attachment 122918

NOTE: Updating ED will remove the 3DMigoto and the mod. Just reinstall in the same way after the update to keep using the mod.
mmm
trying to reinstall after Tuesday's update, but can't see any attachment for the d3dx.ini file? Or is it this b*****d new forum & I just can't see it??


as you were, I found it!!!
 
Is there any way to remove the writing at the top and bottom of the screen? Green writing at the top says : VS: 0/0 PS: 0/0 CS: 0/0 Bottom says: Stereo Disabled.

I didn't see an option for it but likely I missed it. Or maybe I did something wrong during the install but the mod seems to work. No errors and no station fog. It's not an issue in VR but I play in flat sometimes.
 
Is there any way to remove the writing at the top and bottom of the screen? Green writing at the top says : VS: 0/0 PS: 0/0 CS: 0/0 Bottom says: Stereo Disabled.

I didn't see an option for it but likely I missed it. Or maybe I did something wrong during the install but the mod seems to work. No errors and no station fog. It's not an issue in VR but I play in flat sometimes.
You may have "hunting" on.

Try the following:

1. Uninstall 3DMigoto using the uninstall.bat file. Then reinstall using the latest version of 3DMigoto - see post 183 (use the .ini file attached to that post - note that you will need to rename the file once you have downloaded it). That file has the correct settings.

2. If you are already using the latest version, open the dx3d.ini file in notepad, scroll down to hunting and make sure it is set to "hunting=0" (no quotes).
 
You may have "hunting" on.

Try the following:

1. Uninstall 3DMigoto using the uninstall.bat file. Then reinstall using the latest version of 3DMigoto - see post 183 (use the .ini file attached to that post - note that you will need to rename the file once you have downloaded it). That file has the correct settings.

2. If you are already using the latest version, open the dx3d.ini file in notepad, scroll down to hunting and make sure it is set to "hunting=0" (no quotes).
It's a new install and I got the latest file a few days ago. Along with the file you provided. Assuming I installed everything correctly i should be running on default since I've not messed with any options yet. Dont know if it's an issue since I've not had any errors but I should mention I'm running a tone map from the ED Profiler. I'll go over everything tonight when I get home.

Thank you for your efforts o7

Edit: Hunting was set to 0. Saw the number pad mentioned a few times in options so I hit 0 and the writing went away. The option would suggest I have hunting on but it shows off. So I don't know what's going on but it seems to work.

; Key to turn hunting itself on/off. This will also show/hide overlay.
; Hunting must be set to either 1 or 2 to enable this toggle.
toggle_hunting = no_modifiers NO_VK_DECIMAL VK_NUMPAD0
 
Last edited:
Looks like toggling hunting is possible despite the hard setting. Odd, but nice to know. I may look at this a bit closer on the next update if I get time, but ATM using the hot key seems to sufficient to resolve the issue. :)
 
Last edited:
So I downloaded the latest version 1.3.16 and I unzipped it, but there is no X64 folder. I probably did something wrong.
EDIT: nm I figured out what I was doing wrong
 
Last edited:
So I downloaded the latest version 1.3.16 and I unzipped it, but there is no X64 folder. I probably did something wrong.
EDIT: nm I figured out what I was doing wrong
Good, 1.3.16 iprobably works. Note though that the mod is based on 1.3.14 which can be downloaded from the same site. :)
 
Well all this is fine and dandy but it's done absolutely zero for by black levels on the Rift S which is what I'm mainly wanting to improve.
Any specific settings tweaks anyone can recommend?? I want black space.
 
I was directed here from another thread. Does this mod still work all these months later? Does it rewrite core ED files, and if so, can I back those files up and restore them later if I don't like the mod?

Regarding turning off all the canopy HUD clutter (hard mode), can I still target planets and ships? I don't mind them not having HUD overlays (I'd actually prefer that), but I still want to target them using normal methods.
 
Yes it works. It does not modify any ED files. I use it all the time. I have not tried 'hard mode' I just remove dirt and space dust.
 
Yes it works. It does not modify any ED files. I use it all the time. I have not tried 'hard mode' I just remove dirt and space dust.
But I could keep dirt and space dust (I like these in VR) if I want, yes? Each setting is independent IIRC.

I can't wait to try this!
 
NOTE: Don't forget to refresh your game shaders after installation of the mod using the game settings (which allow you to reload the shaders on startup). :)
How EXACTLY do I do this?

UPDATE - I got it working!

I really like how this cleans up my view through the window. The big drawback is the loss of targeting reticles in combat, which is particularly challenging when using fixed weapons like rail guns. Is there a way to make bring back just this and leave all other clutter off? If not, can "hard mode" be bound to a key to allow me to toggle it on and off?

The other thing I noticed is now I can clearly see the 2D sprite smoke in stations. I'm guessing this was masked by the haze. It's annoying in VR, because it rotates as I turn my head. Is there a setting in ED's GraphicsConfiguration.xml file that would allow me to get rid of all this sprite smoke? I don't need it.
 
Last edited:
The other thing I noticed is now I can clearly see the 2D sprite smoke in stations. I'm guessing this was masked by the haze. It's annoying in VR, because it rotates as I turn my head. Is there a setting in ED's GraphicsConfiguration.xml file that would allow me to get rid of all this sprite smoke? I don't need it.
That dirt/haze seems to make everything look worse. I think removing it makes the entire game look much better. I even suggested a toggle for it, but FD declined. At least on PC we can remove it with this filter.
 
That dirt/haze seems to make everything look worse. I think removing it makes the entire game look much better. I even suggested a toggle for it, but FD declined. At least on PC we can remove it with this filter.
But that doesn't remove the 2D "smoke" sprites floating around in the station. I agree, the station looks awesome without the haze, but the haze hid these sprites. Now that the haze is gone, these sprites are right there in my face, rotating around as I move my head in VR. I sure would like to turn them off the way I can turn off bloom and light cones.
 
I was directed here from another thread. Does this mod still work all these months later? Does it rewrite core ED files, and if so, can I back those files up and restore them later if I don't like the mod?

Regarding turning off all the canopy HUD clutter (hard mode), can I still target planets and ships? I don't mind them not having HUD overlays (I'd actually prefer that), but I still want to target them using normal methods.
  • The mod still works as far as I know. May update it after fleet carriers drops - depends on time. The mod was just a thing for me to remove the haze after tone-mapping got nerfed, so don't spend much time on it.
  • Hard mode removes ALL HUD cues, including targeting and aiming. This means they likely use the same game shaders so may not be able to have some cues and not others.
  • The mod doesn't modify any game files - can uninstall it any time and the game will be back to normal.
  • Re a hot-key, I think it may be possible to turn the mod off/on - Have a look at the DX file which goes into the key-bindings for 3DMigoto.
 
I absolutely LOVE the "hard mode" that removes all that HUD clutter. It makes some things a bit challenging (aiming fixed weapons and finding outposts on planets), but all in all, it's a big win for me.

On this note, would it be easy to remove the visuals for ships in supercruise? I'm talking about these bright glowing "comets". I'd prefer not to see anything out my window for ships, relying solely on my instruments, like a submarine using sonar. Again, I'm just talking supercruise comets, not actual ships in real space. I guess it all depends if these comets are 3D assets like planets are, or are they separate sprites like space dust is.

Anyway, if it's trivial, would you consider posting the three lines of code for the ini file here in this thread? I'd very much appreciate it!
 
OH NO!! I just installed the latest NVidia driver, and it disabled the "hard mode" feature! Other things are still working, like removing supercruise lines, dust, etc. but my favorite feature no longer works!

Any suggestions?
 
Thank you very much for this mod. I searched all over for a clean canopy solution but came up empty.
This works great. The station haze and SC lines removal is an extra bonus!

Special thanks to my friend Old Duck for bringing this to my attention.
X.

PS.
Old Duck I hope the hard mode gets fixed for you. In the meantime, try rolling back to the previous drivers.
I've done it a bunch of times without any issues. X.
 
Top Bottom