Graphics Mod to Remove Haze

Thanks. I checked and the folder "shaderFixes" along with 6 hlsl files (that the error says cannot find, which by the way only shows up on the mirror display for few seconds -and not in the headset) are indeed there!
One thing that I see that is funny is if you look in the d3dx file, the path for those files is "vs = ShaderFixes/3dvision2sbs.hlsl". Normally in windows, paths are specified in backslash and not forward slash as far as I know. Could that be the problem?
Also, I disabled the semicolons in order to enable the hard mode but hard mode does not happen.
No, the path relates to custom shaders and you are installing 3DMigoto in the same directory as ED in any case so shouldn't need to define a path.

There is no obvious reason for it not to work so I would suggest:

- uninstall 3DMigoto using the "uninstall.bat" file.
- clean the registry (if you have software you know and trust to do that job).
- Restart your computer.
- Run ED and then close it.
- Reinstall 3DMigoto.
- Replace the default d3dx.ini file with the version at post #121 (which needs to be renamed to the default first).
- Enable the options you want and save (as the same .ini file).

Good to go.

Hopefully (bit of a guess) this will clear out the remnants of what sounds like a left over registry entry resulting from your first installation attempt. :)
 
Last edited:
Hey!

Tried it and really works like a charm. My problem ... I use “Hello V” to inject windows within ED (I know the new Oculus Dash can do so by pinning windows, but you need the Touch controllers to do so). It seems skipping the shaders I don’t want messes up HelloV and I am not able yo inject windows anymore. Real bummer for me ....
 
Thanks CMDRS.

@Jorki Rasalas. So far I have not had any crashes with 3DMigoto so hard to say. The problems you describe are consistent with high game settings or connection issue? I checked the "NPC ball of light" issue you raised earlier. They are still there if you are close enough to the other ship, just not marked in "hard mode". 3DMigoto doesn't appear to put a load on the computer, but uninstall it altogether and see if you still encounter problems.

P.S. Read your edited post and noticed you are using the earlier version of the d3dx file. The new one has a different shader number for the "clean your window" option. For that option try replacing the hash number "e29d91120fc28c8e " with "e37ec68e66eac942". Also can see that you have "hard mode" disabled which means that all external cues should show up. If not try refreshing your shader cache when re-staring the game. Again, uninstalling 3DMigoto will solve the problem regardless if it is shader related.

@Good Death. Shouldn't make any difference as both methods are simply instructing the game to skip a specified shader. That being said, nothing wrong with using .txt files and the default d3dx file if you prefer. As regards the change in lighting, reads like pre 3.3 lighting, Have you made any changes to the graphics config file (via the override file)? If not, you could try disabling the "removes planet haze" .ini option (or .txt file) as that is the only mod I'm aware of that has any affect on planets, and even then only when practically sitting on the surface itself.

Both - Apart from the above suggestions, if you want to continue experimenting with 3DMigoto, try enabling one effect at a time and give it a good run. This will narrow any problem down if it is shader related.
Ah yes, maybe I was up close with the npc to get their balls of light visible.
Didn’t have any problems yesterday with graphics. Will try replacing the d3dx file with your latest. How do I “refresh the shader cache when restarting the game”? What files should be in the shaderfix folder?

edit: my ShaderCache folder is empty
 
Last edited:
Ah yes, maybe I was up close with the npc to get their balls of light visible.
Didn’t have any problems yesterday with graphics. Will try replacing the d3dx file with your latest. How do I “refresh the shader cache when restarting the game”? What files should be in the shaderfix folder?

edit: my ShaderCache folder is empty
Good stuff :)

- From memory there is a ED game setting that gives players the option to prepare shaders on start up. Enable that option.
- By default the "ShaderFixes" subdirectory contains three ".hlsl" files. You don't need to change the contents of that directory to use the modded d3dx.ini file.
 
Last edited:
No problem. Make sure any changes are purely cosmetic (and do not confer an advantage in multi-play) otherwise FD could ban you. [yesnod]
Purely for properly black space and not this grey pish with black patches I'm stuck with..... Oh and no Haze on planets and in stations is a nice bonus.
 
No, the path relates to custom shaders and you are installing 3DMigoto in the same directory as ED in any case so shouldn't need to define a path.

There is no obvious reason for it not to work so I would suggest:

- uninstall 3DMigoto using the "uninstall.bat" file.
- clean the registry (if you have software you know and trust to do that job).
- Restart your computer.
- Run ED and then close it.
- Reinstall 3DMigoto.
- Replace the default d3dx.ini file with the version at post #121 (which needs to be renamed to the default first).
- Enable the options you want and save (as the same .ini file).

Good to go.

Hopefully (bit of a guess) this will clear out the remnants of what sounds like a left over registry entry resulting from your first installation attempt. :)

But the mods do work (aside for hard mode)! So what and where is this register exactly? Can I use windows regedit command?
 
Last edited:
But the mods do work (aside for hard mode)! So what and where is this register exactly? Can I use windows regedit command?
If it's just hard mode that's not working, try replacing its hash with fa1882f467c6f826. That's the correct one for me, and Muskoka. Are you using the Oculus version of the game by any chance?
 
But the mods do work (aside for hard mode)! So what and where is this register exactly? Can I use windows regedit command?
Glad 3DMigoto is now working for you. :)

I was responding to your earlier post that you were getting messages stating "shader not found" etc. This suggested an installation error and that 3DMigoto was looking in the wrong directory for dependent files. I don't know where the registry entry is (or if it exists), but cleaning the registry will remove any entry that is causing 3DMigoto to look in the wrong place assuming the files have since been moved.

If the error is not the cause (and it may not be), then I can only guess why "hard mode" is not working for you. If you are using a version of the game purchased from the Oculus Rift Store, then the suggestion by CMDR Rdmc above may help as other players using that version have encountered a similar issue and changed the hash number as a work around.
 
Last edited:
Glad 3DMigoto is now working for you. :)

I was responding to your earlier post that you were getting messages stating "shader not found" etc. This suggested an installation error and that 3DMigoto was looking in the wrong directory for dependent files. I don't know where the registry entry is (or if it exists), but cleaning the registry will remove any entry that is causing 3DMigoto to look in the wrong place assuming the files have since been moved.

If the error is not the cause (and it may not be), then I can only guess why "hard mode" is not working for you. If you are using a version of the game purchased from the Oculus Rift Store, then the suggestion by CMDR Rdmc above may help as other players using that version have encountered a similar issue and changed the hash number as a work around.
Yes the mods are working (aside from hard mode and maybe clean windows) but the error message still shows up! I purchased ED directly from Frontier and I'm using Pimax5K+.
So can you please tell my how to clear the registries please (maybe using regedit)?
 
Last edited:
If it's just hard mode that's not working, try replacing its hash with fa1882f467c6f826. That's the correct one for me, and Muskoka. Are you using the Oculus version of the game by any chance?
I purchased ED directly from Frontier and I'm using Pimax5K+. I will try that tonight.
 
Yes the mods are working (aside from hard mode and maybe clean windows) but the error message still shows up! I purchased ED directly from Frontier and I'm using Pimax5K+.
So can you please tell my how to clear the registries please (maybe using regedit)?
Ordinarily I wouldn't attempt to manually edit the registry and there is no need just to remove incorrect entries. I use Wise Registry Cleaner to keep my registry in good condition. Its free and reliable.
 
Last edited:
If it's just hard mode that's not working, try replacing its hash with fa1882f467c6f826. That's the correct one for me, and Muskoka. Are you using the Oculus version of the game by any chance?
That worked! Thank you very much! At first I did'nt think I would care much for the "hard" mode, but now that I've tried I LOVE it! It brings immersiveness in VR at a new level for ED without those markers. It makes me feel less playing a game and more actually being in space. I think everyone who plays ED in VR should try it. I wish Frontier would give us a control binding where we can enable/disable all markers like they do for orbit lines.
 
No, the path relates to custom shaders and you are installing 3DMigoto in the same directory as ED in any case so shouldn't need to define a path.

There is no obvious reason for it not to work so I would suggest:

- uninstall 3DMigoto using the "uninstall.bat" file.
- clean the registry (if you have software you know and trust to do that job).
- Restart your computer.
- Run ED and then close it.
- Reinstall 3DMigoto.
- Replace the default d3dx.ini file with the version at post #121 (which needs to be renamed to the default first).
- Enable the options you want and save (as the same .ini file).

Good to go.

Hopefully (bit of a guess) this will clear out the remnants of what sounds like a left over registry entry resulting from your first installation attempt. :)
I followed those steps the the warning message still there! Are those 6 hlsl files supposed to be in shaderfixes folder, or am I suppose to move those over somewhere?
 
I followed those steps the the warning message still there! Are those 6 hlsl files supposed to be in shaderfixes folder, or am I suppose to move those over somewhere?
Leave the files in ShaderFixes folder.

The only other suggestion I can offer is to download and install 3DMigoto v1.3.8 (which is the version I used for the modded d3dx.ini file). I have tried the modded file in 3DMigoto 1.3.14 and did not have any problems so it is a long shot, but there are differences between versions (both in the default d3dx.ini file and the ShaderFixes folder). :)
 
Last edited:
Leave the files in ShaderFixes folder.

The only other suggestion I can offer is to download and install 3DMigoto v1.3.8 (which is the version I used for the modded d3dx.ini file). I have tried the modded file in 3DMigoto 1.3.14 and did not have any problems so it is a long shot, but there are differences between versions (both in the default d3dx.ini file and the ShaderFixes folder). :)
Oh ok that might be the problem. When I installed 3Dmigoto from the link you supplied, I just downloaded the one on the top of the list which I assumed was the latest. So it seems I downlaoded v1.3.1.--- my bad!
Ok so I will uninstall again and reinstall 1.3.14 later tonight.
Thanks

Edit: so that was it I was using old version of 3dmigoto. All good now.
I dont know how you guys figure out this stuff but thankyou for all the help and this great mod!
Cheers!
 
Last edited:
Oh ok that might be the problem. When I installed 3Dmigoto from the link you supplied, I just downloaded the one on the top of the list which I assumed was the latest. So it seems I downlaoded v1.3.1.--- my bad!
Ok so I will uninstall again and reinstall 1.3.14 later tonight.
Thanks

Edit: so that was it I was using old version of 3dmigoto. All good now.
I dont know how you guys figure out this stuff but thankyou for all the help and this great mod!
Cheers!
No problem. Glad you got it sorted. :)
 
I updated to the new version, with the modified .ini file. I had to change the one shader hash for the clean windshield to e29d91120fc28c8e, it was set to e37ec68e66eac942 in the version I downloaded.

Other than that, everything seems to work just fine.

Thanks again, I love the look of ED this way :)
 
I updated to the new version, with the modified .ini file. I had to change the one shader hash for the clean windshield to e29d91120fc28c8e, it was set to e37ec68e66eac942 in the version I downloaded.

Other than that, everything seems to work just fine.

Thanks again, I love the look of ED this way :)
Yes, thanks for all your (and other's) work on this, I like the nice clean look. I've kept the dust in normal space and the vertical lines in SC but got rid of the dust in SC, haze in stations, planets and the dirty windshield. It's good to have options.
 
I've had great success with the default ini set up removing the dust and lines and such, and can't play the other way now. But one question - what would be interfering with my trying to set hunt mode up to look at other shaders? If I set the ini file for hunting to 1, the game will not load. If I do 2, it will load, but will crash if I hit the key to turn it on. Graphics card is an AMD 5770, guessing it's the problem? No big deal really, as I've got what I wanted, just was wondering.
 
Top Bottom