Release Issues with Voice Attack while managing ED's panels

Crowd Source Help

I have given up trying to make voice attack work. I don’t have a background in computing and that means I need their help to the extent that they ignore me now. 3.3 broke it completely. “ I can’t make it work, tell me how?” I asked...”it’s only you” was the response. Sad really, was good for a while though but.
Unfortunately, I guess that is the economic reality. If they charge you $10 they really can't spend $100s of time helping individuals out when the software is working fine for most people.

However the ED Community is large and generous - so how about posting what your problems are here and seeing if anyone can help?

(We'd certainly need more info than 'I can't make it work" though!
 
Going though all the debug files discovered a "corrupted heap" given I had uninstalled VA re-installed VA numerous times to try and fix my issues, to no avail

I went with a more complete solution, just for Voice Attack.

I used this Revo Uninstaller 2.0.6 Free to uninstall VA and used the advance mode to removed all the registry keys associated with VA.

Next step
used Everything Search Engine to delete every folder belonging to VA, rebooted and then re-installed VA, ( you need to re-enter your license key)
Seems the VA uninstaller leaves stuff behind, which if corrupted, 'seems to be' reapplied. In any event doing all that has fixed my issues (I hope) for VA worked for hours without crashing and without a muted mic, and with my favorite plugin the G19 app for Elite dangerous running, the fault with VA was never my PC but with VA itself !


If anyone is interested in the Dumpfiles and Error logs associated with the drama I had with Voice Attack PM me.

Voice Attack was not interested in looking at these files, even after I asked repeatably asked for these logs to be taken and viewed to assist with a Fix and to help stop others from having problems in the future.
I may have to do the same think with the uninstalling thing. I have recently started experiencing similar issues with VA/HCS plugin where it would all load well but in the first 10 minutes a domino effect of commands (I though at first a command cascade) would be responded to by Alix, however no commands were issued by me. I have even turned the mic off and still the VA/HCS is responding. It is as though keyboard commands are being issued within the system. Was working well until a recent Windows 10 update. Although the 3.3.05 EDupdate occured at the same time but based on patch notes, I would tend to think that the windows upgrade may have upset a VA DLL or the like. I am not sure but your success doing the complete uninstall of VA/HCS ad reinstall from a clean base has given me a little more enthusiasm to tackle the issue. This weekend, I will try. Thanks for sharing your success.
 
I'm a little bit late to the party, but the internet does a great job of holding on to information that can be accessed for years to come. I figured I needed to at least present my side of the story and let readers decide whether or not adequate assistance is given to VoiceAttack users. Let me first say that I enjoy helping people. VoiceAttack is my software and I stand by it - that is, if there is a problem with VoiceAttack itself, I am on it (I really want it to work and be enjoyable). Sometimes there are cases where a user's computer is just not working right. It looks like VoiceAttack is broken, but it's because VoiceAttack is accessing the very components that happen to be problematic in ways that are either unaccounted for or simply cannot be accounted for. Although the problem would be outside of what I could actually fix with the software I write, I understand that these types of situations can be disruptive (and probably stressful) - I do want to see the user be able to use and enjoy the software they paid for so I lend a hand where I can. Since I'm not capable of knowing every possible combination of problems that could go wrong with a user's PC, I'm limited to going step-by-step with a user until something is uncovered that can be recognized or reproduced. Sometimes those types of problems can be fixed - this depends on the user and the user's ability to be clear about what it is that they are doing, have done and what they are experiencing. Sometimes the problems cannot be fixed. This could be by lack of expertise on both parties, or even system failure beyond reasonable repair. Either way, you must work together in order to come up with a solution. As with most things, ignoring instructions or straight up belligerence when working together rarely ends up well. Although fairly patient and not easy to offend, I do have a threshold and have to draw a line at some point.

Fortunately, Steam allows you to recall your public conversations even if they are deleted. Discord, however, does not provide this kind of detail. Since I have no evidence other than what is referred to from the Steam discussion, I can only say that this particular user rebuffed any assistance of other (very experienced) VoiceAttack users on Discord and ended up cursing at them, calling them names and then rage quitting. This user went on to post about the problem in Steam discussion, in which I tended. The public discussion is in the images below.


@sutex

@micmacmoc - where is your forum post that was dismissed?

1.png

2.png

3.png

4.png

5.png

6.png

7.png


edit - typo, clearer images
 
Last edited:
And the dump files where never asked for, the fault with VA was never my system or me, yet there was just endless hoop jumping ... When I first posted Discord about this issue with VA / HSC, a picture of a Frog was posted saying is this a toad.. Which set the stage to where we're at now... ED as always been toxic and is just compounded by the need to rely on 3rd party apps, to acually get information and any enjoyment from this 'game'. As you can tell others who have had issue trying to reslove problems with VA, to no avail, of course where not singled out, but this is what Ive learnt to expect, given the penance for frogs.
 
The information is in the fault file - nobody needs a dump file to see that it's ntdll.dll - it's in plain sight. If you are so dependent on the fault file being given to somebody, why did you never feel inclined to just post the file? The problem is with your system, plain and simple - nobody else ended up having that same problem (then OR now), either with VoiceAttack or HCS' pack or plugin. I spent an inordinate amount of time trying to help you get your setup going again, and all you could do was curse, call names and then claim you were never helped.

Also, if you would have read the context, the picture of the enormous bullfrog I rescued in January was posted for somebody else. In case your're fixated on it for some other reasons, here ya go:

IMG_6610.JPG
 
Last edited:
So, what you are saying is that the very first instruction given would have solved the problem -
"Try uninstalling and reinstalling VA (which I think you've done - doesn't hurt though)."
- had you cleared out all the things from all the subdirectories (which includes plugins) that you had installed outside of VA. However, if you truly disabled your plugins per the instructions given by the Discord users as well as the Steam discussion, the plugins would have never loaded and the problem would not have presented itself. How is this blaming the user?

For the record, VoiceAttack's uninstaller doesn't leave anything behind - except things you've installed separately (you know - other plugins and whatever - things the VoiceAttack uninstaller has no control over). The installer is a simple file copy and the registry keys consist of the installation path and the version number for other apps/plugins to read (registered VA does not rely on any of this). By design, there is no magic here. Of course, if your system is gimping up in some way, who knows what will happen. Effectively, all you have to do to uninstall VA is to delete its root folder - there are no installed/registered dll's and no massive registry settings.

So, to recap (again) -
VA ran fine.
Installed HCS plugin.
VA no longer works.
Fault file says it's ntdll.dll.
Uninstalling and reinstalling VA but not uninstalling the plugin which seems to cause the problem does not fix the issue.
Uninstalling VA and removing everything else and reinstalling VA fixes VA.
Installed HCS plugin no longer has an issue.

This was never VA. Period. You were told this within the first few minutes of posting on Discord. Yet, I still stepped in to patiently help you and you act like you've got something wrong with you.

Also, are we still confused about HCS and VoiceAttack.com being the same company? They are not.

I put the frog back in the pond where he belongs. True story!
 
Last edited:
Riiiighty....I was quite riled by the ‘it’s only you’ comment a few months back, I have uninstalled then reinstalled, ran the voice training several times, ensured all keys are bound. It mostly works now but is still choosy about how and when. The most irritating thing it does (minus pack) is keep shouting ‘fix target’ randomly! There is light at the end of the tunnel...but it’s been months of frustration. I have given up with it for the time being. Yes there are some up to date guides on YouTube now...and I have followed these to get where I am.
 
@micmacmoc - Can you elaborate a little more on the, 'fix target' issue? VoiceAttack itself does not have that type of response.

Also, I'm not recalling simply dismissing anybody in any support outlet without some form of assistance. If I know for a fact that VoiceAttack is having a problem that can be solved, I will address it promptly. If the problem lies outside of VoiceAttack, there's not a whole lot anybody but the user and people local to the user can do about the problem. If I know of ways to get around a problem (Windows, certain issues regarding plugins, botched installs), I'll certainly post them, but, again - if there is a problem on a user's computer there is nobody but the user that is going to be able to solve the problem. The issue with this guy (above) was that he was told immediately (and by several people prior to myself getting involved) in Discord that the problem was with his voice pack and that he would need to address the author of the pack about it. If you install other software with VoiceAttack from other companies and that other software is broken, unless I somehow know something about the issue there is nothing I'm going to be able to tell you other than to address the author of that software. I'm not going to withhold information if I know how to help, but it's only common sense to go after the proper company to ultimately get your problem solved. For instance, if you buy a game for Windows and that game just does not work, do you contact the game developer or do you contact Windows support? If you decide to contact Windows support and they offer some advice but then direct you to the game developer, how is this incorrect, unfair or unhelpful?

The only reason I'm saying all of this is because I'm assuming you are having a similar problem to this other user.
 
My apologies, I am confusing Voice Attack with HCS voicepacks, it was they who said ‘it’s just you’.
Sorry, it’s my mistake.
 
I had heaps of issues with the HCS plugin and Voice Attack, panels was apart of it and been slow responding to commands, that and the mic always been muted, had to keep saying "Wakeup" before each command, it nearly crashed me a few times.

Voice attack itself, keeps closing down, and HSC and Voice attack kept suggesting it must be other third party apps.. ( one of the most used ones) So I deleted / uninstalled that widely used app and the issue of VA closing down and the muted mic still kept happening. Finally I gave up on HSC and VA in Discord in trying to find the problem, as there was no real help forth coming, from either VA or HSC.
So posted in Voice Attack on steam asking if anyone else had the same issues I was having, to see if I could find the problem, only to have that Steam post "disappear". (got another thread going today)

So I decide to remove/uninstall the HSC plugin as that was the only plugin left ( which is a problem using VR now as I cant play without Voice assistance ) and all my binds in ED Options where wiped !.
it was a real mess, still sorting it out, even put in a tick to Frontier ( no help there either) So I went back to HSC Discord, an HSC said "impossible its not HSC Plugin" that could wipe your binds...whatever.
Fact is I deleted HSC Plugin and my binds go south, not making this nightmare up !.

So then I'm left with, no binds and no HSC Voice pack, and no other plugins just plain Voice attack, and still VA keeps shutting down, but at least the mic was no longer muted.... progress hahahaah !

Its clear this problem is seen as 'my fault' or the "PC fault" Yet Ive ran every scan on the system have a paid anti virus and this PC is a 2018 PC gaming build, has the latest of everything, its used for gaming nothing else, built for VR

Ive ran Windows 10 file checker 3 times now, had the Tech from the shop where we pick each part and who built my PC, come to my house ( paid for the service) to check nothing is wrong with my PC !
( bench marks where above avg )

YET STILL VOICE ATTACK KEEPS SHUTTING DOWN.

So in answer to your question is there anyone else having issues .. yes me .. the Question is are there any more players with issues ?
'
This is the error code for Voice Attack shutting down

Faulting application name: VoiceAttack.exe, version: 1.7.3.0, time stamp: 0x5bf1e60a
Faulting module name: ntdll.dll, version: 10.0.17134.556, time stamp: 0x319e0a75
Exception code: 0xc0000374
Fault offset: 0x000d8529
Faulting process id: 0x25c0
Faulting application start time: 0x01d4afbeb5f2c680
Faulting application path: C:\Program Files (x86)\VoiceAttack\VoiceAttack.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: e1feb26f-2ca9-4df1-aac1-b55e24453cdb
Faulting package full name:
Faulting package-relative application ID:
Thats a HEAP ERROR being reported by the Kernel. Without debugging the app with the source code- we can only suggest things to do to eliminate possible errors.
On assistance from VA, I had a short discussion (Programmer to Programmer) with one of their Developer Bods years ago and found him a pleasant helpful chap.

I'm going to ask some Idiot Questions - that means you are free to think me an Idiot for asking the obvious, but Eureka Moments come from the oddest places sometimes!

Are you running VA in ADMINISTRATOR MODE? (some years ago Win10 decided to remove elevated permissions from a plethora of Programming Libraries)
Is/Are your BINDS files in the place that VA and ELITE expects to find them?
Are any of your BINDS file READ ONLY?
Do you have the TARGET window in VA selected to ELITE Client or TARGET WINDOW?
Have you noticed when VA falls over, is it consistent at the same point each time?
Have you just "spoken" to or given VA Commands to see how it responds? (ie. set to target window, open notepad and give it focus....speak some commands to se if VA can comply)

There is the extremely small possibility of the ntdll.dll library being ugh! There are instructions online on how to replace it.

What Motherboard are you running? My current ROG ASUS Z270F sound chip isn't worth a diddly - just doesn't work with headsets properly. Gave up and run with a DAC USB Fob.....saves me loads of grief.

Finally, one of the worst things to consider is either dodgy RAM or Sector in your HD! Intermittent memory faults are a pure sod to tie down on occasions. Try one of the free online memory stress tests, see what they suggest if anything.

Don't get yourself griefed out over this. I spent over 3 decades in IT, sometimes the only way through these things is to treat them as a detective puzzle not a problem - if you can be arsed that is - the hardest puzzle for any developer to determine is the one he didn't look for in the first place!
 
I didn’t spend a day studying IT, it’s why I buy things off those who did. Consequently I expect them to respond helpfully and with dignity with any problems I have. It’s respectful. I don’t expect them to know how to add the necessary hops to make an AIPA rather than an IPA, or how to ‘lager’ a beer. But I bet they’d enjoy them. Be nice eh? It costs nowt.
 
Thats a HEAP ERROR being reported by the Kernel. Without debugging the app with the source code- we can only suggest things to do to eliminate possible errors.
On assistance from VA, I had a short discussion (Programmer to Programmer) with one of their Developer Bods years ago and found him a pleasant helpful chap.

I'm going to ask some Idiot Questions - that means you are free to think me an Idiot for asking the obvious, but Eureka Moments come from the oddest places sometimes!

Are you running VA in ADMINISTRATOR MODE? (some years ago Win10 decided to remove elevated permissions from a plethora of Programming Libraries)
Is/Are your BINDS files in the place that VA and ELITE expects to find them?
Are any of your BINDS file READ ONLY?
Do you have the TARGET window in VA selected to ELITE Client or TARGET WINDOW?
Have you noticed when VA falls over, is it consistent at the same point each time?
Have you just "spoken" to or given VA Commands to see how it responds? (ie. set to target window, open notepad and give it focus....speak some commands to se if VA can comply)

There is the extremely small possibility of the ntdll.dll library being ugh! There are instructions online on how to replace it.

What Motherboard are you running? My current ROG ASUS Z270F sound chip isn't worth a diddly - just doesn't work with headsets properly. Gave up and run with a DAC USB Fob.....saves me loads of grief.

Finally, one of the worst things to consider is either dodgy RAM or Sector in your HD! Intermittent memory faults are a pure sod to tie down on occasions. Try one of the free online memory stress tests, see what they suggest if anything.

Don't get yourself griefed out over this. I spent over 3 decades in IT, sometimes the only way through these things is to treat them as a detective puzzle not a problem - if you can be arsed that is - the hardest puzzle for any developer to determine is the one he didn't look for in the first place!
It was never my PC ( or Me) it was VA, which I fixed below, but given the pointlessness of ED. Ive Park my ship and moved on .
Ive grown weary of the 'tone' associated with this 'game' imagine watching Clockwork Orange and 1984 back to back followed by a home evasion, but thanks for the effort
https://forums.frontier.co.uk/threads/issues-with-voice-attack-while-managing-eds-panels.473032/post-7366077
 
To clarify - it was your botched installation of packs that did not work and not VA itself. Had you followed ANY of the instructions given by the SEVERAL users in Discord, your problem would have been solved in the first few minutes. Instead, you cursed at them and left saying, 'none of that works'. You then went around in a great big circle only to solve your problem with one of the very first things that was suggested. I don't know what level of assistance you would require from the company where you said (paraphrased), 'It (VoiceAttack) was working just fine until I installed somebody else's stuff'. I think the level of effort to support you went well above and beyond given the behavior - and also in light of knowing that it was not my product itself but any support I would provide would simply be just to get you up and running again.

Again - VoiceAttack is NOT HCS's product. VoiceAttack.com (the producer of VoiceAttack) is a separate entity. They are not the same company.
 
I no longer use Voice attack it's uninstalled so therefore will have no further dealings with the developer
 
Last edited:

Jenner

Volunteer Moderator
Just a reminder to 'play the ball, not the player'. No need for name calling. Thank you.
 
Top Bottom