Release Issues with Voice Attack while managing ED's panels

I'm not too sure what's going on in this thread, but I can affirm that integrating VA, HCS voice packs, and EDDI into ED is a project that is not for anyone who isn't willing to invest quite a bit of time and technical know how needed to get things working properly. Additionally, the upgrade process is pretty tedious and really requires a good bit of "under the hood" understanding to get it right.

My instinct here is to assume that if someone is having a problem, it's likely rooted in a lack of understanding of the idiosyncrasies of the individual components and how they fit together. Add to that, the vap files upgrade process is a bit obtuse as well. I have communicated my concerns regarding these problems and have received a reply from the HCS devs that they are continuing to work with the developer of Voice Attack in the hope of achieving a one-click upgrade process, but it's clearly taking some time, which is an indication of the complexity of the task they are facing.

I've been through this a few times, and will share what I do to get things working.

If you've used the "Protocol Override Customize Settings" command to customize an HCS voicepack(s) Singularity VAP, then be sure to open it again and do a backup before an upgrade. Obviously not required for a first time installation. Once that's done, I open VA and delete any vap files currently installed, as I'm going to use the latest vap's from HCS and EDDI once I upgrade to the latest versions.

Open control panel and uninstall ALL HCS installed programs. (If you use EDDI it can be upgraded by using the standalone program independently, and the latest vap file will be in the latest EDDI download).

Once you've purged your system of any HCS previously installed voice packs, download and install the newest versions. I first install the latest HCS Tools program as you only need to do that once and need not repeat after that. Then install the voicepack(s).

Once done, Open Voice Attack and load the Singularity vap contained within any of the recently downloaded voice packs. They are all the same, so you only need do this step once from any of the newly downloaded packs. Once that's loaded, locate the latest EDDI vap from that download and use the "import commands" function to integrate the EDDI vap commands into the Singularity profile.

Once all that is done - if you have saved customizations, as described above, re-load them using the "Protocol Override" screen. (You might back up that directory somewhere before doing this as the interface is a bit quirky and I've made mistakes doing this step - and was very glad I had a backup.)

I think that's the right stuff - anyone spotting an obvious error, by all means chime in.

HTH

All I can affirm is that I've been through this quite a few times, and although I'm not pleased with the process and it's complexity, I'm MORE than pleased with the results.

I doubt I'd still be playing ED without VA/HCS/EDDI - it really adds so much to the game.

Also - Voice Attack is a separate program and can be upgraded independently.
 
Last edited:
I'm not too sure what's going on in this thread
It has nothing to do with 'not understanding installation'.. but understanding can be achieved by reading the entire thread

but thanks for the help, others who still use VA and HSC ( I don't ) may well benefit from your insights
 
Top Bottom