New Client broken - no Horizons?

^it seems this is Windows 7/10 issue for me, both Horizons accounts on Win 7 (Steam and that LEP-Frontier Store account) wont work at all, even in a base game mode.

But at Win 10 computer that other LEP Steam-account works despite that 404-page covering most of the launcher but "launch"-button.
With Win 10 it seems also that base game works without problems (bought from Frontier Store without extras).


E: also through Win 10 running just Frontier store base game with out Horizons/LEP, launcher also had 404 error but instead like with Horizons launcher also had 3 options to choose from below, not just "play/launch".
The http 404 error can be solved by changing "Options -> Select language..." from "Use System Defaults" to "English". Options menu can be accessed by left clicking your email address in right upper corner of the Launcher.

For the Steam related problems maybe the tricks posted earlier in this thread may help.
 
........ Options menu can be accessed by left clicking your email address in right upper corner of the Launcher.
......
Is that a W10 feature? I ask as my launcher does not show my email address but below my name in the upper right corner are listed the menu choices including an "Options" one. I ask out of interest only, not requiring help thanks as my issue was fixed days ago.
 
Is that a W10 feature? I ask as my launcher does not show my email address but below my name in the upper right corner are listed the menu choices including an "Options" one. I ask out of interest only, not requiring help thanks as my issue was fixed days ago.
With the 404 problem the whole client area of the launcher was replaced with the 404 error message, including the menu choices (see post #199). For some reason it showed an email address (hardly visible in deep red on a black title bar). Clicking the email address produced a drop down menu with said language option. Now that the problem is solved the title bar doesn't show my email address anymore and clicking the title bar no longer produces the drop down menu. I think it was the GUI toolkit that Frontier uses for the launcher that messed up the window layout after the unexpected 404 error. It probably has nothing to with Windows 10.
 
With the 404 problem the whole client area of the launcher was replaced with the 404 error message, including the menu choices (see post #199). For some reason it showed an email address (hardly visible in deep red on a black title bar). Clicking the email address produced a drop down menu with said language option. Now that the problem is solved the title bar doesn't show my email address anymore and clicking the title bar no longer produces the drop down menu. I think it was the GUI toolkit that Frontier uses for the launcher that messed up the window layout after the unexpected 404 error. It probably has nothing to with Windows 10.
I see - thanks for that information. I hope all these issues get sorted before too many Steam sale purchasers get fed up and go for a refund.
 
With the 404 problem the whole client area of the launcher was replaced with the 404 error message, including the menu choices (see post #199). For some reason it showed an email address (hardly visible in deep red on a black title bar). Clicking the email address produced a drop down menu with said language option. Now that the problem is solved the title bar doesn't show my email address anymore and clicking the title bar no longer produces the drop down menu. I think it was the GUI toolkit that Frontier uses for the launcher that messed up the window layout after the unexpected 404 error. It probably has nothing to with Windows 10.
So...

Is it yet safe to "update" launcher yet then, if it still plays the game?

Would hate to lose selection for options or forget my email for each of my accounts...
 
You only need to update if you are asked to on starting.
Ok thank you, but would be nice to see Galnet news on a launcher besides 404 again, were my point.

Game launches still fine now and would hate to lose access to some options in a launcher, as stated in what I quoted, if I made some changes.

Then there is my Win 7 accounts I can´t launch even a launcher with...
 
Ok thank you, but would be nice to see Galnet news on a launcher besides 404 again, were my point.

Game launches still fine now and would hate to lose access to some options in a launcher, as stated in what I quoted, if I made some changes.

Then there is my Win 7 accounts I can´t launch even a launcher with...
If the 404 error is the only problem remaining then it is safe to solve it by setting the language option to english as described a few posts up.
 
There is no such option in the launcher at the right up corner. Whenever I click play on steam I get greeted by the 404 error and a PLAY DEMO button,nothing else. I think the launcher auto-logins me without registering my account. And even if I somehow fix the 404 error I doubt it will let me redeem the keys to play the game.
there is. left click on your red email adress in right top corner, and it will open context menu (like windows rmb menu), also there is method in changing language in files. But first i think you need to link accounts.
 
Top Bottom