RCT 3 PC RCT3 disc read error with expansions.

I have owned RCT3 and the Wild expansion on disc for quite some time without complaints. I just bought the CD Soaked expansion brand new. I installed it but it kept saying wrong disc inserted insert RCT3 disc. Which I would then do but it would display the same message. If I inserted my Wild expansion disc it would almost go through the entire loading process but then would have any error (As this was the Wild expansion disc).

I have uninstalled the RCT3 game and the expansions and just reinstalled the base game and then just the Soaked expansion with the same "wrong disc inserted" error.

How do I go about "inserting the right disc" even when it is the correct disc? I have inserted RCT3 base disc (which it says to insert with the same error) and the Soaked disc and it also states the same error. Wild was the only one that would actually begin the play but then would have to "end program" because something went wrong.
 
I know this isn't the answer to your problem, but I would be remiss if I didn't say this now .... go to epic games website, and grab RCT3 Complete Edition now for free.
It's only going to be free for a few more days at the time I write this, you might kick yourself if you miss it.
 
Top Bottom