The Vive discussion Thread

That's so much trouble to go to in order to see the desktop. Can I ask, and I'm genuinely curiously, why the SteamVR desktop mirror default is insufficient? Could I get a screenshot of your SteamVR mirror to get an idea?

If I need to see the desktop without removing my headset, I'll just tap the system button on the left side Vive HMD to toggle the desktop on and off.
 
Last edited:
Too inconvenient / slow. Can't bind a hotkey to it as far as I know and you can't instantly operate the browser like you could with an overlay. That matters when you want to do something else while repeatedly waiting for FSD charging and in witch space.

So it seems for now the Portal + script, that alt-tabs, toggles active and mouse locks the browser window is the best option for now for me personally :/.

Could I get a screenshot of your SteamVR mirror to get an idea?
For me it's something like this:
after pressing shift+tab and by pressing again it goes away and I can control the game again. (so basically it's like Steam Overlay)
 
Last edited:
Hi all wondering if anyone can point me in the right direction here. Havent played ED is a while on the Vive and when I have previously it was all working fine. For some reason now though unless I start the game via Steam itself it wont load in VR. I can have steamvr already running but if I launch it from the Desktop Shortcut or using Dr.Kaii VR program it will just launch as normal on the monitor. I go in to settings and get no HMD option.
Again works great via Steam but not via desktop shortcut (note this was not the steam version purchased but was direct from Frontier).
 
Hi all wondering if anyone can point me in the right direction here. Havent played ED is a while on the Vive and when I have previously it was all working fine. For some reason now though unless I start the game via Steam itself it wont load in VR. I can have steamvr already running but if I launch it from the Desktop Shortcut or using Dr.Kaii VR program it will just launch as normal on the monitor. I go in to settings and get no HMD option.
Again works great via Steam but not via desktop shortcut (note this was not the steam version purchased but was direct from Frontier).
Have you got any custom command line switches set for the executable on the desktop shortcut? ISTR there was something like a /VR or /HMD switch to tell the game to start in 2D mode.
 
Just wanted to share a setting on Vive as I really dig this game. Easily the best VR experience/game I've personally used in VR so far.

One of the only things that puts me off was that using the Vive playing Elite, flying around in space kind of felt like sitting in a simulator in the middle of a planitarium. Like there was a 30' spherical screen around you
and the planets and ships/stations were just displayed in 2D on that screen and I thought the Vive brightness was a bit to blame for that however I've searched and searched and could not find a reliable or working way
dim the Vive screen.

I was messing in the Steam VR overlay settings menu because I have been having issues with the controllers randomly turning off and the HMD also goes black for like 1-2 seconds randomly and then comes back on. Everything had been working fine, don't know if that was Steam VR update or changing the video drivers or what but I was checking the power management settings and found a setting called, "Night Mode".

It maybe dims the screen a bit too much but its not bad at all. I loaded up Elite and wow what a difference. Space looks WAY more like endless space now, flying around a bit everything looks much more realistic and emmersive and the 30' bubble screen is no longer pronounced.

Night Mode for the win!

Now if Dr. Kai would just put a toggle in to turn it on whenever Elite launches...hehe... guy can dream!
 
SteamVR Dashboard settings, first option on their "hub" page.

A good bit too dark for me - I want my suns piercing my eyes with their glaring. :9

Did up my skybox resolution a bit though...
 
Hi all wondering if anyone can point me in the right direction here. Havent played ED is a while on the Vive and when I have previously it was all working fine. For some reason now though unless I start the game via Steam itself it wont load in VR. I can have steamvr already running but if I launch it from the Desktop Shortcut or using Dr.Kaii VR program it will just launch as normal on the monitor. I go in to settings and get no HMD option.
Again works great via Steam but not via desktop shortcut (note this was not the steam version purchased but was direct from Frontier).
I have this too if SteamVR is already started so now I start it with SteamVR not already started...
 
Just wanted to share a setting on Vive as I really dig this game. Easily the best VR experience/game I've personally used in VR so far.

One of the only things that puts me off was that using the Vive playing Elite, flying around in space kind of felt like sitting in a simulator in the middle of a planitarium. Like there was a 30' spherical screen around you
and the planets and ships/stations were just displayed in 2D on that screen and I thought the Vive brightness was a bit to blame for that however I've searched and searched and could not find a reliable or working way
dim the Vive screen.

I was messing in the Steam VR overlay settings menu because I have been having issues with the controllers randomly turning off and the HMD also goes black for like 1-2 seconds randomly and then comes back on. Everything had been working fine, don't know if that was Steam VR update or changing the video drivers or what but I was checking the power management settings and found a setting called, "Night Mode".

It maybe dims the screen a bit too much but its not bad at all. I loaded up Elite and wow what a difference. Space looks WAY more like endless space now, flying around a bit everything looks much more realistic and emmersive and the 30' bubble screen is no longer pronounced.

Night Mode for the win!

Now if Dr. Kai would just put a toggle in to turn it on whenever Elite launches...hehe... guy can dream!
thanks for the night mode, always found the Vive screen way too bright, this fixed a lot of things for me and i find that the flickering due to aliasing is less percieved with night mode on.
 
Hi all wondering if anyone can point me in the right direction here. Havent played ED is a while on the Vive and when I have previously it was all working fine. For some reason now though unless I start the game via Steam itself it wont load in VR. I can have steamvr already running but if I launch it from the Desktop Shortcut or using Dr.Kaii VR program it will just launch as normal on the monitor. I go in to settings and get no HMD option.
Again works great via Steam but not via desktop shortcut (note this was not the steam version purchased but was direct from Frontier).
it's still loading for me but since the latest update I'm getting some strange lags on Vive. Tried disabling background processes which might interfere but it's still laggy with occasional freezes. It seems the latest update broke something for me.
 
Anybody else have problems driving around in the SRV in VR? I'm not particularly prone to motion sickness, but I start getting a headache and a slight queasy feeling when driving the SRV around a planet with particularly rough terrain. I'm wondering if an external camera view would be a better way to go, though I need to play around with my settings to use it -- currently, whenever I switch to the "free-floating" camera, my SRV throttles up and takes off without me (even if at a stop).
 
Just wanted to share a setting on Vive as I really dig this game. Easily the best VR experience/game I've personally used in VR so far.

One of the only things that puts me off was that using the Vive playing Elite, flying around in space kind of felt like sitting in a simulator in the middle of a planitarium. Like there was a 30' spherical screen around you
and the planets and ships/stations were just displayed in 2D on that screen and I thought the Vive brightness was a bit to blame for that however I've searched and searched and could not find a reliable or working way
dim the Vive screen.

I was messing in the Steam VR overlay settings menu because I have been having issues with the controllers randomly turning off and the HMD also goes black for like 1-2 seconds randomly and then comes back on. Everything had been working fine, don't know if that was Steam VR update or changing the video drivers or what but I was checking the power management settings and found a setting called, "Night Mode".

It maybe dims the screen a bit too much but its not bad at all. I loaded up Elite and wow what a difference. Space looks WAY more like endless space now, flying around a bit everything looks much more realistic and emmersive and the 30' bubble screen is no longer pronounced.

Night Mode for the win!

Now if Dr. Kai would just put a toggle in to turn it on whenever Elite launches...hehe... guy can dream!
Thanks for this. Solved the glare issue for me too. Looks so much better.
 
...I'm not particularly prone to motion sickness, but I start getting a headache and a slight queasy feeling when driving the SRV around a planet with particularly rough terrain...
Keep in mind that the ground is much closer to you than any other environments you traverse in the game, and as such whizz past (EDIT: ...and anisotropically, to boot...) at a rate that really benefits from keeping up the frame rate, so that things move smoothly. Things may look pretty good at 45pfs, when at a crawl, but at any speed, the large difference between frames will give the view an almost "stroboscopic" effect. The planets are also rather demanding on your hardware, compared to space.

I assume you are playing through SteamVR/OpenVR? If so, the warning message, with the green and red indicator bar, that you can activate, does not pop up until you have missed- and had to reproject a frame twice, so it is pretty much useless to go by, when optimising for frame rate.

Instead; Go to the performance section (desktop side SteamVR settings window) and click the "show frame timing" button. It will open a window that shows a running graph of your frame render times - it has a checkbox that makes the same graph appear in-VR, "attached to the wrist" of one of your motion controllers - just lay is somewhere you can see it.

What you want here, is to try various decreases in graphics quality, until the game can fairly consistently render each frame in less than 11 milliseconds (don't let it grow higher than the tan box (...I think... colourblind...), which will give you the HMD's native 90 frames per second. You may discover that this proves a higher qualitative sacrifice than you are willing to make (2.0 SteamVR supersampling and max shadows makes ED rather nice - wish we could just max out everything), but these are the matters of taste and physiological tolerances everybody have to evaluate for themselves, finding what tradeoffs work for them. :7
A quick test, is to halve your HMD Quality setting - things will look horrible, but it should put you at a level where your graphics card can keep up.

Otherwise there are the usual same matters as when driving in real life: Being a bit tired does not help in the least, but keeping track of the horizon does. (The game also has an option to lock the camera to the horizon (EDIT: ...and have the vehicle bouncing around you instead); For me, that probably makes things worse. :p)

The external camera does attach to the SRV for me, upon switching to it -- You may want to check your keybindings; Many are added for the new cinematic camera "suite", and maybe you have the one that toggles camera parent shared with something else at the moment, causing an accidental switch to world reference...

Hope this was not only drivel...
 
Last edited:
Just wanted to share a setting on Vive as I really dig this game. Easily the best VR experience/game I've personally used in VR so far.

One of the only things that puts me off was that using the Vive playing Elite, flying around in space kind of felt like sitting in a simulator in the middle of a planitarium. Like there was a 30' spherical screen around you
and the planets and ships/stations were just displayed in 2D on that screen and I thought the Vive brightness was a bit to blame for that however I've searched and searched and could not find a reliable or working way
dim the Vive screen.

I was messing in the Steam VR overlay settings menu because I have been having issues with the controllers randomly turning off and the HMD also goes black for like 1-2 seconds randomly and then comes back on. Everything had been working fine, don't know if that was Steam VR update or changing the video drivers or what but I was checking the power management settings and found a setting called, "Night Mode".

It maybe dims the screen a bit too much but its not bad at all. I loaded up Elite and wow what a difference. Space looks WAY more like endless space now, flying around a bit everything looks much more realistic and emmersive and the 30' bubble screen is no longer pronounced.

Night Mode for the win!

Now if Dr. Kai would just put a toggle in to turn it on whenever Elite launches...hehe... guy can dream!
Can't follow you...where did you find that option?
 
Keep in mind that the ground is much closer to you than any other environments you traverse in the game, and as such whizz past (EDIT: ...and anisotropically, to boot...) at a rate that really benefits from keeping up the frame rate, so that things move smoothly. Things may look pretty good at 45pfs, when at a crawl, but at any speed, the large difference between frames will give the view an almost "stroboscopic" effect. The planets are also rather demanding on your hardware, compared to space.

I assume you are playing through SteamVR/OpenVR? If so, the warning message, with the green and red indicator bar, that you can activate, does not pop up until you have missed- and had to reproject a frame twice, so it is pretty much useless to go by, when optimising for frame rate.

Instead; Go to the performance section (desktop side SteamVR settings window) and click the "show frame timing" button. It will open a window that shows a running graph of your frame render times - it has a checkbox that makes the same graph appear in-VR, "attached to the wrist" of one of your motion controllers - just lay is somewhere you can see it.

What you want here, is to try various decreases in graphics quality, until the game can fairly consistently render each frame in less than 11 milliseconds (don't let it grow higher than the tan box (...I think... colourblind...), which will give you the HMD's native 90 frames per second. You may discover that this proves a higher qualitative sacrifice than you are willing to make (2.0 SteamVR supersampling and max shadows makes ED rather nice - wish we could just max out everything), but these are the matters of taste and physiological tolerances everybody have to evaluate for themselves, finding what tradeoffs work for them. :7
A quick test, is to halve your HMD Quality setting - things will look horrible, but it should put you at a level where your graphics card can keep up.

Otherwise there are the usual same matters as when driving in real life: Being a bit tired does not help in the least, but keeping track of the horizon does. (The game also has an option to lock the camera to the horizon (EDIT: ...and have the vehicle bouncing around you instead); For me, that probably makes things worse. :p)

The external camera does attach to the SRV for me, upon switching to it -- You may want to check your keybindings; Many are added for the new cinematic camera "suite", and maybe you have the one that toggles camera parent shared with something else at the moment, causing an accidental switch to world reference...

Hope this was not only drivel...
Thanks for the suggestions. I don't have any problems if I can see the horizon -- it's just on worlds where the topography is so convoluted that I'm bouncing down into holes and back up again that I start feeling it. Thanks for the suggestion on the "show frame timing" button. I'll watch it a bit and see if I'm having problems with dropped frames. I do occasionally see drops in the little graphic display, but as you say, that display isn't all that helpful. Cheers!
 
Alright, got a question. Just got my Vive in yesterday and was able to start using it today. One thing I noticed right away once in my ship is that when i look around, the hud gets a layering effect to it..basically it seems to split up a few millimeters until i stop moving my head around. Have any of you gotten something like that? Apart from that everything else is fine (though my card runs up to 70-75 on medium VR settings lol)
 
Alright, got a question. Just got my Vive in yesterday and was able to start using it today. One thing I noticed right away once in my ship is that when i look around, the hud gets a layering effect to it..basically it seems to split up a few millimeters until i stop moving my head around. Have any of you gotten something like that? Apart from that everything else is fine (though my card runs up to 70-75 on medium VR settings lol)
I don't have that problem, but it sounds like maybe it has to do with interleaving. Make sure the "Allow interleaved reprojection" is turned OFF in the SteamVR settings under Performance. Allow asychronous reprojection should be ON.
 
Yes its broken the game for me tbh, this is not in VR either.

At first the mouse pointer seems fine but after the first click it looses focus and behaves erratic, extremely annoying. ALT Tab helps grab it back for a second but that's all.

FD are aware of the problem apparently.
 
Yes its broken the game for me tbh, this is not in VR either.

At first the mouse pointer seems fine but after the first click it looses focus and behaves erratic, extremely annoying. ALT Tab helps grab it back for a second but that's all.

FD are aware of the problem apparently.
Ok thanks for comfirmation, its a write pain in the rear thrusters.
 
Top Bottom