Release Trade Computer Extension Mk.II

I've recently returned to the game and am back to using my favorite tool. One small thing I noticed is that since the Beyond we now have the "mapped" status for planets, but there's no such state of knowledge on TCE. Due to this, I'd need to roll back all my previous "explored" systems back to another exploration status just to know if I have some mapping to do.
There is no function to reset the exploration status of all systems at once actually.

Coming back after a break of a couple years and change. I've still got my old TCE install reserved but since it's rather ancient, I figured I'd check if there's anything I should do to upgrade it before even attempting. I didn't see anything in particular in the Wiki relating to such an ancient upgrade, which makes sense since it's probably not all that common. Any tips? No rush, obviously.
It should work without issues. Report if you encounter a problem.

I have 1.8.1.3 but I still can't see any trade routes using Agronomic treatments or Tritium. Also I can't see them in the commodity lists even when I'm in a station that has them for sale.
Can't confirm your issue, found plenty of routes, so it will depend on your filter settings.
 
It should work without issues. Report if you encounter a problem.
Welp, no luck there. Got a cascade of errors. Each of these once:

Error while reading records on table Materials:SQL logic error no such table: public_Materials
Error while reading records on table Duplicates:SQL logic error no such table: public_Duplicates
Error while reading records on table LOC_Rares:SQL logic error no such table: public_LOC_Rares
Error while reading records on table OutfitTypes:Index was outside the bounds of the array.
Error while reading records on table Markets_UR:Index was outside the bounds of the array.

This one twice:
Error while reading records on table Powers:SQL logic error no such table: public_Powers

Then this one in a final popup:
ERROR DETECTED
TCE can't access some database, because it has not the permission to create it!

Please give TCE admin rights at the desktop shortcut or do not install it to a drive with tightened security settings (e.g. your OS drive).
TCE will exit now!

Edit: Forgot to mention I tried granting admin rights without success.
 
Last edited:
Welp, no luck there. Got a cascade of errors. Each of these once:

Error while reading records on table Materials:SQL logic error no such table: public_Materials
Error while reading records on table Duplicates:SQL logic error no such table: public_Duplicates
Error while reading records on table LOC_Rares:SQL logic error no such table: public_LOC_Rares
Error while reading records on table OutfitTypes:Index was outside the bounds of the array.
Error while reading records on table Markets_UR:Index was outside the bounds of the array.

This one twice:
Error while reading records on table Powers:SQL logic error no such table: public_Powers

Then this one in a final popup:
ERROR DETECTED
TCE can't access some database, because it has not the permission to create it!

Please give TCE admin rights at the desktop shortcut or do not install it to a drive with tightened security settings (e.g. your OS drive).
TCE will exit now!

Edit: Forgot to mention I tried granting admin rights without success.
Please do not install the new version over the old. Install it instead into a new folder, then start TCE, select the Database tab and there click onto Transfer, select the folder of your old installation afterwards and TCE will do the rest.
 
There is no function to reset the exploration status of all systems at once actually.
Hmm, I'll leave a suggestion to add a new "mapped" state of knowledge, though with the upcoming Odyssey expansion it could again cause a similar issue.

I also believe it would be helpful to record the demand of stations, as it seems the price that the station offers changes according to how much cargo you have in your hold compared to the station demand. Not sure about specifics on how its calculated, but it can easily get substantial enough to make it more optimal to fill the hold with different commodities.

Lastly, I tried clicking on the donate button but the paypal link doesn't seem to be working. A patreon for setting up an automatic donation every month would also be nice.
 
Please do not install the new version over the old. Install it instead into a new folder, then start TCE, select the Database tab and there click onto Transfer, select the folder of your old installation afterwards and TCE will do the rest.
Crap, that's what I did so the old one was overwritten already. I'll have to tinker and get it restored to before last night because I didn't even think to make a backup. (I should know better than to try anything like this right before bed.) Thanks for the help! :)

Edit: And I got it working. Good thing I have backups. They're just more of a pain than manually making one last night would have been had I thought about it. Thanks again, Eventure!
 
Last edited:
1598858377969.png

Hmm, do I need to add Agronomic treatment by hand to commodities since I can`t see them anywhere? This image is from a station that has them for quite a good price. It doesn´t show in the commodity list or trade routes.
 
Version [1.8.1.4] released
Changelog:
  • Added a 'Mapped' status for the state of knowledge indicator of a star system.
  • Fixed an overflow error when using extreme filter settings at the Route Finder panel.
  • Fixed a display issue at the list of routes when selected at the Route Finder panel.
  • Fixed the Donate button at the Launcher and Options panel.
Notes:
Either download the version above, install and transfer your old database, or use the auto-update function of the launcher.
Click the 'new version' notice at the bottom of the launcher.

If you find an error, please report and use the Report a Bug button at the launcher and don't forget to copy the error details and ErrorReportFile.7z archive.

I like to remind any user, who wants to use TCE in french, spanish or russian to help in translating the
latest interface phrases, common commodities and rare commoditiesat OneSky. Thanks in advance.
 
I'm having an issue displaying TCE mk. II correctly. TCE shows up on my main display but, I run ED on a second monitor in borderless window mode. Is there a setting I'm missing or a way that I can correct this?
 
I don't understand why it doesn't save panel locations... I moved for example a cargo panel to the left side of the screen, so it won't overlap the waypoint panel, but once i reboot TCE it's in the middle of the screen again (Where it was before i moved it)... I can't even find a config file to edit it...
 
I don't understand why it doesn't save panel locations... I moved for example a cargo panel to the left side of the screen, so it won't overlap the waypoint panel, but once i reboot TCE it's in the middle of the screen again (Where it was before i moved it)... I can't even find a config file to edit it...
TCE automatically resets the position of a panel, which is off-screen, even only a part of it.
You can disable this behavior by activating the option Allow Free Panel Placement at the Options panel (Panel Configuration tab).
 
Hello, I've managed to introduce a problem all by myself.
I've gone from three monitors, acting as three different monitors, to 3 of them acting as one, so with a resolution of 5760 x 1080.
The problem I have is that I've lost TCE on screen, once it is fully loaded and can't see it. I've only realised this as I've fired it up after being out exploring for a long time. The usual border-less gameplay is in effect so is there something I can do in the config file?
I can get through the other popups and progress bar, it's just the final display screen that I can't find. I can see it there with alt-tab and windows-tab but it's not on the physical screen from what I can tell. Any ideas?

<TCE_Settings
TCE_Version="1.8.1.4"
DB_Version="1"
Status="True"
TCE_Language="0"
Primary_Color="-32768"
Secondary_Color="-12574708"
NavColor_Visited="-256"
NavColor_Scanned="-11179217"
NavColor_Explored="-16751616"
Font="Eurostile-Normal"
Backup="True"
SoundFX="True"
Volume="8"
Text2Speech="False"
MultiMonitor="False"
MonitorID="0"
LastRescanJournal=""
TCE_Launch_Completed="True"
StarScanModifier="0.7"
PlanetScanModifier="0.7"
 
Hello, I've managed to introduce a problem all by myself.
I've gone from three monitors, acting as three different monitors, to 3 of them acting as one, so with a resolution of 5760 x 1080.
The problem I have is that I've lost TCE on screen, once it is fully loaded and can't see it. I've only realised this as I've fired it up after being out exploring for a long time. The usual border-less gameplay is in effect so is there something I can do in the config file?
I can get through the other popups and progress bar, it's just the final display screen that I can't find. I can see it there with alt-tab and windows-tab but it's not on the physical screen from what I can tell. Any ideas?
You should reset the Panel.db database, where all coordinates and sizes of panels is stored.
Enter the Database tab at the launcher, make sure the file is selected only and hit the Default button at the top.
 
You should reset the Panel.db database, where all coordinates and sizes of panels is stored.
Enter the Database tab at the launcher, make sure the file is selected only and hit the Default button at the top.
Nice one Thank you, did the trick while not in game so should be fine when I start.
 
HI Eventure
I've moved to a new computer. Can you tell me what I should copy over from my old machine?
Thanks
I recommend to install the actual version at your new PC and transfer your old installation with the build-in function (Database tab) of the launcher.
Don't copy/paste anything into the new installation, because the path strings at the TCE.config file could be wrong afterwards.
 
I recommend to install the actual version at your new PC and transfer your old installation with the build-in function (Database tab) of the launcher.
Don't copy/paste anything into the new installation, because the path strings at the TCE.config file could be wrong afterwards.
As always thanks for you prompt help. I will have to link up my old computer and then copy the required files to a external drive. Can you tell me what files I need to copy to that and then I think I should be ok importing them
thanks
 
So I followed the thread on Reddit to try and make this work in my oculus rift S headset. I managed to get it set up, but it displays it as 4 or 5 different "apps/windows." The program that inserts the image into the VR environment only allows you to project 1 window. It also has odd colored boxes in the areas where the black defined boxes are not in each of them. The areas in the windows where the black text boxes are not don't appear "see-through" as it does on a monitor, there are solid colors filling the rest of the window. Would it be possible in future patches to get all the on-screen elements, cargo box, info box, etc, combined into a single entity? Also if something could be done to remove the colored area behind the text boxes so shows the game image there like on my monitor hat would be awesome too. (I would add screenshots to better demonstrate this but I've only had my Oculus for 3 days and don't know how to do that yet, lols.)
 
Top Bottom