"update required" bug

I re-installed Elite Dangerous after a few years and after logging in everytime I open the launcher it goes to the "update required" pop up and then closing. I've read through some of the solutions posted here and elsewhere of setting updates to high priority and rebooting Steam which has not resolved the issue. any assistance would be appreciated.
 
That’s right yeah. That is how I start all my games on Steam.

I was referring to the fact that some people say that right-clicking in the library and selecting play there overcomes this issue. (I have never experienced it, just passing-on info):

steam play.jpg


Personally, I use a desktop shortcut (adding of which is shown) which has always worked-out for me.

Good luck
 
great I have been able to launch the game. thanks, now it is saying I need to redeem my purchase ...I have the game in my steam library.

askdjlfhnkwejuu!
 
I have already done that. I have raised a support ticket with Frontier. I think there migh be a back end issue.
 
great I have been able to launch the game. thanks, now it is saying I need to redeem my purchase ...I have the game in my steam library.

askdjlfhnkwejuu!

Well at least that is a known issue for which there is a FAQ on the site, where said FAQ has an issue of its own. Good luck..

 
Top Bottom