Release v1.2.0 elgato stream deck button plugin for elite dangerous

yeah set it up based on the choose file button. I have a toggle set for cargo scoop and same thing, it only displays whatever option is on the off image, but it does do the actions ingame
1635268159998.png
 
yeah set it via the choose gile buttons on the left and the ight. I have it cargo scoop and lights set up and both do what they are supposed to do but the image doesnt change, just stays on the off image.

1635268490600.png
 
Then I don't know what the problem is? Are there any errors in the log file? Did you restart streamdeck.exe?

can you post your streamdeck .profile file here
also the on/off images
and also the status json file from the game journal directory
 
ok sorry about this!! attached what i can find - it wont let me upload the streamdeck profile or status/.son
 

Attachments

  • cargo-scoop-active.png
    cargo-scoop-active.png
    1.7 KB · Views: 23
  • cargo-scoop-normal.png
    cargo-scoop-normal.png
    906 bytes · Views: 20
  • landing-gear-active.png
    landing-gear-active.png
    1.4 KB · Views: 17
  • landing-gear-normal.png
    landing-gear-normal.png
    684 bytes · Views: 19
  • ship-lights-active.png
    ship-lights-active.png
    1.3 KB · Views: 21
  • ship-lights-normal.png
    ship-lights-normal.png
    642 bytes · Views: 19
1)
please switch on the light, deploy the landing gear and cargo scoop, then copy C:\Users\xxx\Saved Games\Frontier Developments\Elite Dangerous\Status.json and post it here
2)
please export the profile in the streamdeck software and post it here :
VLJTIHM.png

3)
please post the plugin log file here
 
apologies! i think i have got it working now. I hadnt completed the tutorial, now that i have the buttons seem to be corresponding. Apologies, if i knew how to delete my dumb comments i would!
 
version 2.3.8

added toggle buttons:

FocusCommsPanel
FocusRadarPanel
FocusRightPanel
FocusLeftPanel

added static buttons:

HumanoidEmoteSlot1 (Point)
HumanoidEmoteSlot2 (Wave)
HumanoidEmoteSlot3 (Agree)
HumanoidEmoteSlot4 (Disagree)
HumanoidEmoteSlot5 (Go)
HumanoidEmoteSlot6 (Stop)
HumanoidEmoteSlot7 (Applaud)
HumanoidEmoteSlot8 (Salute)

you will first have to add keyboard bindings for these new odyssey buttons...
 
version 2.3.8

added toggle buttons:

FocusCommsPanel
FocusRadarPanel
FocusRightPanel
FocusLeftPanel

added static buttons:

HumanoidEmoteSlot1 (Point)
HumanoidEmoteSlot2 (Wave)
HumanoidEmoteSlot3 (Agree)
HumanoidEmoteSlot4 (Disagree)
HumanoidEmoteSlot5 (Go)
HumanoidEmoteSlot6 (Stop)
HumanoidEmoteSlot7 (Applaud)
HumanoidEmoteSlot8 (Salute)

you will first have to add keyboard bindings for these new odyssey buttons...
Hello and thanks for the update.

I have a request\suggestion for the future.

Would it be possible for next update to make it possible to set different custom sounds play when you toggle a command on or off? For example I am doing computer generated voices saying "FSS Activated" and "FSS Deactivated" etc.... For now it makes sense only for single state buttons like "Thrusters 75%"

Thanks for the great work
 
Hi,
I looked into it, but with the current plugin architecture that is not possible.
the sound is currently linked to the button press event.
The game state monitoring is a separate thing.
And the sound would have to play from the game state monitor instead.
I don't have time right now, to change the plugin.

Maybe you can look into voice attack ?
I believe that there are some projects on this forum, that would do what you want...
 
Last edited:
I have nothing to add to my previous comment.
Ok, I'm not a developer so I don't know the pros & cons of having a plugin listed with Elgato.

I only mention it because it is so much easier to update a plugin from within the new store.

If you don't want to go through the process of having it listed then I'm just happy to have your great plugin.

Thanks for your updates and work.
 
Oh well got an minor but important issue-ish.

gif won't work when use as ON image and OFF imagine in your plugin....

made a set of simple ED style gif and found out it won't animated, it seems it can only use the first frame of the gif as a static picture for some reason.

Is there any possible fix on this? Many thanks!
Not sure if this was covered somewhere else, but you can use a (stream deck) multi action switch to achieve that. Just drop in the static switch and put the gif in for the icon for each state
 
Animated gifs are only supported for static buttons. This is a limitation of the streamdeck sdk
got it, just saying you can use the default multi-action switch from the streamdeck plugin(not from your plugin) and drop in your static button in the action sequence. then use gifs
 
Hi mhwlng,
Do you have any ideas why the Streamdeck isn't returning to my default profile when I exit Elite?
I've ensured that the main StreamDeck program window is closed and not just minimised.
It's a little odd as the default profile returns ok when I close other games and apps that I've setup with hotkeys etc on the Streamdeck.
Thanks.
 
Top Bottom