Hi @tennek ,

Aussiedroid uses MFG Crosswind rudder pedals and has a binding file to suit.
The latest version of the script can be found on his Github link...use 'master' drop-down (near top of page) and select 'odyssey'.

Hope this helps.
Not sure what my problem is I have read through this thread and have not found a resolution to my problem. I was using the profile for a year and recently I was looking into using some of the other functions I haven't used in the past (boost, galaxy map, system map from the warthog throttle). I do have voice attack with some of the HCS Voice Packs so I was able to do most things that way. When I was doing some combat missions, I tried to use the boost on the front of the throttle. It did not work I am able to use the tab key on the keyboard and the voice commands successfully. I have downloaded the latest version of Aussiedroid script. I ran it through the latest version of the target script editor. I have never done any coding so I am at a loss of what may be wrong or where to start. I would appreciate any help available.
Hi @tennek ,

Can I assume you also copied the appropriate binds files from the '...\ED Bindings\WITH MFG Crosswinds' folder and selected the correct controls profile in game when starting?
(ie "Aussiedroid Warthog Enhanced 5.0.0")

Next, check the binds folder and make sure you don't have a bunch of other unused binds files in there.

I've not tested Aussiedroids v5.0.0 script with HCSVoicepacks, so when I get a chance, I'll load it up and check.

So I downloaded it and tried it I still am not able to use other commands, using the event tester when I push any button on the HOTAS nothing appears
Hi @tennek

Looks like a Windows USB or TARGET driver issue.

Can you post a link to a screen grab of the Target Console after running the script (before you load the game), please.

Last edited:
Hi @tennek ,

You are not running the Aussiedroid Script.

When launched, you'll get the same printout as you've posted PLUS you should see something like this directly after the "Connecting virtual mouse..." message.

@tennek ,

Best place to start, open the script editor, then open AD_ED_v5.0.0.tmc and compile...

Then, make sure you update the userprefs file etc first, then...
(especially ensuring the pathname to status.json is set correctly)

Compile and run to ensure no errors.
Fire up Elite Dangerous and everything should work (he says with fingers crossed!)

I'm in the process of getting a friend to use this and it will be his first use of TARGET. I have a question about version 4.3.0 (I know that those do what he needs at this point). I did a QUICK scan of the documentation but didn't see an answer.

To run this script, does it matter what version the firmware of the joystick or throttle is. His is V11 were v12 is the latest.
I don't think this has anything to do with the script, but a friend is getting an error when he tries to load the script. Now, this is the first time he has used TARGET, so there is no other bases to compare to.

When he runs the script through "RUN" in the TRARGET GUI it starts but then he gets an error that states "... cannot associate a filter with ... ...VID... ... 0404..." . THis is associated with the throttle. Any idea why he is getting this or a possible resolution.


UPDATE: He unplugged the stick and throttle, plugged them back into the same USP ports and they work (at least for now). I've seen this before with the Warthog.
Last edited:
I wanted to express my thanks for all the work folks have done on this.
I also have a question regarding the Target Script Editor. Does anyone know how to change the text colour for the URL links? In my case it is dark blue on black and unreadable. I can change the colour for other things in options but not the URLs and I cannot seem to change the editors background either.
Hi @Irakandjii ,

Seems you've found where to change colours via the Options, but that has not helped you.
My only advice would be to use Notepad++ as your main editor, then load into the TARGET editor to compile/run.

Top Bottom