Release Elite G19s Companion app (with simulated space traffic control)

Hi!
Feel free to use the picture, I made it for you anyway :)

Concerning edge & admin request, please add an option to not install it, or why not offer the use of other browsers?
It's a little annoying to have to install your app in a sandbox to prevent edge from installing ...

Edit: I've noticed another bug, I'm using a script to start a few apps before ED including Elite G19s, and it forces opens on keyboard and in a little window so I can select radio station by mouse before starting game. It works fine but the opened windows get closed automatically as soon as I get game on fullscreen. I didn't see any crash, no other issue than window closing. but I have to reopen it each time.
I've had this issue on 3.6 too though ...
 
Last edited:
Hi Guys,
i have a problem... maybe small, but i can't get the applett run...

Setup Windows yesterday from zero... so only drivers, E:D, edmc and G19-Applett installed 'till now.
Applett is showing up and running fine, but only on screen, not on my G19-Screen... where's the mistake?
Is there anything i missed to set?

Thanks
NemWar
 
Indeed. Thanks for the info TheMindBuddah and thanks for the great work MagicMau!!!
Hi Guys,
i have a problem... maybe small, but i can't get the applett run...

Setup Windows yesterday from zero... so only drivers, E:D, edmc and G19-Applett installed 'till now.
Applett is showing up and running fine, but only on screen, not on my G19-Screen... where's the mistake?
Is there anything i missed to set?

Thanks
NemWar
Just to confirm what you've said - I've had the same thing for quite a while too butt mine was intentional as I use performance monitors on my g19 screen. I cut down the apps on my keyboard and use Elite G19s Companion on a separate screen - a 10" tablet connected via usb and acting as a monitor with an app "Twomon SE".

Maybe check out your Logitech Gaming software in the tab 'Customise LCD Display' to see if the app's disabled there like mine is.

Good luck
 
t9QC3ei.jpg
What is it you have on the left screen there? Is that from G19s? I've never seen it before but it looks fun!
 
Hmmm, yes, it should be in there. You're running a slightly newer version than me, mine is 9.00 but either way it should work.

I can only really suggest the old fashioned method of uninstallation, reinstalling and see if that does the job.

If that doesn't work, please post back here as someone else may have had the same thing happen in the past and/or maybe able to help o7. Best of luck with your new win build
 
It's not even listed as Applet... maybe that's the fault?
Logitech Gaming Software Version 9.02.65
Hi NemWar. Sometimes reinstalling the LGS software seems to help (don't ask me why). The version of LGS is the same I use, so that can't be it. Otherwise, can you please turn on verbose logging and email or PM me the EliteG19s' log file? Maybe that will give a clue why it's not connecting. Details for that here: https://apps.magicmau.nl/EliteG19s/Docs/EliteG19s-Manual.html#send-log-files
 
greetings o7 thank you for improving your app over the years, i was wondering if its possiable to intergrated a video player similar to the local music feature?
 
I managed to get the G19 Applett to work again.

Hint was given by MagicMau's Manual / Troubleshooting itself....

the 32 bit version of the C++ 2012 redistributables wasn't installed (i installed the 64 bit version too).

After that the Appletts pops up in list and i an start it now.
 
hi, i try for the first time your app on my second screen. It work pretty well, just i have crash when i try to open the current window option (option-->visuals-->current window) (no error message, just a crash). I can use the app, it's just a bit anoying. I have all request stuff install. Thanks for your work ;).
 
hi, i try for the first time your app on my second screen. It work pretty well, just i have crash when i try to open the current window option (option-->visuals-->current window) (no error message, just a crash). I can use the app, it's just a bit anoying. I have all request stuff install. Thanks for your work ;).

Same here :)
 
hi, i try for the first time your app on my second screen. It work pretty well, just i have crash when i try to open the current window option (option-->visuals-->current window) (no error message, just a crash). I can use the app, it's just a bit anoying. I have all request stuff install. Thanks for your work ;).

Thanks for the feedback! I will look into this, it's definitely not meant to crash like that.
 
Top Bottom