How to install ED on Linux using Wine [EXPERIMENTAL, NOT OFFICIALLY SUPPORTED]

my GPU is a GTX660-ti - normally it's fine with this game in windows.. I can appreciate a little drop through the compatibility layer and I'd play at 30-40 fps as that's fine for pve and exploration but 10fps is a litttle low
 
Can you use past Nvidia 418.56? Aren't those the latest linux drivers. I'm not sure which ones work or not. Is that the fps problem? I've never tried past what the nvidia tool spits out at me.

NVM, types too slow.
 
I get 30+ fps in the 418 drivers however I have the issue of fuzzy text on the desktop which h append with the 390 drivers but went away with the 396 and 418 previously.. I guess it will go agway again .. the internet seems to not know why it happens.
 
my GPU is a GTX660-ti - normally it's fine with this game in windows.. I can appreciate a little drop through the compatibility layer and I'd play at 30-40 fps as that's fine for pve and exploration but 10fps is a litttle low
430 driver should be fine however note the 660ti just barely hits the minimum requirements for Vulkan (which dxvk translates dx11 to). Newer generations of GPU have had more advancements in handling newer API like DX12 or Vulkan where as older ones have just had the support to get them running with them and I think this can definitely affect the translation process.

10 fps does seem a little low though, two things to try:

1/ Is your CPU scaling governor in Linux set to performance? There are plenty of guides to do this dependent on the distro you're using, in Manjaro I personally use an extension for Gnome called cpufreq in order to do this for me.

2/ With Proton you should be running dxvk included with proton, you can verify this by putting DXVK_HUD=1 %command% into the steam launch options. If you see a HUD appear on screen with an fps counter this confirms DXVK is working as intended.

If not try PROTON_USE_WINED3D=0 %command% in the launch options see if that's an issue or try below to install DXVK from terminal directly to the prefix:

WINEPREFIX=~/.steam/steam/steamapps/compatdata/359320/pfx winetricks dxvk
 
I've switched my cpu to performance using indicator-cpufreq, Vulkan appears to be working perfectly

I'm getting 27-40 fps on the ground and 40-70 fps in space.. it's good enough for the moment.

I realise my pc is a bit long in the tooth these days. I plan to have a VR setup before next Xmass
 
Well, the game is just playable.. It quite acceptable for exploration. I wouldn't want to pvp in it.. I should be ok for PVE.. Fixed the crash by running in borderless window at native resolution for my monitor.

Running in a smaller window reduces framerate.

I'm going to copy my control schema over from my windows install now. Thankyou so much for your help. I never thought I'd see this game running in Linux for me.
 
the game does not like being alt-tabbed though.. crashes every time.
Did you ever not have that problem? That is my current problem and I'm trying to figure it out. From what I can tell it's when my vram is maxed out, which it keep doing, and you alt tab and try to alt tab back in and crashes. It's the alt tabbing in that does it for me. Although some times it takes a while to crash and refuses to alt tab in.

There was a version of wine that low setting allowed me to avoid this where it did not fill the vram(vram stayed at 70-85% usage). It was something like winehq-Staging 4.5.2. I tried to revert but it gave me 4.5.3 and the problem was present again. I'm not sure if it's wine the game the hardware or a combo. But I know it changes characteristics potentially with wine versions.

The version that didn't have vram issue and alt tab crashing also had like 90-120 fps at all times. It was very efficient somehow. But then it went away with later versions. I would love to see that return. Hopefully it was good code and not bad code just removing visual thing being processed. Although I would take that also at this point.

BTW, as long as the VRAm for me stays below 99%-100% I can alt tab all I want. But wine or something keeps maxing it out regardless of settings.
 
Last edited:
Did you ever not have that problem? That is my current problem and I'm trying to figure it out. From what I can tell it's when my vram is maxed out, which it keep doing, and you alt tab and try to alt tab back in and crashes. It's the alt tabbing in that does it for me. Although some times it takes a while to crash and refuses to alt tab in.

There was a version of wine that low setting allowed me to avoid this where it did not fill the vram. It was something like 4.5.2. I tried to revert but it gave me 4.5.3 and the problem was present again. I'm not sure if it's wine the game the hardware or a combo.

The version that didn't have vram issue and alt tab crashing also had like 90-120 fps at all times. It was very efficient somehow. But then it went away with later versions. I would love to see that return. Hopefully it was good code and not bad code just removing visual thing being processed. Although I would take that also at this point.
my work around is to run the game in a full screen window. I use dual monitors so although the game insists on being on top on my main monitor I can still ( with fore thought ) open up a console and a browser window on the second monitor.
 
That got me thinking. One other thing I did aroudn that time (probably after) was set it to better performance. So, I just set it back to high quality and I can get it to hover at around 94-97% in station. It will probably fill after leaving the station the first time, but I can alt tab all I want atm. Some setting might not do what they should atm and there might be ways to get it to act nicer.

Still playing around with settings.

Exiting the station and leaving the instance and returning maxed it out sadly. Is it possible it's not letting go of things? Maybe info from ships leaving and exiting a station.

BTW, 1060 3gb. If it helps explain anything. (Wishing I had gotten the 6gb.)

Another problem is that alt tabbing, and other actions sometimes, can cause the mouse to get stuck in a tiny sqaure. This can be resolve by alt tabbing, without letting go of alt, and cycling back to the ED program without alt tabbing out of it. This will resolve that but then cause the alt button to be stuck(I'm pretty sure logically, not physically, unless I'm mistaken.). Press alt to unstick it. I have custom keybinds but I hit alt and hit "R," which is max throttle for me and correctional rotation depending on the key combo. It help show if it's unstuck.
 
Last edited:
Been running with Linux for a while now, using the great work from https://github.com/redmcg/wine/wiki on a custom install of Fedora. Seen a few graphics glitches from time to time (and some of them have been seen on windows systems too, so I've not spent any time properly investigating). But, this glitch was just too pretty for me not to share, almost sorry to reboot and correct it.

https://steamuserimages-a.akamaihd.net/ugc/786352494211862768/6E163D25F7ADF98054BA466BB888A44BD73B0F1B/
What drivers you using? From my testing there's only one graphics corruption glitch I've seen, and this happens when DXVK is used on Windows too so it's either a DXVK issue or a problem with Nvidia's Vulkan implementation:

 
Top Bottom