Release Trade Computer Extension Mk.II

I'm a bit confused on the "Data Age of Prices" setting in the launcher.

If I set it to 1-Day and then request to Update Trade Stations, can someone please tell me which of the following scenarios is correct?

A) All of my stations which are older than 1-Day are updated with whatever EDDB has.
B) All of my stations which are older than 1-Day are updated with EDDB information if EDDB is newer.
C) All of my stations which have updates on EDDB within the last 1-Day are updated.
D) Another option I've failed to describe.

Thank you.
Really Good question. It is something I have never fully understood either.
 
I'm pretty sure that data age of prices means which data from EDDB it imports. If you use EDDB, you know that the data for prices on the site always tells you how recently the data that EDDB has available was updated so if you use Data Age of Prices of 7 days, then the only EDDB data that is imported will be that which is 7 days old or newer.

I cannot speak to how it handles overwriting if you have newer data on your end because I never have data that is newer than EDDB. I use EDMC so whenever I get new data on my end EDDB gets it too (in other words, it's not possible for me to have newer data locally).
 
Hi Eventure. I have a couple of things I would like to pass on here.

Firstly I would like to say thanks for your continued support of the TCE. In my mind it is an essential tool for playing ED.

Secondly I seem to be having a little problem when I use the FSS. When I activate the FSS the TCE disappears as if it is an interception, which is good, but then does not reappear when I exit the FSS. I need to then press my show / hide TCE button to get the TCE to reappear. I currently have keysettings as;
Enter FSS = F2;
Exit FSS = F3; and
TCE show / hide Interface = F9.
Please send me a Journal log from the session, so I can try to recreate the issue, you had.

I'm a bit confused on the "Data Age of Prices" setting in the launcher.

If I set it to 1-Day and then request to Update Trade Stations, can someone please tell me which of the following scenarios is correct?

A) All of my stations which are older than 1-Day are updated with whatever EDDB has.
B) All of my stations which are older than 1-Day are updated with EDDB information if EDDB is newer.
C) All of my stations which have updates on EDDB within the last 1-Day are updated.
D) Another option I've failed to describe.

Thank you.
Really Good question. It is something I have never fully understood either.
The parameter comes into action, when TCE compares the update timestamp (date & time) from your database with the EDDB for a particular station.

Let's create an example to show, how it works.
There are three stations (A, B and C) in your database. Station A got the last update of prices at the 1. May, station B at the 3. May and C at the 5. May.
You have selected a data age of one (1 day) and hit the update button.

Now, Station A, B and C got checked against the timestamp of EDDB for that stations. The last price update for all stations was the 4. May for example.
TCE will now update station A and B. Station C is excluded, because it has a newer timestamp in your database actually.

Changing the parameter to '2 day' will result in an update of station A and probably B, if the time of day is older than of EDDB.

My suggestion is to set this parameter to 'Actual' to have the newest price data available from EDDB.
But keep in mind, all data are coming from the EDDB nightly dump at about 6 o'clock in the morning.
 
For the purpose of the log I activated TCE, flew to a system I hadn't been to before and entered the FSS. When I entered the FSS after about 4 seconds TCE automatically hid. I did some scanning and exited the FSS and then just flew around in the system for about 5 minutes. TCE did not automatically reappear during this time.

If you need me to do some more recreations please let me know and thanks in advance for looking at this. It is not a major problem, just a minor inconvenience.
 

Attachments

For the purpose of the log I activated TCE, flew to a system I hadn't been to before and entered the FSS. When I entered the FSS after about 4 seconds TCE automatically hid. I did some scanning and exited the FSS and then just flew around in the system for about 5 minutes. TCE did not automatically reappear during this time.

If you need me to do some more recreations please let me know and thanks in advance for looking at this. It is not a major problem, just a minor inconvenience.
Thanks, found the issue and it will be fixed in the next update.(y)
 
Version [1.7.6.5] released
Changelog:
  • Added over 300 russian language phrases to database and updated some others.
  • Fixed an issue, where the hidden UI in a FSS scan didn't reappear when exiting the mode.
  • Fixed an error with a wrong initial dimension of the trade station array, if the registered market database was empty before.
Notes:
Either download the version above, install and transfer your old database, or use the auto-update function of the launcher.
Click the 'new version' notice at the bottom of the launcher.

If you find an error, please report and use the Report a Bug button at the launcher and don't forget to copy the error details and ErrorReportFile.7z archive.

I like to remind any user, who wants to use TCE in french, spanish or russian to help in translating the
latest interface phrases, common commodities and rare commodities at OneSky. Thanks in advance.
 
I keep getting EVENT ERROR windows appearing in the background with the same basic error "Index was outside the bounds of the array", following an "FSDJump" event. I just emailed in a bug report but in this window I just noticed it makes reference to a lot of issues with TCE code at an F:\ drive. I don't have an F:\ drive on my system. Is that what's causing the error?
 
Version [1.7.6.6] released
Changelog:
  • Added some missing russian language phrases to database.
  • Fixed a rare error when checking waypoints on deep space explorations.
  • Fixed a rare error with the processing of available station outfittings.
  • Fixed a display issue of the influence and reputation icon at the Mission panel.
  • Fixed a recognition issue with the 'Missions' event, when TCE get launched later on.
Notes:
Either download the version above, install and transfer your old database, or use the auto-update function of the launcher.
Click the 'new version' notice at the bottom of the launcher.

If you find an error, please report and use the Report a Bug button at the launcher and don't forget to copy the error details and ErrorReportFile.7z archive.

I like to remind any user, who wants to use TCE in french, spanish or russian to help in translating the
latest interface phrases, common commodities and rare commodities at OneSky. Thanks in advance.
 
I keep getting EVENT ERROR windows appearing in the background with the same basic error "Index was outside the bounds of the array", following an "FSDJump" event. I just emailed in a bug report but in this window I just noticed it makes reference to a lot of issues with TCE code at an F:\ drive. I don't have an F:\ drive on my system. Is that what's causing the error?
Thanks for your report, found the issues and fixed them with the update above.
The F-drive notice is my development drive, so the message points me to the file, which causing the error. ❕
 
d/l today, in d/TCE, used the shortcut on desktop, get login screen, hit log in, then I get error msg, error reading table, no such table for Public_duplicates, Public_loc_rares, public materials, Public_powers, and 2 tables outside the realms of array, Outfit types index, and markets UR index. Alos started TCE after I logged on ED. Keeps saying loading but never does anything else Any help would be appreciated
 
d/l today, in d/TCE, used the shortcut on desktop, get login screen, hit log in, then I get error msg, error reading table, no such table for Public_duplicates, Public_loc_rares, public materials, Public_powers, and 2 tables outside the realms of array, Outfit types index, and markets UR index. Alos started TCE after I logged on ED. Keeps saying loading but never does anything else Any help would be appreciated
Did you installed the actual version into the folder of an older version of TCE? If so, please rename/remove the old version folder and install the actual version into a new folder.
 
no old file, deleted what I had done, put the msi file into c:/TCE, double clicked from there, setup niceley, followed onscreen instructions, seems to be working fine now. Thanks :)
 
@Inner)*(Silence, the Only way I know of to remove the "remove hud" message is to also stop the planet scanned messages in Options->Event Reporter, by unchecking "scan". I did that because the remove hud message annoys me...and doesn't even indicate the correct key binds for me.
 
Top Bottom