Amazingly Realistic Immersion Mod

Hi LSDMT, while I am not a programmer you could try and assign F4 as an example and see if that works. Open the d3dx.ini file and near the top is "VK_F1" so you could try changing that and see if it works "VK_F4". Good luck.
 
Hi LSDMT, while I am not a programmer you could try and assign F4 as an example and see if that works. Open the d3dx.ini file and near the top is "VK_F1" so you could try changing that and see if it works "VK_F4". Good luck.
i have tried that. used F4, used SPACE. if i change F2 and F3 to F4 or SPACE - they still work. it's just F1. i have tried EVERYTHING i can think of:

  • clean reinstalls
  • using just the original OD d3dx.ini file and not changing anything else
  • making sure F1 isn't being used by anything else (Voice Attack, accidental key bind to something else, etc). heck - i even modified Win10 to stop using F1 as it's help button. so F1 is completely free and in the clear - it's just that it doesn't turn off my HUD. F2 and F3 turn off their respective lights but F1 eludes me. other people are recently reporting issues with their HUD too. i wish i could get it fixed because i'd really like the option to turn it off sometimes.

all of the other mods seem to work perfectly (except for the scratches in the canopy which i can only remove if i get the F1 issue fixed). my next step is to try to implement the shaders that OD posted but i'd like to get these other issues resolved first before i go modding it further (lens flare and F1/HUD not working).

-

thanks for replying and trying to help, /u/amcb10. it is much appreciated.
 
Out of interest does F1 work if you map the F2 to it? You don't have a macro bound to F1 do you, sorry I am clutching at straws here but it seems weird that F1 seems to say NO.

If F1 does work when you assign F2 to F1 then it must be something else in the shaders or override file that is not allowing the shader to be applied.
 
hmm :unsure:

that's a good idea. i don't know that i tried that but i will when i get home from work. i know for a fact there is no macro tied to F1. i double-checked everything and even checked the Razer software - it's empty.

i have a very nice computer and i can say that the F1 key does work (it used to bring up Windows 10 help center or whatever. i'm more of a Mac guy but i know my way around both systems). here is my computer (first PC i ever built):

Oculus PC Final

i built that computer exclusively for VR. i only play games on it. here is my VR cockpit:


i have since upgraded to the Rift S and will be upgrading to a full Virpil/VKB setup later this summer (although i do really like the CH stuff. built like a tank).

i like the fact that F2 and F3 turn off the lights/ambient lights. if only i could get the HUD to turn off too, lol.
 
Last edited:
i like the fact that F2 and F3 turn off the lights/ambient lights. if only i could get the HUD to turn off too, lol.
Forgive my naivety, but why not just map the HUD to a key that does work? F1 is "just a key", I picked it because it was there. You can chose any key at all (though I recommend not using an alphanumeric key). Perhaps the Tab key! Just make sure whatever key you pick isn't doubling as some function in ED itself (like F10).
 
Forgive my naivety, but why not just map the HUD to a key that does work? F1 is "just a key", I picked it because it was there. You can chose any key at all (though I recommend not using an alphanumeric key). Perhaps the Tab key! Just make sure whatever key you pick isn't doubling as some function in ED itself (like F10).
no problem, OD. a few posts up i said i tried that:
i have tried that. used F4, used SPACE. if i change F2 and F3 to F4 or SPACE - they still work. it's just F1. i have tried EVERYTHING i can think of.
so - i tried to map F1 to other keys. it's not that the F1 key doesn't work - it's that the HUD doesn't turn on and off no matter what key i bind it to. the lights/functions of F2 and F3 work and toggle like they are supposed to. but the HUD will not toggle regardless of what i have it set to. and i am using the code you provided. if i were at home i would post the file. but i even tried the file you posted in the first thread with no modifications made to it and F1 still won't toggle the HUD. so it's the HUD code for me on my computer apparently 🤷‍♂️
 
Last edited:
Thanks - got that to work OK.

As a way of thanks: please find attached a little shader fix I have made: you can turn down the brightness of the Orbit Lines by altering the value // < < HERE
1.0 is full
0.0 is nothing

MP
You little beauty @Monkey Pants , this is brilliant. Been wanting to sort out the orbit lines for ages. This is far more "realistic" in terms of what a HUD might look like in a spaceship... thanks! :)

Any chance you know how to dial out the orange tint on the lines? I'd love these to be a blue or green!
 
Last edited:
HOLD UP EVERYONE. When I press F1 it does NOT get rid of the HUD. Just some lit space areas, the window marks and the target area of the HUD. Not the entire HUD itself. Which is how it's supposed to be, is it not?
Maybe CMDR LSDMT is working but not in the way he/you expect?

What I'm doing is looking at the code (I'm not a coder) and working out how things work, then experimenting. Which is what OLD DUCK is doing, and then passes on his knowledge. To my mind Ducky boy is being helpful and going beyond anything he needs to do. The rest of us should be happy and grateful that he's done so much in such a short period time and giving it away for nothing. Well, maybe a Fleet Carrier... But that's deserved, bless him.
 
so - i tried to map F1 to other keys. it's not that the F1 key doesn't work - it's that the HUD doesn't turn on and off no matter what key i bind it to.
AHHHHH!!!! See, I misunderstood. I thought the problem was your F1 key, not the HUD code. Well if it's the HUD code in the .ini file, then I might be of some assistance. First thing to do is manual change the global $hideHUD = 1 to 0 and back again (unfortunately you'll have to reload the game each time using the my default .ini) to see if that changes your HUD visibility. The "outside the cockpit" section of the HUD should be off when $hideHUD is set to 1 (thus hidden) and on when set to 0. This will tell me if it's the ShaderOverride section that's broken or the CommandList section.
 
HOLD UP EVERYONE. When I press F1 it does NOT get rid of the HUD. Just some lit space areas, the window marks and the target area of the HUD. Not the entire HUD itself. Which is how it's supposed to be, is it not?
Maybe CMDR LSDMT is working but not in the way he/you expect?
here is what i am specifically looking for: the scratches to disappear from the window when the light from a sun is directly shining on it. you can see from the screenshots that Old Duck has posted that the glass does, in fact, clear up when toggling the HUD using F1. it just doesn't work for me.

my carrier is parked next to a sun. i can go out, undock, and tell right away cuz there are whitish streaks all over my windows. it's not a game breaker or anything. but i will be departing for an extended exploration run after i get back up to 10 billion credits so within the next couple of weeks depending on when i can play.

if i could get this F1/HUD issue resolved, then i would try to modify the <LensFlare> that Old Duck spoke of a few posts back, then i would try to use the shaders he provided.

that's my game plan. just trying to get some help from you guys and i appreciate all the help i get. i'd be more than happy to PayPal someone who could resolve it.
 
HOLD UP EVERYONE. When I press F1 it does NOT get rid of the HUD. Just some lit space areas, the window marks and the target area of the HUD. Not the entire HUD itself. Which is how it's supposed to be, is it not?
The original d3dx file in OP gets rid of the Heads UP Display, not the Heads DOWN Display. It gets rid of everything augmented reality aid that appears outside the cockpit in VR (on the glass in 2D) - this includes circles and names around planets, targeting markers on ships, Tron planets (map effect), artificial horizon over planet surfaces, etc etc. It does not get rid of holographic displays inside the ship like radar, power distribution, target details, etc.

Now my latest d3dx.ini file, which I posted a page or two back, does indeed get rid of both HUD and HDD, by cycling through three modes when pressing F1 - Full HUD, Partial HUD (HDD), and No display at all (similar to CTRL-ALT-G except it also turns off ship lights).
 
AHHHHH!!!! See, I misunderstood. I thought the problem was your F1 key, not the HUD code. Well if it's the HUD code in the .ini file, then I might be of some assistance. First thing to do is manual change the global $hideHUD = 1 to 0 and back again (unfortunately you'll have to reload the game each time using the my default .ini) to see if that changes your HUD visibility. The "outside the cockpit" section of the HUD should be off when $hideHUD is set to 1 (thus hidden) and on when set to 0. This will tell me if it's the ShaderOverride section that's broken or the CommandList section.
THANK YOU SIR! i will try this when i get home tonight and let you know. maybe it will help others, too.

seriously - THANK YOU for trying to help me.
 
here is what i am specifically looking for: the scratches to disappear from the window when the light from a sun is directly shining on it.
But do the circles around planets disappear? While scratches and the glass-based HUD share the same shader, they are technically two different things. It is possible to see the glass in rare occasions despite the HUD shader being bypassed. This happens in my Dolphin because it runs cold, and the "chill" effect causes the glass to appear despite the HUD being turned off.
 
But do the circles around planets disappear? While scratches and the glass-based HUD share the same shader, they are technically two different things. It is possible to see the glass in rare occasions despite the HUD shader being bypassed. This happens in my Dolphin because it runs cold, and the "chill" effect causes the glass to appear despite the HUD being turned off.
i do not believe so, but i will triple check tonight.
 
i do not believe so, but i will triple check tonight.
I think they do ... otherwise we have a mystery (I love a good mystery)

Btw for me HUD = stupid circles, so that was the first thing I wanted and saw from OD's mods ... It is funny you are not sure about the circles, thus indicating you are probably looking for some other 'hud effect' first, and this could turn out to be all misunderstanding of what the mod F1 key does

The original d3dx.ini pretty much only does circles and TRON. Tron (mapping planet iirc) I guess you have not tested, and circles you are not sure.

I'm curious at your findings:)
 
Last edited:
You little beatuy @Monkey Pants , this is brilliant. Been wanting to sort out the orbit lines for ages. This is far more "realistic" in terms of what a HUD might look like in a spaceship... thanks! :)

Any chance you know how to dial out the orange tint on the lines? I'd love these to be a blue or green!
Thx - I will have a look when I am back in front of my PC

MP
 
I think they do ... otherwise we have a mystery (I love a good mystery)

Btw for me HUD = stupid circles, so that was the first thing I wanted and saw from OD's mods ... It is funny you are not sure about the circles, thus indicating you are probably looking for some other 'hud effect' first, and this could turn out to be all misunderstanding of what the mod F1 key does

The original d3dx.ini pretty much only does circles and TRON. Tron (mapping planet iirc) I guess you have not tested, and circles you are not sure.

I'm curious at your findings:)
ok, so i got home and hopped on. scratches on the glass are definitely there (in a Python). i'm parked in Swoilz as the 4xLTD hotspot is here. i flew to the closest planet. hitting F1 made no circles around the planet disappear. not the blue circles that show the gravity well around the planet nor the yellow/orange one that has the name of the planet. no lines disappear.

now - i had never scanned a planet and then hit F1 to see if the 'tron-effect' went away (and that's on me. i have always been more concerned with those stupid scratches on the glass). so i scanned the planet and can confirm that F1 DOES toggle the blue tron-effect on and off. but it does nothing else.

so, it appears as though at least that part of it works. i will now try the instructions that Old Duck told me to do a few posts up and see what that does..
 
First thing to do is manual change the global $hideHUD = 1 to 0 and back again (unfortunately you'll have to reload the game each time using the my default .ini) to see if that changes your HUD visibility. The "outside the cockpit" section of the HUD should be off when $hideHUD is set to 1 (thus hidden) and on when set to 0. This will tell me if it's the ShaderOverride section that's broken or the CommandList section.
well, looking at your .ini file i don't have a 'global $hideHUD'. in the first part of your .ini file it only has a 'global $showHUD':

[Constants]
global $showHUD = 0
global $showInteriorLights = 1
global $ambientLight = 0

[keyToggleHUD]
Key = VK_F1
run = CommandListToggleHud

[keyToggleLights]
Key = VK_F2
run = CommandListToggleLights

[keyToggleAmbientLight]
Key = VK_F3
run = CommandListToggleAmbientLight

[CommandListToggleHud]
$showHUD = 1 - $showHUD

[CommandListToggleLights]
$showInteriorLights = 1 - $showInteriorLights

[CommandListToggleAmbientLight]
$ambientLight = 1 - $ambientLight

(a bit further down it has):

; Remove all "outside" HUD elements - circles around planets, labels, etc. It makes looking out
; the window feel just like that. This can be toggled using the appropriate key.
; NOTE - two shaders affect this, 74a61bc54382d4d9 and e61a98e9d493cdea (the latter retains glass)
[ShaderOverrideCanopyHUD]
Hash=74a61bc54382d4d9
if $showHUD == 0
Handling=skip
endif

; Remove blue "TRON" mapped planet overlay. This will affect not only the window view, but the DSS.
[ShaderOverrideTronPlanets]
Hash=abb57399a1eaf6ce
if $showHUD == 0
Handling=skip
endif

------------------------------------------------------------------

i did a CTRL-F to find 'global $hideHUD' and that is not in this d3dx.ini file. so i will try the opposite of what you say and change the 'global $showHUD' from 1 to 0 and back again and see if that does anything..

[EDIT] nope, that just reversed the tron-effect from being default on to off but other than that - no changes. nothing else on the HUD changes. certainly nothing to do with circles around planets or the window being free from scratches.

i have attached my d3dx.ini file as a text file if anyone would like to look at it.
 

Attachments

Last edited:
Hi, unless I’m not following what you’re saying, it sounds like you might be using the original ini file from post #1. The additional steps for total hud removal are from page 31 on Post #614. This is why you can’t find that ‘global’ code you mention above, it only exists in the revised .ini from post #614.

The #614 post has an evolved set of code/commands that adds a few different things, one of which is total hud removal (and this is the feature some of us can’t get to work for some reason). Total hud removal does not feature in the .ini code from post #1.

The ‘tron’ lines removal gets rid of the big 3/4 circle and star / planet name around your selected target. These are not to be confused with the planetary orbit lines and planet horizon lines, which are a feature you can find in the Elite Controls menu as a toggle on/off (I assign it to a stick button) called Orbital Lines (or similar).
 
Top Bottom