Request for more than 32 buttons (Virpil throttle)

Is there any chance that an update would get rid of the DX6 limit of 32 buttons per controller? Having just received a Virpil throttle, this needs 48. More people are likely to hit this problem.
 
Had a look at vJoy. It seems to concentrate on virtual joysticks and looks like it would need programming. It does not appear to notice my two actual devices. It's certainly not plug and play. I have been using an ancient copy of SV Mapper successfully but it is completely unsupported and could easily be wiped out by future operating system updates (Win 10)
 
What is the problem you have?

DirectX have a limit on 32 buttons per device, so I assume your device shows up as two separate devices. This should not be any problem for Elite to use both of these devices at the same time and assign functions to each of the buttons present on these devices. This is not a limit that FDev or any other game developer really can bypass, if they are using DirectX, then the limit is 32 buttons per device, until Microsoft decides to update the definition to support more than 32 buttons per device. If the device present itself as a keyboard, then we do not have the limit of 32 buttons.


I have a multi function panel with 50 buttons. I also have my throttle, joystick and pedals all matched up into 3 virtual devices by my controller software.
So to Elite, I have
CH Device 1 - 32 buttons
CH Device 2 - 32 buttons
CH Device 3 - 26 buttons

Elite has no problem finding these or use any of these 90 buttons I have available.



As long as your device shows up as DirectX devices, it should not matter if it is spread over 2 or more devices. Elite however is a bit dumb when it comes down to showing which device a button belongs too, so you most likely have two devices,. we call the A and B
A: 32 buttons
B: 16 buttons


For example, you assign A:button 1 to cargo hatch,
then you assign B:button 1 to landing gear

Now Elite will show that "button 1" is bound to both cargo hatch AND landing gear. Which might look very odd, but that is just how Elite shows it. And if you actually try to map A:button 1 to another function, it should alert you that it is already in use and if you go forward with the remap, the binding to cargo hatch will be cleared.




So what is the issue you are facing? It could also be that the driver software that comes with your device needs to be setup to present the throttle as DirectX devices, or that if it is loaded, does not by default present it as DirectX devices. I have the option to present any of my buttons as normal keys, like "j", "1", etc, instead of DirectX buttons.
 
Misty_dark, thanks for taking an interest. I think you slightly misunderstand the situation. The Virpil joystick has no driver or software. Just plug it in and Windows provides the driver. There is no equivalent of, for example the target software for the Warthog. The only software available is for configuration i.e. calibration and downloading firmware. I can’t configure the throttle to show up as two devices; there is no software. The throttle works fine in for example DCS world, which recognises all 48 buttons without any extra software, so the problem lies with Elite, not the joystick or operating system.
In elite all buttons above no. 32 are ignored.



From what I have read modern Windows is happy with up to 196 buttons. My understanding is that Elite uses DX6 standards that limit the buttons to 32 where they could use a more modern version without this low limit.


What software you using to convert your 50 buttons to three virtual devices? I am doing a simple version of this using SV mapper to convert my 48 buttons to 32 buttons plus 16 key presses. The problem is that SV mapper is very old and unsupported and could stop working at any time.


With Virpil nad VKB coming along with new controllers many people may be facing the same problem as me.
 
Oh, I had missed that they upped the limit, I am stuck with old controller software, that limit me to use 32 buttons per device.


I use CH Products so I use their "CH Control Manager" software to manage them.
 
Thanks for raising this. I'm having the exact same problem. While DCS and Prepar3D recognize all buttons, E:D only seems to recognize the first 32. I've opened a support ticket and went back and forth a few times, but the only advice I've got so far is to "update drivers" and "unplug everything except mouse and keyboard". Not very helpful and a bit disappointing. Especially when pointing out that it's working just fine with other software. Clearly a limitation in E:D from what I've seen so far. C'mon Frontier, give a fellow Cmdr a helping hand here.
 
Hey, I think I've found a nice workaround where you don't need to write any code: install the latest version of vJoy (sounds like you've already done it) create a virtual device using vjoyConfig with 32 buttons max (that's seems to be as many as Elite can see). Create additional virtual devices until you have enough buttons to cover your needs. Now download and install Joystick Gremlin. This awesome piece of software let's you map your physical buttons to the virtual devices. This is crazy to do in an interface, very intuitive and the software helps you along. Only issue I ran into that Joystick Gremlin won't launch anymore if I deselect the axis in my virtual devices in vjoyConfig. In this case just hit the reset button in vjoyConfig and adjust your settings. Save your profile once everything is set up in Joystick Gremlin and configure the software to automatically launch witch windows and launch with your profile. Joystick Gremlin needs to run in the background to work. Hope this helps.
 
Thanks Beezle, seems to work fine. We now have a backstop if SV mapper has problems.

Reading around the fuss about season 4 and withdrawal of the ice planets update, it occurs to me that maybe Frontier are planning to move to a more modern graphics standard. If they are it would solve this problem too.
 
Hi mikaz,
I’ve just taken delivery of my Virpil throttle, & am experiencing exactly the same binding issue.
Very annoying!
 
Damn you people... I was sooo happy with my Warthog setup (although, I've had a few issues) and you post a new controller I'd never heard of and now I want. That throttle looks sweet, much better (IMO) than the Warthog throttle's switch-heavy control set.
 
It really is a nice piece of kit.
It’s very well built.

My setup is now complete:
DX racer chair, Virpil MT-50 mongoos joystick, Virpil MT-50 throttle.
Both attached to the DX racer, using Monster Tech chair mounts.
 
Last edited:
I'm holding out for the Virpil Throttle with analog stick... Hopefully all this is well and truly sorted by then.

Z...
 
Could you share your JoyToKey profile?

Do you map the buttons in JoyToKey or in ED? Do you only Map the Axis in ED?

Sorry for all these questions.
Hi Kyreson,
Did you get the Joytokey sorted?
Any advice to can send my way would be much appreciated.
Really need to be able to map bindings to the buttons on my throttle, but like other people not all the buttons are visible for some odd reason.
 
Solution with Joystick Gremlin and vJoy

There still seems to be some interest in getting around the 32 button limit. I started this thread so here is what I ended up doing.


I used SVMapper to map the extra buttons to the number keypad. This worked OK but I had problems with switches T4-6 not working correctly and the possibility of the NUM LOCK key causing problems so I went for a solution that only uses game devices.


I now use ‘JoystickGremlin’ and ‘vJoy’. If you install just ‘JoystickGremlin’ and plug in your controllers you will see, in my case, a Virpil throttle and a joystick. You can set dead zones etc. The important part though is that if you install ‘vJoy’ as well you will see a new vJoy device as well as your actual controllers. You can then set that buttons numbered over 32 be sent to the vJoy device. Elite sees three controllers in this case, the joystick, throttle, and the vJoy device. Each of them has less than 32 buttons so all is OK. The default vJoy device has only 8 buttons so I increased this to 32 using ‘Configure vJoy’ and you can see the results outside Elite using ’JoyMonitor’. This works very dependably on all the buttons and switches and both bits of software are being actively maintained so Windows updates should be OK.


There are some problems. ‘JoystickGremlin’ is fussy about the setup of ‘vJoy’. It’s fine with the default device but when I made major changes to the vJoy device, Joystick Gremlin would not start. I have now left the vJoy device as standard except for changing the number of buttons to 32. This works fine. If anybody knows why this is the case I would be interested.


I now have all the new beta exploration bindings working and look forward to doing the same for mining tomorrow.[big grin]
 
It's too bad that this is still an issue. Got my throttle, plugged it in, awesome.. now why doesn't it work.

Turns out just to use it I need to install two other bits of software. Please Frontier.. fix this!
 
It's too bad that this is still an issue. Got my throttle, plugged it in, awesome.. now why doesn't it work.

Turns out just to use it I need to install two other bits of software. Please Frontier.. fix this!
^^^^^^^^This^^^^^^^^

Come on Frontier, this would be a great QOL fix.
It’s even more necessary, now there are lots more key binds.
 
Top Bottom