Unable to initialise network. Please check your connection

It's worth noting that for the Russian Speaking memebers answering on here it's very likely that your ISP does not work well with Amazon servers they are actually better off using a VPN as most of their ISP's have a block on said servers.
I suspected this as well. AWS is fussy about who trys funny business VPN spoofs
 
От основного провайдера идет только через VPN а это значит надо платить за VPN лишние 500 РУБЛЕЙ .Спасибо Разработчикам мне деньги не куда девать(((((((
 
Same problem here.

In the last few years (since the very beginning from premier) i used the same ISP and had no problem. Even when we transferred to the Steam. But, after the last content patch in tuesday, i cant play anymore. Or, at least barely - fortunatly, I have two ISP service at my home (One, for my family and one for my work).

When i connect with the regular ISP (type: cable, ISP name: MVM NET (a country sized local ISP in central Europe, i used this in the beginning)), i get a "unable to initialise network, check..." error after i hit the play button in the launcher. I can play every mmo and other online games, except the Elite

When i switch to another ISP (type: wifi, ISP name: DIGI (a region sized ISP in middle Europe)) everything is fine, and i can play.

Firewall is okay, firewall/security system's exceptions are okay, my system is okay, everything works fine. Reinstalled the game, checked the files integrity from the launcher, then from Steam, tried to launch with the .exe, etc., nothing helps, only when i switch to another internet connection

(sorry for my bad english, tried my best)
Finally, the lastest (today) patch solved my problem, now i can play again with using my primary isp.
Better later, than never!
 
Please try it now with the new patch. lost patience so deleted the game files (not the launcher) then installed via Steam.
You can get a steam key at the frontier store in the orders your games idontremember exactly google it :D
 
Last edited:
Hurray!, finally it worked, added the function of choosing a network adapter.
I'll try this myself once I have time. I totally uninstalled the game as I thought we'd be waiting into 2020. I'll report back once I've downloaded things again.


Edit: Yes I reinstalled all game files after uninstalling everything, fired up the game and after launching the game it took me to the in-game start screens. In options you can check your network info and other new things. I didn't take my ship out for a flight as I don't have time but the game works again.
 
Last edited:
After last update i cant connect using VPN on my connection (there was no problem before the update). If i disable VPN no problem, but this is not a solution!!
I couldn't connect from either account after the update. Seeing this comment, I disabled my VPN and connected. Not sure what they did that doesn't like a VPN, but I can deal with that. My Python halfway between the bubble and Colonia needs me :)
 
Game isn't able to establish connection to its servers since thursday update.
Checked my network settings, access to STUN server is fine.
STUN servers feeds game with 4 mission servers, but none of them is reacheable at all.
I checked that RKN isn't blocking ips of mission servers, all 4 of them.

I also opened a support ticket for my case, no responce there even though SLA is 72Hrs.
But who gives a damn about SLAs....
 
Top Bottom